aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-07-27 19:25:30 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-07-27 19:25:30 +0000
commit7df09b8e1349dba5426a5538dee3cbb5e1f50502 (patch)
tree4e8c1639f3d6f0c54a429826ddc26e7b2bf947d1 /dns
parent85062930a5005cb62ce7f91883241ce727ade773 (diff)
downloadports-7df09b8e1349dba5426a5538dee3cbb5e1f50502.tar.gz
ports-7df09b8e1349dba5426a5538dee3cbb5e1f50502.zip
- Add p5-IO-Async-Resolver-DNS 0.05
IO::Async::Resolver::DNS extends the IO::Async::Resolver class with extra methods and resolver functions to perform DNS-specific resolver lookups. It does not directly provide any methods or functions of its own. These functions are provided for performing DNS-specific lookups, to obtain MX or SRV records, for example. For regular name resolution, the usual getaddrinfo and getnameinfo methods on the standard IO::Async::Resolver should be used. WWW: http://search.cpan.org/dist/IO-Async-Resolver-DNS/
Notes
Notes: svn path=/head/; revision=393021
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/p5-IO-Async-Resolver-DNS/Makefile26
-rw-r--r--dns/p5-IO-Async-Resolver-DNS/distinfo2
-rw-r--r--dns/p5-IO-Async-Resolver-DNS/pkg-descr9
-rw-r--r--dns/p5-IO-Async-Resolver-DNS/pkg-plist4
5 files changed, 42 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 9709ecfa4c2e..404f34200194 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -109,6 +109,7 @@
SUBDIR += p5-DNS-Zone
SUBDIR += p5-DNS-ZoneParse
SUBDIR += p5-Data-Validate-Domain
+ SUBDIR += p5-IO-Async-Resolver-DNS
SUBDIR += p5-Mozilla-PublicSuffix
SUBDIR += p5-Net-Amazon-Route53
SUBDIR += p5-Net-Bonjour
diff --git a/dns/p5-IO-Async-Resolver-DNS/Makefile b/dns/p5-IO-Async-Resolver-DNS/Makefile
new file mode 100644
index 000000000000..d1ecb153972e
--- /dev/null
+++ b/dns/p5-IO-Async-Resolver-DNS/Makefile
@@ -0,0 +1,26 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= IO-Async-Resolver-DNS
+PORTVERSION= 0.05
+CATEGORIES= dns perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Resolve DNS queries using IO::Async
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Future>=0:${PORTSDIR}/devel/p5-Future \
+ p5-IO-Async>=0.52:${PORTSDIR}/devel/p5-IO-Async \
+ p5-List-UtilsBy>=0.07:${PORTSDIR}/devel/p5-List-UtilsBy \
+ p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+NO_ARCH= yes
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/dns/p5-IO-Async-Resolver-DNS/distinfo b/dns/p5-IO-Async-Resolver-DNS/distinfo
new file mode 100644
index 000000000000..91a02fb7c34a
--- /dev/null
+++ b/dns/p5-IO-Async-Resolver-DNS/distinfo
@@ -0,0 +1,2 @@
+SHA256 (IO-Async-Resolver-DNS-0.05.tar.gz) = 3831f0ce2209f1e3061da19724258b02ebb3734ef94195bc3507774d49281899
+SIZE (IO-Async-Resolver-DNS-0.05.tar.gz) = 17673
diff --git a/dns/p5-IO-Async-Resolver-DNS/pkg-descr b/dns/p5-IO-Async-Resolver-DNS/pkg-descr
new file mode 100644
index 000000000000..b20d706412f1
--- /dev/null
+++ b/dns/p5-IO-Async-Resolver-DNS/pkg-descr
@@ -0,0 +1,9 @@
+IO::Async::Resolver::DNS extends the IO::Async::Resolver class with extra
+methods and resolver functions to perform DNS-specific resolver lookups. It does
+not directly provide any methods or functions of its own.
+
+These functions are provided for performing DNS-specific lookups, to obtain MX
+or SRV records, for example. For regular name resolution, the usual getaddrinfo
+and getnameinfo methods on the standard IO::Async::Resolver should be used.
+
+WWW: http://search.cpan.org/dist/IO-Async-Resolver-DNS/
diff --git a/dns/p5-IO-Async-Resolver-DNS/pkg-plist b/dns/p5-IO-Async-Resolver-DNS/pkg-plist
new file mode 100644
index 000000000000..a4b94fe1b6ec
--- /dev/null
+++ b/dns/p5-IO-Async-Resolver-DNS/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/IO/Async/Resolver/DNS.pm
+%%SITE_PERL%%/IO/Async/Resolver/DNS/LibResolvImpl.pm
+%%SITE_PERL%%/IO/Async/Resolver/DNS/NetDNSImpl.pm
+%%PERL5_MAN3%%/IO::Async::Resolver::DNS.3.gz