aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-05 00:18:17 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-05 00:18:17 +0000
commit0921d535b33a33bbb698f65353c4afc0c2550fd2 (patch)
treeda0b11d1f6647d7844520efde1a8b3b41d1944f7 /dns
parentea1babb4f7fbc104f98dd5c092ad32fdc14a4d6d (diff)
downloadports-0921d535b33a33bbb698f65353c4afc0c2550fd2.tar.gz
ports-0921d535b33a33bbb698f65353c4afc0c2550fd2.zip
Remove NOPORTDOCS and NOPORTEXAMPLES from unstaged ports. Stage a couple while
we're here. Remove any other references to NOPORT*. Approved by: portmgr (blanket for modernization)
Notes
Notes: svn path=/head/; revision=360706
Diffstat (limited to 'dns')
-rw-r--r--dns/checkdns/Makefile7
-rw-r--r--dns/dhisd/Makefile9
-rw-r--r--dns/posadis/Makefile5
3 files changed, 17 insertions, 4 deletions
diff --git a/dns/checkdns/Makefile b/dns/checkdns/Makefile
index f8154487674e..8f9d5f1a5975 100644
--- a/dns/checkdns/Makefile
+++ b/dns/checkdns/Makefile
@@ -16,7 +16,12 @@ SUB_FILES= pkg-message
PORTDOCS= AUTHORS COPYING ChangeLog INSTALL README THANKS TODO
+OPTIONS_DEFINE= DOCS
+
NO_STAGE= yes
+
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/main.c \
${WRKSRC}/INSTALL ${WRKSRC}/README ${WRKSRC}/checkdns.conf-dist
@@ -27,7 +32,7 @@ post-install:
${CP} -p ${PREFIX}/etc/checkdns.conf-dist ${PREFIX}/etc/checkdns.conf ; \
fi
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_MAN} ${WRKSRC}/$f ${DOCSDIR}
diff --git a/dns/dhisd/Makefile b/dns/dhisd/Makefile
index 20f2f756ed50..92becfb16735 100644
--- a/dns/dhisd/Makefile
+++ b/dns/dhisd/Makefile
@@ -17,7 +17,12 @@ LDFLAGS+= -L${PREFIX}/lib
DOCFILES= CONTRIBUTORS COPYRIGHT INSTALL MODULES README
+OPTIONS_DEFINE= DOCS
+
NO_STAGE= yes
+
+.include <bsd.port.options.mk>
+
post-patch:
${CP} ${FILESDIR}/dhisd.sh ${WRKSRC}/dhisd.sh
cd ${WRKSRC} && ${REINPLACE_CMD} -e "s^__PREFIX__^${PREFIX}^g" \
@@ -46,7 +51,7 @@ post-install:
@${INSTALL_SCRIPT} -m 751 ${WRKSRC}/dhisd.sh ${PREFIX}/etc/rc.d/dhisd.sh
@${ECHO_CMD} "etc/rc.d/dhisd.sh" >> ${TMPPLIST}
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${ECHO_MSG} "===> Installing documentation in ${DOCSDIR}"
@${MKDIR} ${DOCSDIR}
@${CHMOD} 755 ${DOCSDIR}
@@ -63,7 +68,7 @@ post-install:
@${ECHO} ""
@${ECHO} "For more information, see the following site:"
@${ECHO} "http://www.dhis.org/dhis/r5/"
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${ECHO} ""
@${ECHO} "or the files in ${DOCSDIR}"
@${ECHO} "Read INSTALL and INSTALL.bsd at least for the setup information of dhisd."
diff --git a/dns/posadis/Makefile b/dns/posadis/Makefile
index 5b6d36d72526..3622c6c59f03 100644
--- a/dns/posadis/Makefile
+++ b/dns/posadis/Makefile
@@ -18,6 +18,9 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+.include <bsd.port.options.mk>
+
.if defined(WITH_FAM) || exists(${LOCALBASE}/lib/libfam.so)
CONFIGURE_ARGS= --enable-fam
BUILD_DEPENDS= ${LOCALBASE}/include/fam.h:${PORTSDIR}/devel/fam
@@ -34,7 +37,7 @@ MAN1= getzone.1 posadis.1 posadis-getroots.1 posask.1 poshost.1
MAN5= posadisrc.5
DOCS= AUTHORS ChangeLog README TODO
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}