aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2007-09-08 01:12:10 +0000
committerMark Linimon <linimon@FreeBSD.org>2007-09-08 01:12:10 +0000
commit9839011ec3910790376ce9ace5e2a1c5bcb2781f (patch)
tree41c61966bf1404bd3cfce06493a35d6a1a4acfc6 /dns
parent41a56135d1e8a68844e4c575702cdbad451d7322 (diff)
downloadports-9839011ec3910790376ce9ace5e2a1c5bcb2781f.tar.gz
ports-9839011ec3910790376ce9ace5e2a1c5bcb2781f.zip
Welcome bsd.perl.mk. Add support for constructs such as USE_PERL5=5.8.0+.
Drop support for antique perl. Work done by: gabor Sponsored by: Google Summer of Code 2007 Hat: portmgr
Notes
Notes: svn path=/head/; revision=199069
Diffstat (limited to 'dns')
-rw-r--r--dns/fpdns/Makefile8
-rw-r--r--dns/p5-DNS-EasyDNS/Makefile8
-rw-r--r--dns/p5-Net-DNS-SEC/Makefile4
-rw-r--r--dns/p5-Net-DNS-ToolKit/Makefile8
-rw-r--r--dns/p5-Net-DNS-ZoneFile-Fast/Makefile8
-rw-r--r--dns/p5-Net-Domain-TLD/Makefile10
-rw-r--r--dns/p5-Net-LibIDN/Makefile8
-rw-r--r--dns/p5-Stanford-DNSserver/Makefile8
8 files changed, 8 insertions, 54 deletions
diff --git a/dns/fpdns/Makefile b/dns/fpdns/Makefile
index 1260e6068239..3d12c5394196 100644
--- a/dns/fpdns/Makefile
+++ b/dns/fpdns/Makefile
@@ -23,12 +23,6 @@ PERL_CONFIGURE= yes
MAN1= fpdns.1
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= Requires at least Perl version 5.6.0
-.endif
-
verify: checksum
gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.sig
@@ -41,4 +35,4 @@ post-build:
post-install:
${RM} ${SITE_PERL}/${PERL_ARCH}/auto/Net/DNS/Fingerprint/.packlist
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/dns/p5-DNS-EasyDNS/Makefile b/dns/p5-DNS-EasyDNS/Makefile
index d101325271fc..d6b75cc9f7bc 100644
--- a/dns/p5-DNS-EasyDNS/Makefile
+++ b/dns/p5-DNS-EasyDNS/Makefile
@@ -23,16 +23,10 @@ MAN3= DNS::EasyDNS.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/dns/p5-Net-DNS-SEC/Makefile b/dns/p5-Net-DNS-SEC/Makefile
index c64ada9ac2b2..488026bababf 100644
--- a/dns/p5-Net-DNS-SEC/Makefile
+++ b/dns/p5-Net-DNS-SEC/Makefile
@@ -33,9 +33,7 @@ MAN3= Net::DNS::Keyset.3 Net::DNS::RR::DS.3 Net::DNS::RR::KEY.3 \
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6.0 or higher. Please install lang/perl5.8 and try again.
-.elif ${PERL_LEVEL} < 500800
+.if ${PERL_LEVEL} < 500800
BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
RUN_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
diff --git a/dns/p5-Net-DNS-ToolKit/Makefile b/dns/p5-Net-DNS-ToolKit/Makefile
index ab188d49f047..c6277a64f108 100644
--- a/dns/p5-Net-DNS-ToolKit/Makefile
+++ b/dns/p5-Net-DNS-ToolKit/Makefile
@@ -43,10 +43,4 @@ MAN3= Net::DNS::ToolKit.3 \
Net::DNS::ToolKit::RR::Template.3 \
Net::DNS::ToolKit::Utilities.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-CONFIGURE_ARGS+= LDFLAGS="-Wl,-E -L${LOCALBASE}/lib"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/dns/p5-Net-DNS-ZoneFile-Fast/Makefile b/dns/p5-Net-DNS-ZoneFile-Fast/Makefile
index d8a89b91424d..178a3dbb30a4 100644
--- a/dns/p5-Net-DNS-ZoneFile-Fast/Makefile
+++ b/dns/p5-Net-DNS-ZoneFile-Fast/Makefile
@@ -24,10 +24,4 @@ PERL_CONFIGURE= yes
MAN3= Net::DNS::ZoneFile::Fast.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/dns/p5-Net-Domain-TLD/Makefile b/dns/p5-Net-Domain-TLD/Makefile
index 97472e3fe017..bc0cc88e0206 100644
--- a/dns/p5-Net-Domain-TLD/Makefile
+++ b/dns/p5-Net-Domain-TLD/Makefile
@@ -24,12 +24,4 @@ PERL_CONFIGURE= yes
MAN3= Net::Domain::TLD.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-post-patch:
- ${PERL} -pi -e 's/^\s*our\s+([\$$\@\%]\w+)/use vars qw($$1);$$1/;' \
- -e 's/.*warnings.*//' ${WRKSRC}/lib/Net/Domain/TLD.pm
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/dns/p5-Net-LibIDN/Makefile b/dns/p5-Net-LibIDN/Makefile
index a970ef6620d9..f11f6f8f32cc 100644
--- a/dns/p5-Net-LibIDN/Makefile
+++ b/dns/p5-Net-LibIDN/Makefile
@@ -22,10 +22,4 @@ CONFIGURE_ARGS+= --with-libidn=${PREFIX}/lib --with-libidn-inc=${PREFIX}/include
MAN3= Net::LibIDN.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-IGNORE= requires perl 5.6.1 or later. Install lang/perl5.8 then try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/dns/p5-Stanford-DNSserver/Makefile b/dns/p5-Stanford-DNSserver/Makefile
index e0fd1f27f80f..e28edbf5fee9 100644
--- a/dns/p5-Stanford-DNSserver/Makefile
+++ b/dns/p5-Stanford-DNSserver/Makefile
@@ -18,10 +18,4 @@ PERL_CONFIGURE= yes
MAN3= Stanford::DNS.3 Stanford::DNSserver.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= does not work with the IO::Socket::INET module in Perl 5.00503
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>