aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2003-12-07 11:55:37 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2003-12-07 11:55:37 +0000
commit6a7ffc6fe3e82083030646f304d6f18f38420371 (patch)
tree474f16520e394af50a7ef99717631c1f987c17be /dns
parent322cbf6979dfd7e4e9f7f479fed89e6abeb7c6ee (diff)
downloadports-6a7ffc6fe3e82083030646f304d6f18f38420371.tar.gz
ports-6a7ffc6fe3e82083030646f304d6f18f38420371.zip
- Fix build with postgresql 7.4
- Fix package with ldapbackend - reorder makefile - detect if recursor is buildable
Notes
Notes: svn path=/head/; revision=95257
Diffstat (limited to 'dns')
-rw-r--r--dns/powerdns-devel/Makefile70
-rw-r--r--dns/powerdns-devel/pkg-plist5
-rw-r--r--dns/powerdns/Makefile70
-rw-r--r--dns/powerdns/pkg-plist5
4 files changed, 94 insertions, 56 deletions
diff --git a/dns/powerdns-devel/Makefile b/dns/powerdns-devel/Makefile
index 2eeb8ffe8925..a12110ffbd7f 100644
--- a/dns/powerdns-devel/Makefile
+++ b/dns/powerdns-devel/Makefile
@@ -22,6 +22,12 @@ GNU_CONFIGURE= YES
CONFIGURE_ARGS+= --with-modules="${CONFIGURE_MODULES} pipe" \
--with-dynmodules=""
# --enable-debug
+SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
+ CURDIR2="${.CURDIR}" \
+ MKDIR="${MKDIR}" \
+ DISTNAME="${DISTNAME}" \
+ POWERDNS_OPTIONS="${POWERDNS_OPTIONS}"
+MAN8= pdns_control.8 pdns_server.8 zone2sql.8
# use user config if possible
.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
@@ -36,36 +42,55 @@ NO_DESCRIBE=yes
.endif
.if defined(WITH_POSTGRESQL_DRIVER) && !defined(WITHOUT_POSTGRESQL_DRIVER)
-BROKEN= does not compile with postgresql 7.4
-LIB_DEPENDS= pq[+][+].4:${PORTSDIR}/databases/postgresql-libpq++
+LIB_DEPENDS+= pq[+][+].4:${PORTSDIR}/databases/postgresql-libpq++
CONFIGURE_ARGS+= --enable-pgsql
CONFIGURE_MODULES+= "gpgsql"
+CFLAGS+= -DDLLIMPORT=""
.else
CONFIGURE_ARGS+= --disable-pgsql
.endif
.if defined(WITH_MYSQL_DRIVER)
-MYSQL_PORT?= databases/mysql323-client
LIB_DEPENDS+= mysqlclient:${PORTSDIR}/${MYSQL_PORT}
+MYSQL_PORT?= databases/mysql323-client
CONFIGURE_ARGS+= --enable-mysql
CONFIGURE_MODULES+= "gmysql"
.else
CONFIGURE_ARGS+= --disable-mysql
.endif
-SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
- CURDIR2="${.CURDIR}" \
- MKDIR="${MKDIR}" \
- DISTNAME="${DISTNAME}" \
- POWERDNS_OPTIONS="${POWERDNS_OPTIONS}"
+.if defined(WITH_LDAP)
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/${LDAP_PORT}
+LIB_DEPENDS+= lber.2:${PORTSDIR}/${LDAP_PORT}
+LDAP_PORT?= net/openldap20-client
+USE_LIBTOOL= YES
+INSTALLS_SHLIB= YES
+USE_GCC=3.2
+CONFIGURE_MODULES+= "ldap"
+PLIST_SUB+= WITHLDAP=""
+.else
+PLIST_SUB+= WITHLDAP="@comment "
+.endif
-MAN8= pdns_control.8 pdns_server.8 zone2sql.8
+.if defined(POWERDNS_WITH_RECURSOR)
+USE_GCC=3.2
+CONFIGURE_ARGS+= --enable-recursor
+PLIST_SUB+= RECURSOR=""
+.else
+PLIST_SUB+= RECURSOR="@comment "
+.endif
-pre-everything::
- @ ${SETENV} ${SCRIPTS_ENV} ${SH} ${FILESDIR}/configure.powerdns
+.include <bsd.port.pre.mk>
-post-clean:
- @ ${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
+.if defined(POWERDNS_WITH_RECURSOR)
+.if exists(/usr/include/ucontext.h)
+UCONTEXT!= ${AWK} '/setcontext/ { print "YES" }' \
+ /usr/include/ucontext.h
+.if ${UCONTEXT} == ""
+BROKEN= setcontext for recursor not found
+.endif
+.endif
+.endif
.if defined(NO_DESCRIBE)
describe:
@@ -75,24 +100,13 @@ describe:
@cd ${.CURDIR} && ${MAKE} ${__softMAKEFLAGS} BATCH=yes ${.TARGET}
.endif
-.include <bsd.port.pre.mk>
+pre-everything::
+ @ ${SETENV} ${SCRIPTS_ENV} ${SH} ${FILESDIR}/configure.powerdns
-.if defined(POWERDNS_WITH_RECURSOR)
-BROKEN= does not compile in this version
-USE_GCC=3.2
-CONFIGURE_ARGS+= --enable-recursor
-PLIST_SUB+= RECURSOR=""
-.else
-PLIST_SUB+= RECURSOR="@comment "
-.endif
+post-clean:
+ @ ${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
.if defined(WITH_LDAP)
-USE_GCC=3.2
-LDAP_PORT?= net/openldap20-client
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/${LDAP_PORT}
-LIB_DEPENDS+= lber.2:${PORTSDIR}/${LDAP_PORT}
-CONFIGURE_MODULES+= "ldap"
-
post-patch:
${REINPLACE_CMD} -e 's;-I. ;-I. -I${LOCALBASE}/include ;' \
-e 's;la_LDFLAGS =;la_LDFLAGS = -L${LOCALBASE}/lib;' \
diff --git a/dns/powerdns-devel/pkg-plist b/dns/powerdns-devel/pkg-plist
index 9c102b6dc03b..d1ee0f0b1b49 100644
--- a/dns/powerdns-devel/pkg-plist
+++ b/dns/powerdns-devel/pkg-plist
@@ -2,6 +2,11 @@ bin/pdns_control
bin/zone2ldap
bin/zone2sql
sbin/pdns_server
+%%WITHLDAP%%lib/libldapbackend.so.0
+%%WITHLDAP%%lib/libldapbackend.la
+%%WITHLDAP%%lib/libldapbackend.a
+%%WITHLDAP%%@exec ln -fs libldapbackend.so.0 %D/lib/libldapbackend.so
+%%WITHLDAP%%@unexec rm -f %D/lib/libldapbackend.so
%%RECURSOR%%sbin/pdns_recursor
@unexec if cmp -s %D/etc/pdns.conf %D/etc/pdns.conf-dist; then rm -f %D/etc/pdns.conf; fi
etc/pdns.conf-dist
diff --git a/dns/powerdns/Makefile b/dns/powerdns/Makefile
index 2eeb8ffe8925..a12110ffbd7f 100644
--- a/dns/powerdns/Makefile
+++ b/dns/powerdns/Makefile
@@ -22,6 +22,12 @@ GNU_CONFIGURE= YES
CONFIGURE_ARGS+= --with-modules="${CONFIGURE_MODULES} pipe" \
--with-dynmodules=""
# --enable-debug
+SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
+ CURDIR2="${.CURDIR}" \
+ MKDIR="${MKDIR}" \
+ DISTNAME="${DISTNAME}" \
+ POWERDNS_OPTIONS="${POWERDNS_OPTIONS}"
+MAN8= pdns_control.8 pdns_server.8 zone2sql.8
# use user config if possible
.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
@@ -36,36 +42,55 @@ NO_DESCRIBE=yes
.endif
.if defined(WITH_POSTGRESQL_DRIVER) && !defined(WITHOUT_POSTGRESQL_DRIVER)
-BROKEN= does not compile with postgresql 7.4
-LIB_DEPENDS= pq[+][+].4:${PORTSDIR}/databases/postgresql-libpq++
+LIB_DEPENDS+= pq[+][+].4:${PORTSDIR}/databases/postgresql-libpq++
CONFIGURE_ARGS+= --enable-pgsql
CONFIGURE_MODULES+= "gpgsql"
+CFLAGS+= -DDLLIMPORT=""
.else
CONFIGURE_ARGS+= --disable-pgsql
.endif
.if defined(WITH_MYSQL_DRIVER)
-MYSQL_PORT?= databases/mysql323-client
LIB_DEPENDS+= mysqlclient:${PORTSDIR}/${MYSQL_PORT}
+MYSQL_PORT?= databases/mysql323-client
CONFIGURE_ARGS+= --enable-mysql
CONFIGURE_MODULES+= "gmysql"
.else
CONFIGURE_ARGS+= --disable-mysql
.endif
-SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
- CURDIR2="${.CURDIR}" \
- MKDIR="${MKDIR}" \
- DISTNAME="${DISTNAME}" \
- POWERDNS_OPTIONS="${POWERDNS_OPTIONS}"
+.if defined(WITH_LDAP)
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/${LDAP_PORT}
+LIB_DEPENDS+= lber.2:${PORTSDIR}/${LDAP_PORT}
+LDAP_PORT?= net/openldap20-client
+USE_LIBTOOL= YES
+INSTALLS_SHLIB= YES
+USE_GCC=3.2
+CONFIGURE_MODULES+= "ldap"
+PLIST_SUB+= WITHLDAP=""
+.else
+PLIST_SUB+= WITHLDAP="@comment "
+.endif
-MAN8= pdns_control.8 pdns_server.8 zone2sql.8
+.if defined(POWERDNS_WITH_RECURSOR)
+USE_GCC=3.2
+CONFIGURE_ARGS+= --enable-recursor
+PLIST_SUB+= RECURSOR=""
+.else
+PLIST_SUB+= RECURSOR="@comment "
+.endif
-pre-everything::
- @ ${SETENV} ${SCRIPTS_ENV} ${SH} ${FILESDIR}/configure.powerdns
+.include <bsd.port.pre.mk>
-post-clean:
- @ ${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
+.if defined(POWERDNS_WITH_RECURSOR)
+.if exists(/usr/include/ucontext.h)
+UCONTEXT!= ${AWK} '/setcontext/ { print "YES" }' \
+ /usr/include/ucontext.h
+.if ${UCONTEXT} == ""
+BROKEN= setcontext for recursor not found
+.endif
+.endif
+.endif
.if defined(NO_DESCRIBE)
describe:
@@ -75,24 +100,13 @@ describe:
@cd ${.CURDIR} && ${MAKE} ${__softMAKEFLAGS} BATCH=yes ${.TARGET}
.endif
-.include <bsd.port.pre.mk>
+pre-everything::
+ @ ${SETENV} ${SCRIPTS_ENV} ${SH} ${FILESDIR}/configure.powerdns
-.if defined(POWERDNS_WITH_RECURSOR)
-BROKEN= does not compile in this version
-USE_GCC=3.2
-CONFIGURE_ARGS+= --enable-recursor
-PLIST_SUB+= RECURSOR=""
-.else
-PLIST_SUB+= RECURSOR="@comment "
-.endif
+post-clean:
+ @ ${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
.if defined(WITH_LDAP)
-USE_GCC=3.2
-LDAP_PORT?= net/openldap20-client
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/${LDAP_PORT}
-LIB_DEPENDS+= lber.2:${PORTSDIR}/${LDAP_PORT}
-CONFIGURE_MODULES+= "ldap"
-
post-patch:
${REINPLACE_CMD} -e 's;-I. ;-I. -I${LOCALBASE}/include ;' \
-e 's;la_LDFLAGS =;la_LDFLAGS = -L${LOCALBASE}/lib;' \
diff --git a/dns/powerdns/pkg-plist b/dns/powerdns/pkg-plist
index 9c102b6dc03b..d1ee0f0b1b49 100644
--- a/dns/powerdns/pkg-plist
+++ b/dns/powerdns/pkg-plist
@@ -2,6 +2,11 @@ bin/pdns_control
bin/zone2ldap
bin/zone2sql
sbin/pdns_server
+%%WITHLDAP%%lib/libldapbackend.so.0
+%%WITHLDAP%%lib/libldapbackend.la
+%%WITHLDAP%%lib/libldapbackend.a
+%%WITHLDAP%%@exec ln -fs libldapbackend.so.0 %D/lib/libldapbackend.so
+%%WITHLDAP%%@unexec rm -f %D/lib/libldapbackend.so
%%RECURSOR%%sbin/pdns_recursor
@unexec if cmp -s %D/etc/pdns.conf %D/etc/pdns.conf-dist; then rm -f %D/etc/pdns.conf; fi
etc/pdns.conf-dist