aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-03-24 18:49:56 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-03-24 18:49:56 +0000
commit0615217f490666582212aaaf8212ac2894f53582 (patch)
treef9b6cd59021ab492134702ad6272fdf55e73f486 /dns
parenta695ad456a0a38d79fba187ba0bd4a4be012b5f3 (diff)
downloadports-0615217f490666582212aaaf8212ac2894f53582.tar.gz
ports-0615217f490666582212aaaf8212ac2894f53582.zip
A fully compliant DynDNS.org client for UNIX (supports NIC v2.0)
Notes
Notes: svn path=/head/; revision=40319
Diffstat (limited to 'dns')
-rw-r--r--dns/ipcheck/Makefile31
-rw-r--r--dns/ipcheck/distinfo1
-rw-r--r--dns/ipcheck/pkg-comment1
-rw-r--r--dns/ipcheck/pkg-descr22
-rw-r--r--dns/ipcheck/pkg-plist1
5 files changed, 56 insertions, 0 deletions
diff --git a/dns/ipcheck/Makefile b/dns/ipcheck/Makefile
new file mode 100644
index 000000000000..387133f92765
--- /dev/null
+++ b/dns/ipcheck/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ipcheck
+# Date created: 24 Mar 2001
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipcheck
+PORTVERSION= 0.85
+CATEGORIES= net
+MASTER_SITES= http://ipcheck.sourceforge.net/
+DISTNAME= ipcheck.py
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= lioux@FreeBSD.org
+
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+do-patch:
+ @${SED} -e "s!/usr/bin/python!${LOCALBASE}/bin/python!" \
+ -e "s!ppp0!tun0!" \
+ ${DISTDIR}/${DISTNAME} > ${WRKDIR}/${DISTNAME}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/dns/ipcheck/distinfo b/dns/ipcheck/distinfo
new file mode 100644
index 000000000000..e87c75092431
--- /dev/null
+++ b/dns/ipcheck/distinfo
@@ -0,0 +1 @@
+MD5 (ipcheck.py) = 29b6823d6d1bcfa3e6544fd8b78d889c
diff --git a/dns/ipcheck/pkg-comment b/dns/ipcheck/pkg-comment
new file mode 100644
index 000000000000..d93a7f7fb134
--- /dev/null
+++ b/dns/ipcheck/pkg-comment
@@ -0,0 +1 @@
+A fully compliant DynDNS.org client for UNIX (supports NIC v2.0)
diff --git a/dns/ipcheck/pkg-descr b/dns/ipcheck/pkg-descr
new file mode 100644
index 000000000000..c0b6001e7c6f
--- /dev/null
+++ b/dns/ipcheck/pkg-descr
@@ -0,0 +1,22 @@
+[from web site]
+This is a simple Python script to register your dynamic IP address
+using the NIC V2.0 protocol. We aim to be fully compliant with the
+dyndns client specification.
+
+We currently support all options and latest recommendations by
+Dyndns. Ipcheck is easy to install and very easy to use.
+
+Root access is not required and no configuration files are needed.
+
+Just specify your username, password and hostname(s) on the command
+line (or cron entry).
+
+You can specify the interface (default tun0) to search for your ip
+address on or use web based IP detection.
+
+There is also direct support for determining the IP address on the
+following devices: Linksys (-L), Netgear (-N), Draytek (-D), Netopia
+(-O), HawkingTech (-H), Cisco 667i (-C), Cisco 700 series (-I),
+ZyXEL Prestige (-Z), SMC Barricade (-S)
+
+WWW: http://ipcheck.sourceforge.net/
diff --git a/dns/ipcheck/pkg-plist b/dns/ipcheck/pkg-plist
new file mode 100644
index 000000000000..ae286ad3ac52
--- /dev/null
+++ b/dns/ipcheck/pkg-plist
@@ -0,0 +1 @@
+bin/ipcheck.py