aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-02-02 08:53:21 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-02-02 08:53:21 +0000
commit0cf97c910f06dde12e75f7aa7c2a210a7e756648 (patch)
treea74d461e0df85551a4a2992398463fc98f4404e7 /dns
parentdb0bda26b8278cccdd14c789a315b19aa0faf54c (diff)
downloadports-0cf97c910f06dde12e75f7aa7c2a210a7e756648.tar.gz
ports-0cf97c910f06dde12e75f7aa7c2a210a7e756648.zip
- New port openresolv-1.1
A resolvconf compatible framework for managing /etc/resolv.conf. PR: ports/119171 Submitted by: Roy Marples <roy@marples.name> (maintainer)
Notes
Notes: svn path=/head/; revision=206624
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/openresolv/Makefile27
-rw-r--r--dns/openresolv/distinfo3
-rw-r--r--dns/openresolv/files/pkg-deinstall.in24
-rw-r--r--dns/openresolv/files/pkg-message.in8
-rw-r--r--dns/openresolv/pkg-descr3
-rw-r--r--dns/openresolv/pkg-plist11
7 files changed, 77 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index d3b5ad7ce232..c72609f5513f 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -70,6 +70,7 @@
SUBDIR += nss_resinit
SUBDIR += odsclient
SUBDIR += opendd
+ SUBDIR += openresolv
SUBDIR += p5-BIND-Conf_Parser
SUBDIR += p5-DNS-Config
SUBDIR += p5-DNS-EasyDNS
diff --git a/dns/openresolv/Makefile b/dns/openresolv/Makefile
new file mode 100644
index 000000000000..cdefdaf8f143
--- /dev/null
+++ b/dns/openresolv/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: openresolv
+# Date created: 20 December 2007
+# Whom: Wesley Shields <wxs@atarininja.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openresolv
+PORTVERSION= 1.1
+CATEGORIES= dns
+MASTER_SITES= http://roy.marples.name/openresolv/
+
+MAINTAINER= roy@marples.name
+COMMENT= A resolvconf compatible framework for managing resolv.conf
+
+USE_BZIP2= yes
+
+MAN8= resolvconf.8
+
+SUB_FILES= pkg-deinstall pkg-message
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+post-install:
+ @${CAT} ${WRKDIR}/pkg-message
+
+.include <bsd.port.mk>
diff --git a/dns/openresolv/distinfo b/dns/openresolv/distinfo
new file mode 100644
index 000000000000..dfaf2e7bf191
--- /dev/null
+++ b/dns/openresolv/distinfo
@@ -0,0 +1,3 @@
+MD5 (openresolv-1.1.tar.bz2) = 346767d3072b8a294148d70a3e0ac763
+SHA256 (openresolv-1.1.tar.bz2) = 979e7af497c69f03d9ae70134ae11e5338b42bdca06fecab5b297a1f16f381f5
+SIZE (openresolv-1.1.tar.bz2) = 8765
diff --git a/dns/openresolv/files/pkg-deinstall.in b/dns/openresolv/files/pkg-deinstall.in
new file mode 100644
index 000000000000..38dc149c2fb2
--- /dev/null
+++ b/dns/openresolv/files/pkg-deinstall.in
@@ -0,0 +1,24 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+case $2 in
+ DEINSTALL)
+ ;;
+ POST-DEINSTALL)
+ echo "===> post-deinstallation information for $1"
+ echo ""
+ echo "Please note that $1 was not completely removed"
+ echo "from this system:"
+ echo ""
+ echo "/etc/resolv.conf should now be changed to be a regular"
+ echo "file and /var/run/resolvconf can be removed if openresolv"
+ echo "will no longer be used."
+ echo ""
+ ;;
+ *)
+ exit 64
+ ;;
+esac
+exit 0
diff --git a/dns/openresolv/files/pkg-message.in b/dns/openresolv/files/pkg-message.in
new file mode 100644
index 000000000000..b17d948ce23a
--- /dev/null
+++ b/dns/openresolv/files/pkg-message.in
@@ -0,0 +1,8 @@
+=================================================
+
+To make sure openresolv runs correctly
+please symlink /etc/resolv.conf to
+%%PREFIX%%/etc/resolvconf/run/resolv.conf
+
+=================================================
+
diff --git a/dns/openresolv/pkg-descr b/dns/openresolv/pkg-descr
new file mode 100644
index 000000000000..6c93476f28cb
--- /dev/null
+++ b/dns/openresolv/pkg-descr
@@ -0,0 +1,3 @@
+A resolvconf compatible framework for managing /etc/resolv.conf.
+
+WWW: http://roy.marples.name/node/343
diff --git a/dns/openresolv/pkg-plist b/dns/openresolv/pkg-plist
new file mode 100644
index 000000000000..d5ff7222da8f
--- /dev/null
+++ b/dns/openresolv/pkg-plist
@@ -0,0 +1,11 @@
+@exec mkdir -p %D/etc/resolvconf/update-libc.d
+@exec mkdir -p %D/etc/resolvconf/resolv.conf.d
+sbin/resolvconf
+etc/resolvconf/run
+etc/resolvconf/update.d/libc
+etc/resolvconf/update.d/dnsmasq
+etc/resolvconf/update.d/named
+@dirrm etc/resolvconf/update.d
+@dirrm etc/resolvconf/update-libc.d
+@dirrm etc/resolvconf/resolv.conf.d
+@dirrm etc/resolvconf