aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-30 00:47:26 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-30 00:47:26 +0000
commitb8d63a209f1bc1e07e8f37b0c19ec0cec9967cc8 (patch)
tree24195e9355fb7e3b35611c11cda0474fb7b3550e /dns
parent180d7d9419b20195af73b58ba2c93c5ba06d9cab (diff)
downloadports-b8d63a209f1bc1e07e8f37b0c19ec0cec9967cc8.tar.gz
ports-b8d63a209f1bc1e07e8f37b0c19ec0cec9967cc8.zip
Move net/weedns_sc to dns/weedns_sc
Notes
Notes: svn path=/head/; revision=88022
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/weedns_sc/Makefile47
-rw-r--r--dns/weedns_sc/distinfo1
-rw-r--r--dns/weedns_sc/pkg-descr1
-rw-r--r--dns/weedns_sc/pkg-plist6
5 files changed, 56 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 84269a6b2823..4d4a5424b5e4 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -1,5 +1,6 @@
# $FreeBSD$
#
+ SUBDIR += weedns_sc
SUBDIR += rbldnsd
.include <bsd.port.subdir.mk>
diff --git a/dns/weedns_sc/Makefile b/dns/weedns_sc/Makefile
new file mode 100644
index 000000000000..55c783d2ff55
--- /dev/null
+++ b/dns/weedns_sc/Makefile
@@ -0,0 +1,47 @@
+# ports collection Makefile for: weedns_sc
+# Whom: Matthias Andree <matthias.andree@gmx.de>
+# Date created: 2003-05-22
+#
+# $FreeBSD$
+#
+
+PORTNAME= weedns_sc
+PORTVERSION= 1.19
+CATEGORIES= dns perl5
+MASTER_SITES= http://www.weedns.com/clients/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= matthias.andree@gmx.de
+COMMENT= Client to update whyi.org dynamic DNS service
+
+RUN_DEPENDS= ${SITE_PERL}/HTTP/Request/Common.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI
+
+USE_PERL5= yes
+USE_REINPLACE= yes
+NO_BUILD= yes
+
+post-patch:
+ ${REINPLACE_CMD} "s|^#!/usr/bin/perl|#!${PERL}|" ${WRKSRC}/bin/skeleton_client.pl
+ ${REINPLACE_CMD} "s|^#!/usr/bin/perl|#!${PERL}|" ${WRKSRC}/bin/smtp_ip.pl
+
+do-install:
+ ${MKDIR} ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/etc
+ ${MKDIR} ${SITE_PERL}/WeedNS
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/skeleton_client.pl ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/smtp_ip.pl ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/lib/WeedNS/Client.pm ${SITE_PERL}/WeedNS
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/skeleton_client.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= "requires Perl 5.6+. Install lang/perl5, run use.perl port, retry"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/dns/weedns_sc/distinfo b/dns/weedns_sc/distinfo
new file mode 100644
index 000000000000..6c9b0737b6fe
--- /dev/null
+++ b/dns/weedns_sc/distinfo
@@ -0,0 +1 @@
+MD5 (weedns_sc-1.19.tgz) = 8a9ee8b11e34d7820f37704ba3bb6fcc
diff --git a/dns/weedns_sc/pkg-descr b/dns/weedns_sc/pkg-descr
new file mode 100644
index 000000000000..8b137891791f
--- /dev/null
+++ b/dns/weedns_sc/pkg-descr
@@ -0,0 +1 @@
+
diff --git a/dns/weedns_sc/pkg-plist b/dns/weedns_sc/pkg-plist
new file mode 100644
index 000000000000..88f1cd77e7e8
--- /dev/null
+++ b/dns/weedns_sc/pkg-plist
@@ -0,0 +1,6 @@
+bin/skeleton_client.pl
+bin/smtp_ip.pl
+%%SITE_PERL%%/WeedNS/Client.pm
+%%PORTDOCS%%%%DOCSDIR%%/skeleton_client.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%SITE_PERL%%/WeedNS