aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2002-06-11 18:46:16 +0000
committerAnton Berezin <tobez@FreeBSD.org>2002-06-11 18:46:16 +0000
commitf53230d8af19cf8af428e4d89e88ded9b6776da4 (patch)
treed234bc15e4954c21e372df1ef5e3cddefc0d63e7 /dns
parent5b29610d8076dbf9f0b5db500a229a86f68e4dda (diff)
downloadports-f53230d8af19cf8af428e4d89e88ded9b6776da4.tar.gz
ports-f53230d8af19cf8af428e4d89e88ded9b6776da4.zip
Add p5-Net-DNS-ZoneFile, a Perl extension to convert a zone file to a
collection of RRs.
Notes
Notes: svn path=/head/; revision=61129
Diffstat (limited to 'dns')
-rw-r--r--dns/p5-Net-DNS-ZoneFile/Makefile34
-rw-r--r--dns/p5-Net-DNS-ZoneFile/distinfo1
-rw-r--r--dns/p5-Net-DNS-ZoneFile/files/patch-ZoneFile.pm39
-rw-r--r--dns/p5-Net-DNS-ZoneFile/pkg-comment1
-rw-r--r--dns/p5-Net-DNS-ZoneFile/pkg-descr9
-rw-r--r--dns/p5-Net-DNS-ZoneFile/pkg-plist4
6 files changed, 88 insertions, 0 deletions
diff --git a/dns/p5-Net-DNS-ZoneFile/Makefile b/dns/p5-Net-DNS-ZoneFile/Makefile
new file mode 100644
index 000000000000..33f1c1859ba4
--- /dev/null
+++ b/dns/p5-Net-DNS-ZoneFile/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: net/p5-Net-DNS-ZoneFile
+# Date created: 11 June 2002
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-DNS-ZoneFile
+PORTVERSION= 1.00
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/DNS/RR.pm:${PORTSDIR}/net/p5-Net-DNS \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/NetAddr/IP.pm:${PORTSDIR}/net/p5-NetAddr-IP
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Net::DNS::ZoneFile.3
+
+post-patch:
+ ${PERL} -pi -e 's/^\s*our\s+([\$$\@\%]\w+)/use vars qw($$1);$$1/;' \
+ -e '$$_="" if /require 5/;' \
+ -e '$$_="" if /^\s*(use|no)\s+warnings;\s*$$/;' \
+ ${WRKSRC}/ZoneFile.pm
+
+.include <bsd.port.mk>
diff --git a/dns/p5-Net-DNS-ZoneFile/distinfo b/dns/p5-Net-DNS-ZoneFile/distinfo
new file mode 100644
index 000000000000..2721ab2a3a59
--- /dev/null
+++ b/dns/p5-Net-DNS-ZoneFile/distinfo
@@ -0,0 +1 @@
+MD5 (Net-DNS-ZoneFile-1.00.tar.gz) = 3489dee610f2a8d2dbbfc94fab0280e9
diff --git a/dns/p5-Net-DNS-ZoneFile/files/patch-ZoneFile.pm b/dns/p5-Net-DNS-ZoneFile/files/patch-ZoneFile.pm
new file mode 100644
index 000000000000..9a5d10a65c52
--- /dev/null
+++ b/dns/p5-Net-DNS-ZoneFile/files/patch-ZoneFile.pm
@@ -0,0 +1,39 @@
+$FreeBSD$
+
+--- ZoneFile.pm.orig Tue Jun 11 20:34:27 2002
++++ ZoneFile.pm Tue Jun 11 20:35:23 2002
+@@ -129,23 +129,23 @@
+ elsif ($text =~ # SOA
+ s/
+ \A(|\*|\s*@|\.|([-\w\d]+(\.[-\w\d]+)*\.?))
+- \s+ ((IN|HESIOD|CHAOS) \s+)?
++ \s+ (?:([\d]+)\s+)? ((IN|HESIOD|CHAOS) \s+)?
+ (SOA) \s+ ([-\w\d]+(\.[-\w\d]+)*\.)
+ \s+ ([-\w\d]+(\.[-\w\d]+)*\.) \s* \(
+ \s* (\d+) \s+ (\d+) \s+ (\d+) \s+ (\d+) \s+ (\d+) \s+ \) \s*$
+ //mxi)
+ {
+ my $name = $1;
+- my $class = $5 || 'IN';
+- my $type = $6;
+- my $host = $7;
+- my $admin = $9;
+- my $d1 = $11;
+- my $d2 = $12;
+- my $d3 = $13;
+- my $d4 = $14;
+- my $d5 = $15;
+- my $ttl = $d5;
++ my $class = $6 || 'IN';
++ my $type = $7;
++ my $host = $8;
++ my $admin = $10;
++ my $d1 = $12;
++ my $d2 = $13;
++ my $d3 = $14;
++ my $d4 = $15;
++ my $d5 = $16;
++ my $ttl = $4 || $d5;
+
+ $SoaTTL = $ttl;
+
diff --git a/dns/p5-Net-DNS-ZoneFile/pkg-comment b/dns/p5-Net-DNS-ZoneFile/pkg-comment
new file mode 100644
index 000000000000..55832711cb08
--- /dev/null
+++ b/dns/p5-Net-DNS-ZoneFile/pkg-comment
@@ -0,0 +1 @@
+Perl extension to convert a zone file to a collection of RRs
diff --git a/dns/p5-Net-DNS-ZoneFile/pkg-descr b/dns/p5-Net-DNS-ZoneFile/pkg-descr
new file mode 100644
index 000000000000..487fe8ebeed9
--- /dev/null
+++ b/dns/p5-Net-DNS-ZoneFile/pkg-descr
@@ -0,0 +1,9 @@
+This module parses a zone file and returns a reference to an array of
+Net::DNS::RR objects containing each of the RRs given in the zone in the
+case that the whole zone file was succesfully parsed.
+
+Author: Luis Mun~oz <lem@cantv.net>
+WWW: http://search.cpan.org/search?dist=Net-DNS-ZoneFile
+
+-Anton
+<tobez@FreeBSD.org>
diff --git a/dns/p5-Net-DNS-ZoneFile/pkg-plist b/dns/p5-Net-DNS-ZoneFile/pkg-plist
new file mode 100644
index 000000000000..d70a2acbae76
--- /dev/null
+++ b/dns/p5-Net-DNS-ZoneFile/pkg-plist
@@ -0,0 +1,4 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/DNS/ZoneFile/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/ZoneFile.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/DNS/ZoneFile
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Net/DNS 2>/dev/null || true