aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-09-12 14:01:42 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-09-12 14:01:42 +0000
commit6bb8e6f41d302944ef724597ab1b46547042a936 (patch)
tree0e7be28c76ef651494269445ac9917ce584c7b8e /dns
parent2fc6a06a9bc3abfccb6b93249380619b3228bd4b (diff)
downloadports-6bb8e6f41d302944ef724597ab1b46547042a936.tar.gz
ports-6bb8e6f41d302944ef724597ab1b46547042a936.zip
Fix network interface detection. Pass maintainership to submitter.
PR: 160677 Submitted by: sthalik@tehran.lain.pl
Notes
Notes: svn path=/head/; revision=281669
Diffstat (limited to 'dns')
-rw-r--r--dns/noip/Makefile10
-rw-r--r--dns/noip/files/patch-Makefile20
-rw-r--r--dns/noip/files/patch-noip2.c4
3 files changed, 11 insertions, 23 deletions
diff --git a/dns/noip/Makefile b/dns/noip/Makefile
index e51dceb8a4d7..9f36be89c1a3 100644
--- a/dns/noip/Makefile
+++ b/dns/noip/Makefile
@@ -7,23 +7,21 @@
PORTNAME= noip
PORTVERSION= 2.1.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns
MASTER_SITES= http://www.no-ip.com/client/linux/ \
CRITICAL
-MAINTAINER= ehaupt@FreeBSD.org
+MAINTAINER= sthalik@tehran.lain.pl
COMMENT= No-IP.com's dynamic DNS update client
+LICENSE= GPLv2
+
ALL_TARGET= noip2
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
USE_RC_SUBR= noip
-LICENSE= GPLv2
-
-CFLAGS+= -Dbsd_with_getifaddrs
-
USERS= noip
GROUPS= noip
diff --git a/dns/noip/files/patch-Makefile b/dns/noip/files/patch-Makefile
index 9f3b90b30c12..211301ed0a5b 100644
--- a/dns/noip/files/patch-Makefile
+++ b/dns/noip/files/patch-Makefile
@@ -1,9 +1,8 @@
---- Makefile.orig 2008-11-21 23:27:15.000000000 +0100
-+++ Makefile 2011-03-28 18:15:31.000000000 +0200
-@@ -1,8 +1,8 @@
+--- ./Makefile.orig 2008-11-21 23:27:15.000000000 +0100
++++ ./Makefile 2011-09-12 15:00:30.000000000 +0200
+@@ -1,8 +1,7 @@
TGT=noip2
-CC=gcc
-+CC?=gcc
PKG=noip-2.1.tgz
-PREFIX=/usr/local
@@ -11,21 +10,12 @@
CONFDIR=${PREFIX}/etc
BINDIR=${PREFIX}/bin
-@@ -11,7 +11,7 @@
- ARCH=linux
-
- # for Mac OS X and BSD systems that have getifaddr(), uncomment the next line
--#ARCH=bsd_with_getifaddrs
-+ARCH=bsd_with_getifaddrs
-
- # for early BSD systems without getifaddrs(), uncomment the next line
- #ARCH=bsd
-@@ -22,7 +22,7 @@
+@@ -22,7 +21,7 @@
# ARCH=sun
${TGT}: Makefile ${TGT}.c
- ${CC} -Wall -g -D${ARCH} -DPREFIX=\"${PREFIX}\" ${TGT}.c -o ${TGT} ${LIBS}
-+ ${CC} ${CFLAGS} -DPREFIX=\"${PREFIX}\" ${TGT}.c -o ${TGT} ${LIBS}
++ ${CC} -Dbsd_with_getifaddrs -DPREFIX=\"${PREFIX}\" ${TGT}.c -o ${TGT} ${LIBS}
install: ${TGT}
if [ ! -d ${BINDIR} ]; then mkdir -p ${BINDIR};fi
diff --git a/dns/noip/files/patch-noip2.c b/dns/noip/files/patch-noip2.c
index 62399450912a..f8f70e4b5c8b 100644
--- a/dns/noip/files/patch-noip2.c
+++ b/dns/noip/files/patch-noip2.c
@@ -1,5 +1,5 @@
---- noip2.c.orig 2009-11-17 20:23:40.000000000 +0100
-+++ noip2.c 2009-11-17 20:27:45.000000000 +0100
+--- ./noip2.c.orig 2008-11-21 23:19:54.000000000 +0100
++++ ./noip2.c 2011-09-12 14:58:30.000000000 +0200
@@ -198,7 +198,7 @@
#define CLIENT_IP_PORT 8245