aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2011-07-28 21:59:28 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2011-07-28 21:59:28 +0000
commitd7ecc7c232cfe190107d45841ea6375523dcd360 (patch)
tree1778fd2cff994522215e039c45e61bfcf20f1177 /dns
parentd944917e18f9336f22a9ec9ca1ba0a21806aa393 (diff)
downloadports-d7ecc7c232cfe190107d45841ea6375523dcd360.tar.gz
ports-d7ecc7c232cfe190107d45841ea6375523dcd360.zip
Update to 1.8.1 [1]
Add LICENSE PR: ports/159199 Submitted by: Rob Farmer <rfarmer@predatorlabs.net> (maintainer) [1] Approved by: tabthorpe (mentor)
Notes
Notes: svn path=/head/; revision=278503
Diffstat (limited to 'dns')
-rw-r--r--dns/ddclient/Makefile3
-rw-r--r--dns/ddclient/distinfo4
-rw-r--r--dns/ddclient/files/patch-ddclient31
-rw-r--r--dns/ddclient/files/patch-ticket221
4 files changed, 18 insertions, 41 deletions
diff --git a/dns/ddclient/Makefile b/dns/ddclient/Makefile
index 9e6ac186af44..ef76fbcbc863 100644
--- a/dns/ddclient/Makefile
+++ b/dns/ddclient/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ddclient
-PORTVERSION= 3.8.0
-PORTREVISION= 2
+PORTVERSION= 3.8.1
CATEGORIES= dns
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
diff --git a/dns/ddclient/distinfo b/dns/ddclient/distinfo
index df0e7422b854..994d10894bf0 100644
--- a/dns/ddclient/distinfo
+++ b/dns/ddclient/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ddclient-3.8.0.tar.bz2) = 910dc49bd4b2920fad6c4afce03805de5a4cffd0db5f3d902c5417353420aef4
-SIZE (ddclient-3.8.0.tar.bz2) = 41701
+SHA256 (ddclient-3.8.1.tar.bz2) = 77a82668a53fdbed1e05ad6febe6dbefb093e3922afb20b993d4ad9ee868258f
+SIZE (ddclient-3.8.1.tar.bz2) = 43711
diff --git a/dns/ddclient/files/patch-ddclient b/dns/ddclient/files/patch-ddclient
index 5a1c51e7aa7b..d3f732d4e474 100644
--- a/dns/ddclient/files/patch-ddclient
+++ b/dns/ddclient/files/patch-ddclient
@@ -1,21 +1,21 @@
---- ./ddclient.orig 2009-01-27 20:14:02.000000000 +0100
-+++ ./ddclient 2010-08-17 20:13:00.000000000 +0200
+--- ./ddclient.orig 2011-07-25 19:41:39.000000000 -0700
++++ ./ddclient 2011-07-25 19:41:48.000000000 -0700
@@ -1,4 +1,3 @@
-#!/usr/bin/perl -w
#!/usr/local/bin/perl -w
######################################################################
- # $Id: ddclient 106 2008-12-04 18:05:23Z wimpunk $
+ # $Id: ddclient 130 2011-07-11 21:02:07Z wimpunk $
@@ -19,6 +18,7 @@
use Getopt::Long;
use Sys::Hostname;
use IO::Socket;
+use POSIX 'setsid';
- my $version = "3.8.0";
- my $programd = $0;
-@@ -625,6 +625,9 @@
- $SIG{'KILL'} = sub { $caught_kill = 1; };
- if (opt('daemon') && !opt('force')) {
+ my ($VERSION) = q$Revision: 130 $ =~ /(\d+)/;
+
+@@ -668,6 +668,9 @@
+ ;
+ } elsif (opt('daemon')) {
$SIG{'CHLD'} = 'IGNORE';
+ chdir '/';
+ open(STDIN, "</dev/null");
@@ -23,35 +23,34 @@
my $pid = fork;
if ($pid < 0) {
print STDERR "${program}: can not fork ($!)\n";
-@@ -632,11 +635,10 @@
+@@ -675,10 +678,9 @@
} elsif ($pid) {
exit 0;
}
+ setsid;
$SIG{'CHLD'} = 'DEFAULT';
- $opt{'syslog'} = 1;
- open(STDOUT, ">/dev/null");
- open(STDERR, ">/dev/null");
- open(STDIN, "</dev/null");
+ open(STDERR, "&STDOUT");
-
- write_pid();
}
-@@ -1404,17 +1406,17 @@
+
+ # write out the pid file if we're daemon'ized
+@@ -1463,17 +1465,17 @@
## execute the command.
local *FD;
if (! open(FD, $cmd)) {
- printf STDERR "$program: cannot execute command %s.\n", $cmd;
-+ warning("$program: cannot execute command %s.\n", $cmd);
++ warning("$program: cannot execute command %s.\n", $cmd);
} elsif ($stdin && (! print FD "$stdin\n")) {
- printf STDERR "$program: failed writting to %s.\n", $cmd;
-+ warning("$program: failed writing to %s.\n", $cmd);
++ warning("$program: failed writing to %s.\n", $cmd);
close(FD);
} elsif (! close(FD)) {
- printf STDERR "$program: failed closing %s.($@)\n", $cmd;
-+ warning("$program: failed closing %s.($@)\n", $cmd);
++ warning("$program: failed closing %s.($@)\n", $cmd);
} elsif (opt('exec') && $?) {
- printf STDERR "$program: failed %s. ($@)\n", $cmd;
diff --git a/dns/ddclient/files/patch-ticket2 b/dns/ddclient/files/patch-ticket2
deleted file mode 100644
index ac4d331ff93d..000000000000
--- a/dns/ddclient/files/patch-ticket2
+++ /dev/null
@@ -1,21 +0,0 @@
---- ddclient.orig 2011-03-11 00:00:19.394750047 -0800
-+++ ddclient 2011-03-11 00:04:28.967751644 -0800
-@@ -2094,10 +2094,14 @@
- } elsif (defined($sub) && &$sub($host)) {
- $update = 1;
-
-- } elsif (($cache{$host}{'static'} ne $config{$host}{'static'}) ||
-- ($cache{$host}{'wildcard'} ne $config{$host}{'wildcard'}) ||
-- ($cache{$host}{'mx'} ne $config{$host}{'mx'}) ||
-- ($cache{$host}{'backupmx'} ne $config{$host}{'backupmx'})) {
-+ } elsif ((defined($cache{$host}{'static'}) && defined($config{$host}{'static'}) &&
-+ ($cache{$host}{'static'} ne $config{$host}{'static'})) ||
-+ (defined($cache{$host}{'wildcard'}) && defined($config{$host}{'wildcard'}) &&
-+ ($cache{$host}{'wildcard'} ne $config{$host}{'wildcard'})) ||
-+ (defined($cache{$host}{'mx'}) && defined($config{$host}{'mx'}) &&
-+ ($cache{$host}{'mx'} ne $config{$host}{'mx'})) ||
-+ (defined($cache{$host}{'backupmx'}) && defined($config{$host}{'backupmx'}) &&
-+ ($cache{$host}{'backupmx'} ne $config{$host}{'backupmx'})) ) {
- info("updating %s because host settings have been changed.", $host);
- $update = 1;
-