aboutsummaryrefslogtreecommitdiff
path: root/editors/biew/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2009-09-29 12:46:10 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2009-09-29 12:46:10 +0000
commit8dea97dc198ab26044ece187e406aaa8e4c3131f (patch)
treefe6c08be11cdc0e79e506d6677bac0e5617f4805 /editors/biew/Makefile
parent4e915ff73301d53b868c025c6740f985090a5617 (diff)
downloadports-8dea97dc198ab26044ece187e406aaa8e4c3131f.tar.gz
ports-8dea97dc198ab26044ece187e406aaa8e4c3131f.zip
- Update to version 6.0.0
- Pacify portlint(1) Feature safe: yes
Notes
Notes: svn path=/head/; revision=242227
Diffstat (limited to 'editors/biew/Makefile')
-rw-r--r--editors/biew/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/editors/biew/Makefile b/editors/biew/Makefile
index 8bed68d8010c..0770ffdac591 100644
--- a/editors/biew/Makefile
+++ b/editors/biew/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: biew
+# New ports collection makefile for: BIEW
# Date created: 04 February 2000
# Whom: Michael Vasilenko <acid@stu.cn.ua>
#
@@ -6,24 +6,25 @@
#
PORTNAME= biew
-PORTVERSION= 5.7.3.1
+PORTVERSION= 6.0.0
CATEGORIES= editors
MASTER_SITES= SF
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
-
-LIB_DEPENDS= slang.2:${PORTSDIR}/devel/libslang2
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}-src
MAINTAINER= danfe@FreeBSD.org
COMMENT= Binary file viewer and editor
+LIB_DEPENDS= slang.2:${PORTSDIR}/devel/libslang2
+
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --cc="${CC}" --with-extraincdir="${LOCALBASE}/include" \
--ld="${CC}" --with-extralibdir="${LOCALBASE}/lib" \
- --prefix="${PREFIX}" --datadir="${DATADIR}"
+ --prefix="${PREFIX}" --datadir="${DATADIR}" --enable-slang
USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
MAKEFILE= makefile
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.//g}
PLIST_FILES= bin/biew \
%%DATADIR%%/assembly.skn \