aboutsummaryrefslogtreecommitdiff
path: root/editors/bless
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2004-11-26 06:20:11 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2004-11-26 06:20:11 +0000
commit11c7f0290386bde6e8eb1c501247e0976211b76a (patch)
tree92c585f5cc80d3627102c8048222dd9881aacf93 /editors/bless
parent06ea4d503d7c6079a8e7f86364b6cf2bdf304170 (diff)
downloadports-11c7f0290386bde6e8eb1c501247e0976211b76a.tar.gz
ports-11c7f0290386bde6e8eb1c501247e0976211b76a.zip
Bless is a binary (hex) editor, a program that enables you to edit files as
a sequence of bytes. It is written in C# and uses the Gtk# bindings for the GTK+ toolkit. Main Features ------------- * Efficient editing of large data files. * Multilevel undo - redo operations. * Customizable data views. * Fast data rendering on screen. WWW: http://home.gna.org/bless/ Project by: BSD# - http://forge.novell.com/modules/xfmod/project/?bsd-sharp
Notes
Notes: svn path=/head/; revision=122482
Diffstat (limited to 'editors/bless')
-rw-r--r--editors/bless/Makefile40
-rw-r--r--editors/bless/distinfo2
-rw-r--r--editors/bless/files/patch-src::Makefile29
-rw-r--r--editors/bless/files/patch-src::gui::Makefile40
-rw-r--r--editors/bless/pkg-descr12
-rw-r--r--editors/bless/pkg-plist7
6 files changed, 130 insertions, 0 deletions
diff --git a/editors/bless/Makefile b/editors/bless/Makefile
new file mode 100644
index 000000000000..1b18bc6b52de
--- /dev/null
+++ b/editors/bless/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: bless
+# Date created: 24 October 2004
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bless
+PORTVERSION= 0.2.0
+CATEGORIES= editors
+MASTER_SITES= http://home.gna.org/bless/
+
+MAINTAINER= bsd-sharp-list@forge.novell.com
+COMMENT= A high quality, full featured hex editor
+
+BUILD_DEPENDS= gapi-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+
+DOCS= COPYING Changelog README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|make|${GMAKE}|g' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|function pkg_config_check|pkg_config_check()|g' \
+ ${WRKSRC}/configure
+
+.ifndef (NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for i in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/editors/bless/distinfo b/editors/bless/distinfo
new file mode 100644
index 000000000000..72235b6bd0d1
--- /dev/null
+++ b/editors/bless/distinfo
@@ -0,0 +1,2 @@
+MD5 (bless-0.2.0.tar.gz) = f9e89bdc032c0a6ed4e9c989f4db3194
+SIZE (bless-0.2.0.tar.gz) = 232405
diff --git a/editors/bless/files/patch-src::Makefile b/editors/bless/files/patch-src::Makefile
new file mode 100644
index 000000000000..83c02c1972a7
--- /dev/null
+++ b/editors/bless/files/patch-src::Makefile
@@ -0,0 +1,29 @@
+--- src/Makefile.orig Wed Oct 27 13:21:26 2004
++++ src/Makefile Wed Oct 27 13:23:01 2004
+@@ -44,16 +44,16 @@
+ -resource:gui/default.layout,default.layout
+
+ bless.exe: $(GUI_SRC) $(BB_SRC) $(GUI_DRAWERS_SRC) $(GUI_AREAS_SRC) $(GUI_DIALOGS_SRC) $(UTIL_SRC)
+- $(MCS) -g -o bless.exe -t:exe -r:nunit.framework $(RESOURCES) -pkg:gtk-sharp -pkg:glade-sharp \
++ $(MCS) -g -o bless.exe -t:exe -r:nunit.framework $(RESOURCES) $(shell pkg-config --libs gtk-sharp glade-sharp) \
+ $(GUI_SRC) $(BB_SRC) $(GUI_DRAWERS_SRC) $(GUI_AREAS_SRC) $(GUI_DIALOGS_SRC) $(UTIL_SRC)
+
+
+ %.dll:%.cs
+- $(MCS) -t:library -r:nunit.framework -pkg:gtk-sharp $<
++ $(MCS) -t:library -r:nunit.framework $(shell pkg-config --libs gtk-sharp) $<
+
+ install: bless.exe
+ install -c -d $(PREFIX)/lib/bless
+- install -c bless.exe /usr/local/lib/bless
++ install -c bless.exe $(PREFIX)/lib/bless
+ echo "mono $(PREFIX)/lib/bless/bless.exe \"\$$@\"" > bless
+ install -c -d $(PREFIX)/bin
+ install -c bless $(PREFIX)/bin
+@@ -63,4 +63,4 @@
+ rm -rf $(PREFIX)/lib/bless
+ rm $(PREFIX)/bin/bless
+ clean:
+- rm -rf $(DLLS)
+\ No newline at end of file
++ rm -rf $(DLLS)
diff --git a/editors/bless/files/patch-src::gui::Makefile b/editors/bless/files/patch-src::gui::Makefile
new file mode 100644
index 000000000000..dbb81fb0432d
--- /dev/null
+++ b/editors/bless/files/patch-src::gui::Makefile
@@ -0,0 +1,40 @@
+--- src/gui/Makefile.orig Wed Oct 27 13:13:51 2004
++++ src/gui/Makefile Wed Oct 27 13:14:03 2004
+@@ -5,7 +5,7 @@
+ DLLS= FontDrawer.dll
+
+ exe:
+- $(MCS) -r:nunit.framework -pkg:gtk-sharp FontDrawer.cs
++ $(MCS) -r:nunit.framework $(shell pkg-config --libs gtk-sharp) FontDrawer.cs
+
+ test: fd-test oa-test
+
+@@ -22,21 +22,21 @@
+ nunit-console DataView.dll
+
+ FontDrawer.dll: FontDrawer.cs
+- $(MCS) -t:library -r:nunit.framework -pkg:gtk-sharp FontDrawer.cs
++ $(MCS) -t:library -r:nunit.framework $(shell pkg-config --libs gtk-sharp) FontDrawer.cs
+
+ OffsetArea.dll: OffsetArea.cs
+- $(MCS) -t:library -r:nunit.framework -pkg:gtk-sharp OffsetArea.cs Area.cs FontDrawer.cs
++ $(MCS) -t:library -r:nunit.framework $(shell pkg-config --libs gtk-sharp) OffsetArea.cs Area.cs FontDrawer.cs
+
+ HexArea.dll: HexArea.cs
+- $(MCS) -t:library -r:nunit.framework -pkg:gtk-sharp HexArea.cs Area.cs FontDrawer.cs
++ $(MCS) -t:library -r:nunit.framework $(shell pkg-config --libs gtk-sharp) HexArea.cs Area.cs FontDrawer.cs
+
+ DataView.dll: DataView.cs Area.cs HexArea.cs OffsetArea.cs SeparatorArea.cs AsciiArea.cs FontDrawer.cs
+- $(MCS) -t:library -r:nunit.framework -pkg:gtk-sharp DataView.cs Area.cs HexArea.cs OffsetArea.cs SeparatorArea.cs AsciiArea.cs FontDrawer.cs
++ $(MCS) -t:library -r:nunit.framework $(shell pkg-config --libs gtk-sharp) DataView.cs Area.cs HexArea.cs OffsetArea.cs SeparatorArea.cs AsciiArea.cs FontDrawer.cs
+
+
+
+ %.dll:%.cs
+- $(MCS) -t:library -r:nunit.framework -pkg:gtk-sharp $<
++ $(MCS) -t:library -r:nunit.framework $(shell pkg-config --libs gtk-sharp) $<
+
+ clean:
+- rm -rf $(DLLS)
+\ No newline at end of file
++ rm -rf $(DLLS)
diff --git a/editors/bless/pkg-descr b/editors/bless/pkg-descr
new file mode 100644
index 000000000000..ead742e0379f
--- /dev/null
+++ b/editors/bless/pkg-descr
@@ -0,0 +1,12 @@
+Bless is a binary (hex) editor, a program that enables you to edit files as
+a sequence of bytes. It is written in C# and uses the Gtk# bindings for the
+GTK+ toolkit.
+
+Main Features
+-------------
+ * Efficient editing of large data files.
+ * Multilevel undo - redo operations.
+ * Customizable data views.
+ * Fast data rendering on screen.
+
+WWW: http://home.gna.org/bless/
diff --git a/editors/bless/pkg-plist b/editors/bless/pkg-plist
new file mode 100644
index 000000000000..7c7864e1b9af
--- /dev/null
+++ b/editors/bless/pkg-plist
@@ -0,0 +1,7 @@
+bin/bless
+lib/bless/bless.exe
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/Changelog
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm lib/bless