aboutsummaryrefslogtreecommitdiff
path: root/editors/bless
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2004-11-28 10:24:23 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2004-11-28 10:24:23 +0000
commit7090b81205a40cc4ca66338948ab9b25e7db1195 (patch)
treef5d8231c1d314c186da8025da5afd4a6a78aa1ba /editors/bless
parent51c45e0d065ef0ac2f970c59490bf8b846d0b5db (diff)
downloadports-7090b81205a40cc4ca66338948ab9b25e7db1195.tar.gz
ports-7090b81205a40cc4ca66338948ab9b25e7db1195.zip
Update to 0.2.2.
Notes
Notes: svn path=/head/; revision=122654
Diffstat (limited to 'editors/bless')
-rw-r--r--editors/bless/Makefile10
-rw-r--r--editors/bless/distinfo4
-rw-r--r--editors/bless/files/patch-src::Makefile22
-rw-r--r--editors/bless/files/patch-src::gui::Makefile40
-rw-r--r--editors/bless/pkg-plist3
5 files changed, 13 insertions, 66 deletions
diff --git a/editors/bless/Makefile b/editors/bless/Makefile
index 1b18bc6b52de..20a2e89de22e 100644
--- a/editors/bless/Makefile
+++ b/editors/bless/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= bless
-PORTVERSION= 0.2.0
+PORTVERSION= 0.2.2
CATEGORIES= editors
-MASTER_SITES= http://home.gna.org/bless/
+MASTER_SITES= http://download.gna.org/bless/
MAINTAINER= bsd-sharp-list@forge.novell.com
COMMENT= A high quality, full featured hex editor
@@ -21,13 +21,11 @@ USE_X_PREFIX= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-DOCS= COPYING Changelog README
+DOCS= AUTHORS Changelog NEWS README
post-patch:
@${REINPLACE_CMD} -e 's|make|${GMAKE}|g' \
- ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|function pkg_config_check|pkg_config_check()|g' \
- ${WRKSRC}/configure
+ ${WRKSRC}/Makefile
.ifndef (NOPORTDOCS)
post-install:
diff --git a/editors/bless/distinfo b/editors/bless/distinfo
index 72235b6bd0d1..a7d0a83fcc27 100644
--- a/editors/bless/distinfo
+++ b/editors/bless/distinfo
@@ -1,2 +1,2 @@
-MD5 (bless-0.2.0.tar.gz) = f9e89bdc032c0a6ed4e9c989f4db3194
-SIZE (bless-0.2.0.tar.gz) = 232405
+MD5 (bless-0.2.2.tar.gz) = 90617231e3b43b1d359e3edaec3194cb
+SIZE (bless-0.2.2.tar.gz) = 234383
diff --git a/editors/bless/files/patch-src::Makefile b/editors/bless/files/patch-src::Makefile
index 83c02c1972a7..fe17bb47f25c 100644
--- a/editors/bless/files/patch-src::Makefile
+++ b/editors/bless/files/patch-src::Makefile
@@ -1,9 +1,9 @@
---- src/Makefile.orig Wed Oct 27 13:21:26 2004
-+++ src/Makefile Wed Oct 27 13:23:01 2004
-@@ -44,16 +44,16 @@
- -resource:gui/default.layout,default.layout
+--- src/Makefile.orig Sun Nov 28 04:02:39 2004
++++ src/Makefile Sun Nov 28 04:06:32 2004
+@@ -49,12 +49,12 @@
- bless.exe: $(GUI_SRC) $(BB_SRC) $(GUI_DRAWERS_SRC) $(GUI_AREAS_SRC) $(GUI_DIALOGS_SRC) $(UTIL_SRC)
+
+ bless.exe: $(GUI_SRC) $(BB_SRC) $(GUI_DRAWERS_SRC) $(GUI_AREAS_SRC) $(GUI_DIALOGS_SRC) $(UTIL_SRC) $(MISC_DEPS)
- $(MCS) -g -o bless.exe -t:exe -r:nunit.framework $(RESOURCES) -pkg:gtk-sharp -pkg:glade-sharp \
+ $(MCS) -g -o bless.exe -t:exe -r:nunit.framework $(RESOURCES) $(shell pkg-config --libs gtk-sharp glade-sharp) \
$(GUI_SRC) $(BB_SRC) $(GUI_DRAWERS_SRC) $(GUI_AREAS_SRC) $(GUI_DIALOGS_SRC) $(UTIL_SRC)
@@ -15,15 +15,3 @@
install: bless.exe
install -c -d $(PREFIX)/lib/bless
-- install -c bless.exe /usr/local/lib/bless
-+ install -c bless.exe $(PREFIX)/lib/bless
- echo "mono $(PREFIX)/lib/bless/bless.exe \"\$$@\"" > bless
- install -c -d $(PREFIX)/bin
- install -c bless $(PREFIX)/bin
-@@ -63,4 +63,4 @@
- rm -rf $(PREFIX)/lib/bless
- rm $(PREFIX)/bin/bless
- clean:
-- rm -rf $(DLLS)
-\ No newline at end of file
-+ rm -rf $(DLLS)
diff --git a/editors/bless/files/patch-src::gui::Makefile b/editors/bless/files/patch-src::gui::Makefile
deleted file mode 100644
index dbb81fb0432d..000000000000
--- a/editors/bless/files/patch-src::gui::Makefile
+++ /dev/null
@@ -1,40 +0,0 @@
---- src/gui/Makefile.orig Wed Oct 27 13:13:51 2004
-+++ src/gui/Makefile Wed Oct 27 13:14:03 2004
-@@ -5,7 +5,7 @@
- DLLS= FontDrawer.dll
-
- exe:
-- $(MCS) -r:nunit.framework -pkg:gtk-sharp FontDrawer.cs
-+ $(MCS) -r:nunit.framework $(shell pkg-config --libs gtk-sharp) FontDrawer.cs
-
- test: fd-test oa-test
-
-@@ -22,21 +22,21 @@
- nunit-console DataView.dll
-
- FontDrawer.dll: FontDrawer.cs
-- $(MCS) -t:library -r:nunit.framework -pkg:gtk-sharp FontDrawer.cs
-+ $(MCS) -t:library -r:nunit.framework $(shell pkg-config --libs gtk-sharp) FontDrawer.cs
-
- OffsetArea.dll: OffsetArea.cs
-- $(MCS) -t:library -r:nunit.framework -pkg:gtk-sharp OffsetArea.cs Area.cs FontDrawer.cs
-+ $(MCS) -t:library -r:nunit.framework $(shell pkg-config --libs gtk-sharp) OffsetArea.cs Area.cs FontDrawer.cs
-
- HexArea.dll: HexArea.cs
-- $(MCS) -t:library -r:nunit.framework -pkg:gtk-sharp HexArea.cs Area.cs FontDrawer.cs
-+ $(MCS) -t:library -r:nunit.framework $(shell pkg-config --libs gtk-sharp) HexArea.cs Area.cs FontDrawer.cs
-
- DataView.dll: DataView.cs Area.cs HexArea.cs OffsetArea.cs SeparatorArea.cs AsciiArea.cs FontDrawer.cs
-- $(MCS) -t:library -r:nunit.framework -pkg:gtk-sharp DataView.cs Area.cs HexArea.cs OffsetArea.cs SeparatorArea.cs AsciiArea.cs FontDrawer.cs
-+ $(MCS) -t:library -r:nunit.framework $(shell pkg-config --libs gtk-sharp) DataView.cs Area.cs HexArea.cs OffsetArea.cs SeparatorArea.cs AsciiArea.cs FontDrawer.cs
-
-
-
- %.dll:%.cs
-- $(MCS) -t:library -r:nunit.framework -pkg:gtk-sharp $<
-+ $(MCS) -t:library -r:nunit.framework $(shell pkg-config --libs gtk-sharp) $<
-
- clean:
-- rm -rf $(DLLS)
-\ No newline at end of file
-+ rm -rf $(DLLS)
diff --git a/editors/bless/pkg-plist b/editors/bless/pkg-plist
index 7c7864e1b9af..8bd1c7e87da4 100644
--- a/editors/bless/pkg-plist
+++ b/editors/bless/pkg-plist
@@ -1,7 +1,8 @@
bin/bless
lib/bless/bless.exe
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/Changelog
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm lib/bless