aboutsummaryrefslogtreecommitdiff
path: root/editors/codelite/files
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-01-21 16:18:52 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-01-21 16:18:52 +0000
commit17d64225a4d41f8c7b6f01db09c7a32fa0bdaa81 (patch)
tree5183c8c7110ad22e51af2678b66cec7a709658f4 /editors/codelite/files
parent2567b372517cd6c29cc845e12d602e260f431f86 (diff)
downloadports-17d64225a4d41f8c7b6f01db09c7a32fa0bdaa81.tar.gz
ports-17d64225a4d41f8c7b6f01db09c7a32fa0bdaa81.zip
- Fix llvm-devel include paths (broken after r332935 [1] [MFH]
- Fix build on modern compilers [MFH] - STAGE-clean - Convert to new LIB_DEPENDS format - Convert to USES=dos2unix Reported by: John J. Rushford <jjr@alisa.org>
Notes
Notes: svn path=/head/; revision=340617
Diffstat (limited to 'editors/codelite/files')
-rw-r--r--editors/codelite/files/patch-CMakeLists.txt6
-rw-r--r--editors/codelite/files/patch-CodeLite_cpptoken.h11
2 files changed, 14 insertions, 3 deletions
diff --git a/editors/codelite/files/patch-CMakeLists.txt b/editors/codelite/files/patch-CMakeLists.txt
index 94ee53871bd0..1989460ead69 100644
--- a/editors/codelite/files/patch-CMakeLists.txt
+++ b/editors/codelite/files/patch-CMakeLists.txt
@@ -7,9 +7,9 @@
- set( CLANG_INCLUDE "${CL_SRC_ROOT}/sdk/clang/Linux/${ARCH_NAME}/include" )
- set( CLANG_LIBRARY "-L${CL_SRC_ROOT}/sdk/clang/Linux/${ARCH_NAME}/lib -lclang" )
- set( CLANG_BINARY "${CL_SRC_ROOT}/sdk/clang/Linux/${ARCH_NAME}/lib/libclang.so")
-+ set( CLANG_INCLUDE "%%LOCALBASE%%/include" )
-+ set( CLANG_LIBRARY "-L%%LOCALBASE%%/lib/ -lclang" )
-+ set( CLANG_BINARY "%%LOCALBASE%%/lib/libclang.so")
++ set( CLANG_INCLUDE "%%LOCALBASE%%/llvm-devel/include" )
++ set( CLANG_LIBRARY "-L%%LOCALBASE%%/llvm-devel/lib/ -lclang" )
++ set( CLANG_BINARY "%%LOCALBASE%%/llvm-devel/lib/libclang.so")
endif()
message( "-- clang link line ${CLANG_LIBRARY} ")
diff --git a/editors/codelite/files/patch-CodeLite_cpptoken.h b/editors/codelite/files/patch-CodeLite_cpptoken.h
new file mode 100644
index 000000000000..085de87482e1
--- /dev/null
+++ b/editors/codelite/files/patch-CodeLite_cpptoken.h
@@ -0,0 +1,11 @@
+--- CodeLite/cpptoken.h.orig 2014-01-21 10:05:01.000000000 +0100
++++ CodeLite/cpptoken.h 2014-01-21 10:05:10.000000000 +0100
+@@ -87,7 +87,7 @@
+ void print();
+
+ // Provide lower-than operator so we can use std::list::sort method
+- bool operator < (const CppToken& rhs) {
++ bool operator < (const CppToken& rhs) const {
+ return filename < rhs.filename;
+ }
+ };