aboutsummaryrefslogtreecommitdiff
path: root/editors/color-mate
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-10-07 15:59:37 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-10-07 15:59:37 +0000
commita7c450f8c2076da95cd9bf9e28a11b4c8baa8f25 (patch)
tree2aa2f22676fc4fa4c6f934a34ef7f085765a3f9e /editors/color-mate
parent6735c4c55534e92ba8d0746cb4e37745b80f6ff1 (diff)
downloadports-a7c450f8c2076da95cd9bf9e28a11b4c8baa8f25.tar.gz
ports-a7c450f8c2076da95cd9bf9e28a11b4c8baa8f25.zip
Color customizing module for Emacsen
Notes
Notes: svn path=/head/; revision=22226
Diffstat (limited to 'editors/color-mate')
-rw-r--r--editors/color-mate/Makefile75
-rw-r--r--editors/color-mate/distinfo1
-rw-r--r--editors/color-mate/files/theme_build.sh18
-rw-r--r--editors/color-mate/pkg-comment1
-rw-r--r--editors/color-mate/pkg-descr23
-rw-r--r--editors/color-mate/pkg-plist124
6 files changed, 242 insertions, 0 deletions
diff --git a/editors/color-mate/Makefile b/editors/color-mate/Makefile
new file mode 100644
index 000000000000..6dc2d0cf5cdf
--- /dev/null
+++ b/editors/color-mate/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: color-mate for emacs
+# Version required: 1.0.0.1
+# Date created: 99/09/29
+# Whom: Satoshi Taoka <taoka@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= color-mate-10.0.1
+CATEGORIES= editors elisp
+MASTER_SITES= http://www.netlab.is.tsukuba.ac.jp/~yokota/archive/
+
+MAINTAINER= taoka@FreeBSD.org
+
+BUILD_DEPENDS= lndir:${PORTSDIR}/x11/XFree86 \
+ showrgb:${PORTSDIR}/x11/XFree86
+
+USE_PERL5= yes
+
+EMACSDIR= ${PREFIX}/share/emacs/site-lisp
+ELISPDIR= ${EMACSDIR}/color-mate
+SITEPKGDIR= ${PREFIX}/lib/xemacs/site-packages
+XELISPDIR= ${SITEPKGDIR}/lisp/color-mate
+THEME_DIR= ${ELISPDIR}/theme
+DOCDIR= ${PREFIX}/share/doc/color-mate
+MANIFEST= MANIFEST.color-mate
+
+do-build:
+# Create color-mate-rgb.el
+ cd ${WRKSRC}; \
+ (showrgb | ${PERL5} ./rgb2el.pl > ./color-mate-rgb.el ) || ( ${ECHO} "Make rgb table from color-mate-rgb.el.std" ; ${CP} ./color-mate-rgb.el.std ./color-mate-rgb.el)
+# Create Xresource for theme
+ cd ${WRKSRC}/theme; \
+ ${SH} ${FILESDIR}/theme_build.sh
+ ${SED} -e 's,@INSTALLPATH@,${XELISPDIR},' ${WRKSRC}/Dot.emacs.default.in \
+ > ${WRKDIR}/color-mate-startup.el
+ ${ECHO} "(provide 'color-mate-startup)" >> ${WRKDIR}/color-mate-startup.el
+ ${SED} -e 's,@INSTALLPATH@,${XELISPDIR},' ${WRKSRC}/Dot.emacs.default.in \
+ > ${WRKDIR}/color-mate-startup.xemacs.el
+ ${ECHO} "(provide 'color-mate-startup)" >> ${WRKDIR}/color-mate-startup.xemacs.el
+
+do-install:
+ ${MKDIR} ${ELISPDIR} ${DOCDIR} ${THEME_DIR} ${XELISPDIR} ${ELISPDIR}/kanakan-cursor ${ELISPDIR}/contrib
+ ${INSTALL_DATA} ${WRKSRC}/*.el ${ELISPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/kanakan-cursor/*.el ${ELISPDIR}/kanakan-cursor/
+ ${INSTALL_DATA} ${WRKSRC}/contrib/*.el ${ELISPDIR}/contrib/
+ ${INSTALL_DATA} ${WRKSRC}/contrib/README ${ELISPDIR}/contrib/
+ ${INSTALL_DATA} ${WRKSRC}/contrib/cm_select.sh.in ${ELISPDIR}/contrib/
+ ${INSTALL_DATA} ${WRKSRC}/theme/* ${THEME_DIR}
+ ${RM} ${THEME_DIR}/Makefile*
+ ${MV} ${THEME_DIR}/README ${THEME_DIR}/README.jp
+ ${INSTALL_SCRIPT} ${FILESDIR}/theme_build.sh ${THEME_DIR}
+ ${INSTALL_DATA} ${WRKDIR}/color-mate-startup.el ${ELISPDIR}/../
+.if !defined(NOPORTDOCS)
+ ${INSTALL_DATA} ${WRKSRC}/README.color-mate ${DOCDIR}/README.color-mate.jp
+ ${INSTALL_DATA} ${WRKSRC}/README.color-mate.eng ${DOCDIR}/README.color-mate.eng
+ ${INSTALL_DATA} ${WRKSRC}/Q_and_A.color-mate ${DOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/QuickStart.color-mate ${DOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Customize.txt ${DOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Dot.emacs.default.in ${DOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/kanakan-cursor/README.kanakan-cursor ${DOCDIR}/README.kanakan-cursor.jp
+ ${INSTALL_DATA} ${WRKSRC}/kanakan-cursor/README.kanakan-cursor.eng ${DOCDIR}/README.kanakan-cursor.eng
+.endif
+#
+# For XEmacs
+ cd ${XELISPDIR}; lndir ${ELISPDIR}
+ ${RM} -f ${WRKDIR}/${MANIFEST}
+ emacsdir=`${ECHO} ${SITEPKGDIR} | ${SED} -e "s;^${PREFIX}/;;"`; \
+ ${CAT} ${PLIST} | ${GREP} -e "^$${emacsdir}" | \
+ ${SED} -e "s;^$${emacsdir}/;;" > ${WRKDIR}/${MANIFEST}
+ ${MKDIR} ${SITEPKGDIR}/pkginfo
+ ${INSTALL_DATA} ${WRKDIR}/${MANIFEST} ${SITEPKGDIR}/pkginfo/
+ ${INSTALL_DATA} ${WRKDIR}/color-mate-startup.xemacs.el ${XELISPDIR}/../color-mate-startup.el
+
+.include <bsd.port.mk>
diff --git a/editors/color-mate/distinfo b/editors/color-mate/distinfo
new file mode 100644
index 000000000000..a4f3a221d159
--- /dev/null
+++ b/editors/color-mate/distinfo
@@ -0,0 +1 @@
+MD5 (color-mate-10.0.1.tar.gz) = d25eadf169f9fb762e7c059dc839786f
diff --git a/editors/color-mate/files/theme_build.sh b/editors/color-mate/files/theme_build.sh
new file mode 100644
index 000000000000..fb97659e17d2
--- /dev/null
+++ b/editors/color-mate/files/theme_build.sh
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+# from color-mate-10.0.1/theme/Makefile
+for file in *.xdef; do
+ dist=`echo $file| sed 's/xdef$/X/'`
+ cat $file ./Xdefaults.cpp \
+ | gcc -E - \
+ | sed -e '/^# *[0-9][0-9]* *.*$$/d' \
+ -e 's/ $$//' \
+ -e /CM_BG/d \
+ -e /CM_FG/d \
+ -e /CM_BUTTON_BG/d \
+ -e /CM_BUTTON_FG/d \
+ -e /CM_BUTTON_SHAPE/d \
+ -e /CM_HIGHLIGHT_FG/d \
+ -e /CM_CHECK/d \
+ | tail +`wc $file | awk '{print $$1 + 1}'` > $dist
+done
diff --git a/editors/color-mate/pkg-comment b/editors/color-mate/pkg-comment
new file mode 100644
index 000000000000..5177f70a34a9
--- /dev/null
+++ b/editors/color-mate/pkg-comment
@@ -0,0 +1 @@
+Color customizing module for Emacsen
diff --git a/editors/color-mate/pkg-descr b/editors/color-mate/pkg-descr
new file mode 100644
index 000000000000..b403a4923901
--- /dev/null
+++ b/editors/color-mate/pkg-descr
@@ -0,0 +1,23 @@
+"Color-Mate" is color customizing module for emacs/mule/xemacs/"Mule for
+Win32"/Meadow(Emacs20 for win32).
+
+"Color-Mate" requires emacs19/mule2.3 or upper version of emacs. And
+also requires hilit19.el(emacs/mule), font-lock.el(emacs/mule/xemacs),
+paren.el(emacs/mule/xemacs). Usually, these three files are install
+with emacs. If you want to more, see
+${PREFIX}/share/doc/color-mate/README.color-mate.eng
+
+If you can use imput method(Wnn, Canna, Sj3, skk, leim, WindowsIME),
+"Color-Mate" is coloring imput method with "kanakan-sousor". If you
+want to more, see
+${PREFIX}/share/doc/color-mate/README.kanakan-cursor.eng
+
+To use Color-Mate, put the next line into your ~/.emacs:
+
+ (require 'color-mate-startup)
+
+and the next file into ~/.Xdefaults
+
+/usr/local/share/emacs/site-lisp/color-mate/theme/SunnyDay.X
+
+WWW: http://www.netlab.is.tsukuba.ac.jp/~yokota/izumi/color-mate/
diff --git a/editors/color-mate/pkg-plist b/editors/color-mate/pkg-plist
new file mode 100644
index 000000000000..7314f59d72a9
--- /dev/null
+++ b/editors/color-mate/pkg-plist
@@ -0,0 +1,124 @@
+share/emacs/site-lisp/color-mate/color-mate-compile.el
+share/emacs/site-lisp/color-mate/color-mate-e20-fontset.el
+share/emacs/site-lisp/color-mate/color-mate-emacs-frame.el
+share/emacs/site-lisp/color-mate/color-mate-face.el
+share/emacs/site-lisp/color-mate/color-mate-mule-fontset.el
+share/emacs/site-lisp/color-mate/color-mate-rgb.el
+share/emacs/site-lisp/color-mate/color-mate-util.el
+share/emacs/site-lisp/color-mate/color-mate-xemacs-frame.el
+share/emacs/site-lisp/color-mate/color-mate.el
+share/emacs/site-lisp/color-mate/contrib/README
+share/emacs/site-lisp/color-mate/contrib/cm_select.el
+share/emacs/site-lisp/color-mate/contrib/cm_select.sh.in
+share/emacs/site-lisp/color-mate/contrib/contrib-compile.el
+share/emacs/site-lisp/color-mate/contrib/summary-color.el
+share/emacs/site-lisp/color-mate/contrib/vregister.el
+share/emacs/site-lisp/color-mate/kanakan-cursor/canna-cursor.el
+share/emacs/site-lisp/color-mate/kanakan-cursor/egg-cursor.el
+share/emacs/site-lisp/color-mate/kanakan-cursor/kanakan-cursor-compile.el
+share/emacs/site-lisp/color-mate/kanakan-cursor/leim-cursor.el
+share/emacs/site-lisp/color-mate/kanakan-cursor/sj3-cursor.el
+share/emacs/site-lisp/color-mate/kanakan-cursor/skk-cursor.el
+share/emacs/site-lisp/color-mate/kanakan-cursor/skk-cursor2.el
+share/emacs/site-lisp/color-mate/kanakan-cursor/win32-cursor.el
+share/emacs/site-lisp/color-mate/theme/GreenTea.X
+share/emacs/site-lisp/color-mate/theme/GreenTea.el
+share/emacs/site-lisp/color-mate/theme/GreenTea.xdef
+share/emacs/site-lisp/color-mate/theme/Maron.X
+share/emacs/site-lisp/color-mate/theme/Maron.el
+share/emacs/site-lisp/color-mate/theme/Maron.xdef
+share/emacs/site-lisp/color-mate/theme/Null.X
+share/emacs/site-lisp/color-mate/theme/Null.el
+share/emacs/site-lisp/color-mate/theme/Null.xdef
+share/emacs/site-lisp/color-mate/theme/README.jp
+share/emacs/site-lisp/color-mate/theme/Stone.X
+share/emacs/site-lisp/color-mate/theme/Stone.el
+share/emacs/site-lisp/color-mate/theme/Stone.xdef
+share/emacs/site-lisp/color-mate/theme/SunnyDay-LCD.X
+share/emacs/site-lisp/color-mate/theme/SunnyDay-LCD.el
+share/emacs/site-lisp/color-mate/theme/SunnyDay-LCD.xdef
+share/emacs/site-lisp/color-mate/theme/SunnyDay.X
+share/emacs/site-lisp/color-mate/theme/SunnyDay.el
+share/emacs/site-lisp/color-mate/theme/SunnyDay.xdef
+share/emacs/site-lisp/color-mate/theme/WaterWorld.X
+share/emacs/site-lisp/color-mate/theme/WaterWorld.el
+share/emacs/site-lisp/color-mate/theme/WaterWorld.xdef
+share/emacs/site-lisp/color-mate/theme/Wine.X
+share/emacs/site-lisp/color-mate/theme/Wine.el
+share/emacs/site-lisp/color-mate/theme/Wine.xdef
+share/emacs/site-lisp/color-mate/theme/Xdefaults.cpp
+share/emacs/site-lisp/color-mate/theme/color-mate-theme-compile.el
+share/emacs/site-lisp/color-mate/theme/theme_build.sh
+share/emacs/site-lisp/color-mate-startup.el
+@comment Almost next files for XEmacs are symlinks :-)
+lib/xemacs/site-packages/lisp/color-mate/theme/GreenTea.X
+lib/xemacs/site-packages/lisp/color-mate/theme/GreenTea.el
+lib/xemacs/site-packages/lisp/color-mate/theme/GreenTea.xdef
+lib/xemacs/site-packages/lisp/color-mate/theme/README.jp
+lib/xemacs/site-packages/lisp/color-mate/theme/theme_build.sh
+lib/xemacs/site-packages/lisp/color-mate/theme/Maron.X
+lib/xemacs/site-packages/lisp/color-mate/theme/Maron.el
+lib/xemacs/site-packages/lisp/color-mate/theme/Maron.xdef
+lib/xemacs/site-packages/lisp/color-mate/theme/Null.X
+lib/xemacs/site-packages/lisp/color-mate/theme/Null.el
+lib/xemacs/site-packages/lisp/color-mate/theme/Null.xdef
+lib/xemacs/site-packages/lisp/color-mate/theme/Stone.X
+lib/xemacs/site-packages/lisp/color-mate/theme/Stone.el
+lib/xemacs/site-packages/lisp/color-mate/theme/Stone.xdef
+lib/xemacs/site-packages/lisp/color-mate/theme/SunnyDay-LCD.X
+lib/xemacs/site-packages/lisp/color-mate/theme/SunnyDay-LCD.el
+lib/xemacs/site-packages/lisp/color-mate/theme/SunnyDay-LCD.xdef
+lib/xemacs/site-packages/lisp/color-mate/theme/SunnyDay.X
+lib/xemacs/site-packages/lisp/color-mate/theme/SunnyDay.el
+lib/xemacs/site-packages/lisp/color-mate/theme/SunnyDay.xdef
+lib/xemacs/site-packages/lisp/color-mate/theme/WaterWorld.X
+lib/xemacs/site-packages/lisp/color-mate/theme/WaterWorld.el
+lib/xemacs/site-packages/lisp/color-mate/theme/WaterWorld.xdef
+lib/xemacs/site-packages/lisp/color-mate/theme/Wine.X
+lib/xemacs/site-packages/lisp/color-mate/theme/Wine.el
+lib/xemacs/site-packages/lisp/color-mate/theme/Wine.xdef
+lib/xemacs/site-packages/lisp/color-mate/theme/Xdefaults.cpp
+lib/xemacs/site-packages/lisp/color-mate/theme/color-mate-theme-compile.el
+lib/xemacs/site-packages/lisp/color-mate/kanakan-cursor/canna-cursor.el
+lib/xemacs/site-packages/lisp/color-mate/kanakan-cursor/egg-cursor.el
+lib/xemacs/site-packages/lisp/color-mate/kanakan-cursor/kanakan-cursor-compile.el
+lib/xemacs/site-packages/lisp/color-mate/kanakan-cursor/leim-cursor.el
+lib/xemacs/site-packages/lisp/color-mate/kanakan-cursor/sj3-cursor.el
+lib/xemacs/site-packages/lisp/color-mate/kanakan-cursor/skk-cursor.el
+lib/xemacs/site-packages/lisp/color-mate/kanakan-cursor/skk-cursor2.el
+lib/xemacs/site-packages/lisp/color-mate/kanakan-cursor/win32-cursor.el
+lib/xemacs/site-packages/lisp/color-mate/contrib/cm_select.el
+lib/xemacs/site-packages/lisp/color-mate/contrib/contrib-compile.el
+lib/xemacs/site-packages/lisp/color-mate/contrib/summary-color.el
+lib/xemacs/site-packages/lisp/color-mate/contrib/vregister.el
+lib/xemacs/site-packages/lisp/color-mate/contrib/README
+lib/xemacs/site-packages/lisp/color-mate/contrib/cm_select.sh.in
+lib/xemacs/site-packages/lisp/color-mate/color-mate-compile.el
+lib/xemacs/site-packages/lisp/color-mate/color-mate-e20-fontset.el
+lib/xemacs/site-packages/lisp/color-mate/color-mate-emacs-frame.el
+lib/xemacs/site-packages/lisp/color-mate/color-mate-face.el
+lib/xemacs/site-packages/lisp/color-mate/color-mate-mule-fontset.el
+lib/xemacs/site-packages/lisp/color-mate/color-mate-rgb.el
+lib/xemacs/site-packages/lisp/color-mate/color-mate-util.el
+lib/xemacs/site-packages/lisp/color-mate/color-mate-xemacs-frame.el
+lib/xemacs/site-packages/lisp/color-mate/color-mate.el
+lib/xemacs/site-packages/lisp/color-mate-startup.el
+lib/xemacs/site-packages/pkginfo/MANIFEST.color-mate
+share/doc/color-mate/Customize.txt
+share/doc/color-mate/Dot.emacs.default.in
+share/doc/color-mate/Q_and_A.color-mate
+share/doc/color-mate/QuickStart.color-mate
+share/doc/color-mate/README.color-mate.eng
+share/doc/color-mate/README.color-mate.jp
+share/doc/color-mate/README.kanakan-cursor.eng
+share/doc/color-mate/README.kanakan-cursor.jp
+@dirrm share/emacs/site-lisp/color-mate/contrib
+@dirrm share/emacs/site-lisp/color-mate/kanakan-cursor
+@dirrm share/emacs/site-lisp/color-mate/theme
+@dirrm share/emacs/site-lisp/color-mate
+@dirrm lib/xemacs/site-packages/lisp/color-mate/contrib
+@dirrm lib/xemacs/site-packages/lisp/color-mate/kanakan-cursor
+@dirrm lib/xemacs/site-packages/lisp/color-mate/theme
+@dirrm lib/xemacs/site-packages/lisp/color-mate
+@dirrm share/doc/color-mate
+