aboutsummaryrefslogtreecommitdiff
path: root/editors/e3
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-07-12 07:10:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-07-12 07:10:18 +0000
commit010692116b663718ad511fbaddae9f127fae8e02 (patch)
tree385bee12f34faedac8f7f3d0863ec683ae931dc4 /editors/e3
parentb316d4c9eca31c9e20fdc68c758851f1e0dc27f9 (diff)
downloadports-010692116b663718ad511fbaddae9f127fae8e02.tar.gz
ports-010692116b663718ad511fbaddae9f127fae8e02.zip
- Update to 2,8
PR: 148508 Submitted by: Toshihiko ARAI <arai.toshihiko@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=257664
Diffstat (limited to 'editors/e3')
-rw-r--r--editors/e3/Makefile13
-rw-r--r--editors/e3/distinfo6
-rw-r--r--editors/e3/files/patch-Makefile25
-rw-r--r--editors/e3/files/patch-e3.asm6
4 files changed, 33 insertions, 17 deletions
diff --git a/editors/e3/Makefile b/editors/e3/Makefile
index eb49d0ab5dd4..183c628550da 100644
--- a/editors/e3/Makefile
+++ b/editors/e3/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= e3
-PORTVERSION= 2.7.0
+PORTVERSION= 2.8
PORTEPOCH= 3
CATEGORIES= editors
-MASTER_SITES= http://www.sax.de/~adlibit/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/60/6/}
+MASTER_SITES= http://sites.google.com/site/e3editor/Home/
+EXTRACT_SUFX= .tgz
MAINTAINER= joseph@randomnetworks.com
COMMENT= A full featured text editor written in assembler
@@ -24,6 +24,13 @@ ONLY_FOR_ARCHS= i386
MAN1= e3.1
PLIST_FILES= bin/e3 bin/e3em bin/e3ne bin/e3pi bin/e3vi bin/e3ws
+FETCH_ARGS= -p -o ${DISTDIR}/${DISTFILES}
+
+do-fetch:
+ @if [ ! -f ${DISTDIR}/${DISTFILES} ]; then \
+ ${FETCH_CMD} ${MASTER_SITES}${DISTFILES}?attredirects=0\&d=1 ; \
+ fi
+
post-patch:
@${REINPLACE_CMD} -e '/SYS_sigaction 46/s/46/342/' ${WRKSRC}/e3.h
diff --git a/editors/e3/distinfo b/editors/e3/distinfo
index 1f36cf626df7..351baf0752f7 100644
--- a/editors/e3/distinfo
+++ b/editors/e3/distinfo
@@ -1,3 +1,3 @@
-MD5 (e3-2.7.0.tar.gz) = a76dd61c52a80a1f4d3938a4ce54c62e
-SHA256 (e3-2.7.0.tar.gz) = ab45362282b3b3e987ef40a0c6b300aa7267fcc0bb1f9879d09bbb6445eec18d
-SIZE (e3-2.7.0.tar.gz) = 239477
+MD5 (e3-2.8.tgz) = 0120bb073133ad26a054b35f88333183
+SHA256 (e3-2.8.tgz) = 035737d0cc82b287386fdff8682b2c23ef620d7ef97dff7a1b1fe1777e4c4fb7
+SIZE (e3-2.8.tgz) = 119939
diff --git a/editors/e3/files/patch-Makefile b/editors/e3/files/patch-Makefile
index 6773f474575b..cf7c7cc97607 100644
--- a/editors/e3/files/patch-Makefile
+++ b/editors/e3/files/patch-Makefile
@@ -1,17 +1,26 @@
---- Makefile.orig Fri Nov 9 10:38:26 2001
-+++ Makefile Mon Dec 24 17:54:32 2001
-@@ -8,7 +8,7 @@
+--- Makefile.orig 2010-05-28 03:58:59.000000000 +0900
++++ Makefile 2010-07-12 10:10:41.000000000 +0900
+@@ -7,7 +7,7 @@
# 2. edit dest dir prefix if you want....
-PREFIX='/usr/local'
+PREFIX?='/usr/local'
- #PREFIX=/boot/home
-
-@@ -86,13 +86,13 @@
- ln -sf $(BINDIR)/e3 $(BINDIR)/e3ne
+ # 3. for programmers only: debugging in 64 bit Linux
+ DEBUG=false
+@@ -43,7 +43,7 @@
+ chmod +x e3
else
+ echo $(ASVER)
+- nasm -O2 $(AFLAGS) -o e3.o e3.asm -l e3.lst -D$(OS) -D$(EXMODE)
++ nasm -O2 $(AFLAGS) -o e3.o e3.asm -l e3.lst -D$(OS)
+ ld -s -o e3 e3.o
+ strip --remove-section .comment e3
+ endif
+@@ -72,13 +72,13 @@
+
+ install: e3
install -d $(PREFIX) $(BINDIR) $(MANDIR)
- install -m 755 e3 $(BINDIR)
+ ${BSD_INSTALL_PROGRAM} e3 $(BINDIR)
@@ -22,6 +31,6 @@
ln -sf $(BINDIR)/e3 $(BINDIR)/e3ne
- install -m 644 e3.man $(MANDIR)/e3.$(MANSEC)
+ ${BSD_INSTALL_MAN} e3.man $(MANDIR)/e3.$(MANSEC)
- endif
clean:
+ rm -f e3*.o e3*.lst e3.tmp e3 e3em e3pi e3vi e3ws e3ne *~
diff --git a/editors/e3/files/patch-e3.asm b/editors/e3/files/patch-e3.asm
index 4401340bc403..73cf10f913ca 100644
--- a/editors/e3/files/patch-e3.asm
+++ b/editors/e3/files/patch-e3.asm
@@ -1,6 +1,6 @@
---- e3.asm Wed Jan 3 14:21:19 2001
-+++ e3.asm.new Wed Jan 3 14:21:47 2001
-@@ -3620,8 +3620,8 @@
+--- e3.asm.orig 2010-05-10 01:16:47.000000000 +0900
++++ e3.asm 2010-07-12 10:01:52.000000000 +0900
+@@ -5813,8 +5813,8 @@
dw KeyVICmdI -_start ;33h
dw KeyVICmdR -_start ;34h
dw KeyVICmdd -_start ;35h