aboutsummaryrefslogtreecommitdiff
path: root/editors/emacs-devel
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2018-04-26 13:49:09 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2018-04-26 13:49:09 +0000
commitc85daea952f8e404cf3587787b74301042c2a4a3 (patch)
tree73629039cb72c8ced6cd6de0e02f47febecd00a6 /editors/emacs-devel
parent9d1454194d77e13f183ac6f385c564b8d0f6d1a6 (diff)
downloadports-c85daea952f8e404cf3587787b74301042c2a4a3.tar.gz
ports-c85daea952f8e404cf3587787b74301042c2a4a3.zip
Emacs ports: Conform to 'Order of Variables in Port Makefiles' in PH
Notes
Notes: svn path=/head/; revision=468348
Diffstat (limited to 'editors/emacs-devel')
-rw-r--r--editors/emacs-devel/Makefile34
1 files changed, 15 insertions, 19 deletions
diff --git a/editors/emacs-devel/Makefile b/editors/emacs-devel/Makefile
index 0afd8fcd73b1..14f99d893af2 100644
--- a/editors/emacs-devel/Makefile
+++ b/editors/emacs-devel/Makefile
@@ -24,32 +24,26 @@ nox_PKGNAMESUFFIX= -devel_nox
USES= autoreconf:build cpe gmake localbase:ldflags makeinfo ncurses \
pkgconfig
+CPE_VENDOR= gnu
USE_GITHUB= yes
GH_ACCOUNT= emacs-mirror
GH_TAGNAME= d599dce
-CPE_VENDOR= gnu
-EMACS_VER= 27.0.50
-EMACS_REV= 20180220
GNU_CONFIGURE= yes
-INFO_PATH= ${DATADIR_REL}/info
-
-SUB_FILES= sources.el
-SUB_LIST= EMACS_VER=${EMACS_VER}
-
CONFIGURE_ARGS= --with-gameuser=games:games
-CONFIGURE_ENV= ac_cv_prog_liblockfile=no
-
-PLIST_SUB= EMACS_VER=${EMACS_VER} GNU_HOST=${CONFIGURE_TARGET}
-
CONFIGURE_ENV= ac_cv_header_sys_sysinfo_h=no \
ac_cv_prog_liblockfile=no
-INFO= ada-mode auth autotype bovine calc ccmode cl dbus dired-x ebrowse ede \
- ediff edt efaq eieio eintr elisp emacs emacs-gnutls emacs-mime epa erc \
- ert eshell eudc eww flymake forms gnus htmlfontify idlwave ido info \
- mairix-el message mh-e newsticker nxml-mode octave-mode org pcl-cvs pgg \
- rcirc reftex remember sasl sc semantic ses sieve smtpmail speedbar \
- srecode todo-mode tramp url vhdl-mode vip viper widget wisent woman
+INFO= ada-mode auth autotype bovine calc ccmode cl dbus dired-x \
+ ebrowse ede ediff edt efaq eieio eintr elisp emacs emacs-gnutls \
+ emacs-mime epa erc ert eshell eudc eww flymake forms gnus \
+ htmlfontify idlwave ido info mairix-el message mh-e newsticker \
+ nxml-mode octave-mode org pcl-cvs pgg rcirc reftex remember \
+ sasl sc semantic ses sieve smtpmail speedbar srecode todo-mode \
+ tramp url vhdl-mode vip viper widget wisent woman
+INFO_PATH= ${DATADIR_REL}/info
+PLIST_SUB= EMACS_VER=${EMACS_VER} GNU_HOST=${CONFIGURE_TARGET}
+SUB_FILES= sources.el
+SUB_LIST= EMACS_VER=${EMACS_VER}
OPTIONS_DEFINE= ACL DBUS GCONF GNUTLS GSETTINGS LCMS2 LLDB M17N MAILUTILS \
MODULES OTF SCROLLBARS SOURCES THREADS XFT XIM XML XWIDGETS
@@ -165,7 +159,6 @@ XWIDGETS_CONFIGURE_WITH= xwidgets
XWIDGETS_LIB_DEPENDS= libwebkit2gtk-4.0.so:www/webkit2-gtk3
XWIDGETS_IMPLIES= GTK3
-
.if ${FLAVOR:U} == nox
CONFIGURE_ARGS+= --with-sound=no --without-cairo --without-dbus \
--without-gconf --without-gif --without-gsettings \
@@ -185,6 +178,9 @@ USE_XORG= ice sm x11 xcb xext xfixes xinerama xmu xrandr xt
USES+= desktop-file-utils
.endif
+EMACS_VER= 27.0.50
+EMACS_REV= 20180220
+
.include <bsd.port.options.mk>
# has graphics/ImageMagick been compiled with OPENMP?