aboutsummaryrefslogtreecommitdiff
path: root/editors/emacs.app/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-09-28 20:06:41 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-09-28 20:06:41 +0000
commitf01fc2a361d2433559d666afa48ac26a958ae2f3 (patch)
tree43ae0b0d5da062dd26f710266b640f551f60d612 /editors/emacs.app/Makefile
parentfe0bd7cc5e3a46c63b95f648cc45c1ade3d24d51 (diff)
downloadports-f01fc2a361d2433559d666afa48ac26a958ae2f3.tar.gz
ports-f01fc2a361d2433559d666afa48ac26a958ae2f3.zip
This is GNU Emacs ported to OS X and GNUstep, based on the earlier
Rhapsody, OPENSTEP, and NeXTSTEP versions. This port offers superior platform support for MacOS X and GNUstep, including full desktop integration (dock, drag/drop, etc.), standard keybindings, use of standard Font, Color, and File open/save panels, and support for Services. Via GNUstep, it provides anti-aliased font rendering on Linux and other Unix systems. This port is based on GNU Emacs 23 from CVS. PR: 103510 Submitted by: Gürkan Sengün
Notes
Notes: svn path=/head/; revision=174054
Diffstat (limited to 'editors/emacs.app/Makefile')
-rw-r--r--editors/emacs.app/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/editors/emacs.app/Makefile b/editors/emacs.app/Makefile
new file mode 100644
index 000000000000..6bff35281eaa
--- /dev/null
+++ b/editors/emacs.app/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: emacs.app
+# Date created: 4 Sep 2006
+# Whom: gurkan@linuks.mine.nu
+#
+# $FreeBSD$
+#
+
+PORTNAME= emacs.app
+PORTVERSION= 9.0
+CATEGORIES= editors
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= emacs-app
+DISTNAME= emacs-23.0.0_NS-${PORTVERSION}pre3b
+
+MAINTAINER= gurkan@linuks.mine.nu
+COMMENT= The GNU Emacs editor on GNUstep
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+BASEDIR=${WRKSRC}/build/Emacs.app
+BINDIR=${BASEDIR}
+CFLAGS+=-I${PREFIX}/System/Library/Headers/
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_MAKE= yes
+MAKEFILE= GNUmakefile
+
+post-configure:
+ @${REINPLACE_CMD} -e 's|#define config_machfile "m/.h"|#define config_machfile "m/sparc.h"|g' ${WRKSRC}/src/config.h
+ @${REINPLACE_CMD} -e's|source /etc/GNUstep/GNUstep.conf|. ${SYSMAKEDIR}/GNUstep.sh|g' ${WRKSRC}/nextstep/compile
+
+do-build:
+ (. ${SYSMAKEDIR}/GNUstep.sh; cd ${WRKSRC}/nextstep; ${MAKE_ENV} ./compile)
+
+do-install:
+ ${CP} -r ${WRKSRC}/nextstep/build/Emacs.app ${PREFIX}/System/Applications/
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(BATCH) || defined(CLEAN_ROOT)
+ ${RM} -rf /root/GNUstep
+.endif
+
+.include <bsd.port.mk>