aboutsummaryrefslogtreecommitdiff
path: root/editors/emacs
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2011-05-16 12:27:12 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2011-05-16 12:27:12 +0000
commit623a0a78f1d1fd27949f4a891fb04e1efab94154 (patch)
tree8fad62ce2727f6935a47ebda8fca53cdd0f0bde6 /editors/emacs
parentf52bbae2a96b312c175999b9d5a1f2e6766389df (diff)
downloadports-623a0a78f1d1fd27949f4a891fb04e1efab94154.tar.gz
ports-623a0a78f1d1fd27949f4a891fb04e1efab94154.zip
- Update emacs.desktop to launch Emacs in Terminal when WITHOUT_X11 is
defined.[1] - Emacs picks up giflib if available instead of libungif. Account for this.[2] - Include 'alloca' fix.[2] PR: ports/156167[1] Submitted by: Zhihao Yuan <lichray@gmail.com>[1] Herbert J. Skuhra <h.skuhra@gmail.com>[2] (via private email)
Notes
Notes: svn path=/head/; revision=274180
Diffstat (limited to 'editors/emacs')
-rw-r--r--editors/emacs/Makefile8
-rw-r--r--editors/emacs/files/patch-src_config.in14
2 files changed, 22 insertions, 0 deletions
diff --git a/editors/emacs/Makefile b/editors/emacs/Makefile
index c22b2042064f..871e6db130cf 100644
--- a/editors/emacs/Makefile
+++ b/editors/emacs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= emacs
PORTVERSION= ${EMACS_VER}
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= editors ipv6
MASTER_SITES= ${MASTER_SITE_GNU}
@@ -139,7 +140,11 @@ LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
.if defined(WITHOUT_GIF)
CONFIGURE_ARGS+= --without-gif
.else
+. if exists(${LOCALBASE}/lib/libgif.so)
+LIB_DEPENDS+= gif.5:${PORTSDIR}/graphics/giflib
+. else
LIB_DEPENDS+= ungif.5:${PORTSDIR}/graphics/libungif
+. endif
.endif
.if defined(WITHOUT_PNG)
@@ -225,6 +230,9 @@ BROKEN= Emacs 23.X does not currently build on ia64
post-patch:
@${RM} -f ${WRKSRC}/info/*
@${REINPLACE_CMD} -e "s/%%EMACS_VER%%/${EMACS_VER}/g" -e "s/%%DATADIR%%/${DATADIR:C/\//\\\//g}/g" ${WRKSRC}/sources.el
+.if defined(WITHOUT_X11)
+ @${REINPLACE_CMD} -e 's/^Terminal=.*$$/Terminal=true/' ${WRKSRC}/etc/emacs.desktop
+.endif
post-configure:
@${REINPLACE_CMD} -e "s/^\(DBUS_LIBS.*\)-pthread\(.*\)$$/\1$$(${DBUS_PTHREAD_LIBS})\2/" ${WRKSRC}/src/Makefile
diff --git a/editors/emacs/files/patch-src_config.in b/editors/emacs/files/patch-src_config.in
new file mode 100644
index 000000000000..834b77b8c5c2
--- /dev/null
+++ b/editors/emacs/files/patch-src_config.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/config.in.orig
++++ src/config.in
+@@ -1183,6 +1183,8 @@
+ #endif
+ #ifdef HAVE_ALLOCA_H
+ # include <alloca.h>
++#elif defined __FreeBSD__
++#include <stdlib.h>
+ #elif defined __GNUC__
+ # define alloca __builtin_alloca
+ #elif defined _AIX