aboutsummaryrefslogtreecommitdiff
path: root/editors/emacs
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2014-11-07 12:46:59 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2014-11-07 12:46:59 +0000
commit91332f8894a97f567b98cbe34223545154d7c574 (patch)
treed11d52bb1a5411ca40ad7cc615006fb937035718 /editors/emacs
parentebf18a7b493601dc23e9f77bbf50d58114d915fb (diff)
downloadports-91332f8894a97f567b98cbe34223545154d7c574.tar.gz
ports-91332f8894a97f567b98cbe34223545154d7c574.zip
- Fix pkg-install script to correctly install emacs games scores files[1]
- Fix building port when ALSA option is enabled[2] - Depend on desktop-file-utils only when X11 option is enabled[3] - Bump PORTREVISION to account for these changes PR: 194624[1], 194862[2] Submitted by: crest <crest at sahiro.org>[2] Reported by: Joseph Mingrone <jrm at ftfl.ca>[1], Richard Kuhns <rjk at wintek.com>[3] (via private email)
Notes
Notes: svn path=/head/; revision=372258
Diffstat (limited to 'editors/emacs')
-rw-r--r--editors/emacs/Makefile8
-rw-r--r--editors/emacs/files/pkg-install.in19
-rw-r--r--editors/emacs/pkg-install10
3 files changed, 26 insertions, 11 deletions
diff --git a/editors/emacs/Makefile b/editors/emacs/Makefile
index aaa7dcc84492..c5bb3f653410 100644
--- a/editors/emacs/Makefile
+++ b/editors/emacs/Makefile
@@ -3,6 +3,7 @@
PORTNAME= emacs
PORTVERSION= ${EMACS_VER}
+PORTREVISION= 1
PORTEPOCH= 3
CATEGORIES= editors ipv6
MASTER_SITES= ${MASTER_SITE_GNU}
@@ -25,11 +26,14 @@ CONFLICTS= emacs-19.* emacs21-[0-9]* emacs22-[0-9]* emacs23-[0-9]* \
EMACS_VER= 24.4
GNU_CONFIGURE= yes
-USES= desktop-file-utils gmake makeinfo ncurses pkgconfig shebangfix tar:xz
+USES= gmake makeinfo ncurses pkgconfig shebangfix tar:xz
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INFO_PATH= ${DATADIR_REL}/info
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+SUB_FILES= pkg-install
+SUB_LIST+= ARCHLIBDIR=${PREFIX}/libexec/emacs/${EMACS_VER}/${CONFIGURE_TARGET}
SHEBANG_FILES= lib-src/grep-changelog
# Append --without-compress-install to prevent emacs from compressing info
@@ -90,6 +94,7 @@ CANNA_LIB_DEPENDS= libcanna.so:${PORTSDIR}/japanese/canna-lib
SOUND_CONFIGURE_OFF= --with-sound=no
ALSA_CONFIGURE_ON= --with-sound=alsa
+ALSA_LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib
OSS_CONFIGURE_ON= --with-sound=oss
DBUS_LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus
@@ -106,6 +111,7 @@ SVG_CONFIGURE_WITH= rsvg
X11_CONFIGURE_WITH= x
X11_USE= XORG=x11
+X11_USES= desktop-file-utils
X11_PLIST_DIRSTRY_OFF= share/icons/hicolor/scalable/mimetypes \
share/icons/hicolor/scalable/apps \
share/icons/hicolor/scalable \
diff --git a/editors/emacs/files/pkg-install.in b/editors/emacs/files/pkg-install.in
new file mode 100644
index 000000000000..7c3bd729433c
--- /dev/null
+++ b/editors/emacs/files/pkg-install.in
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+# $FreeBSD$
+
+GAMESROOT=/var/games/emacs
+ARCHLIBDIR=%%ARCHLIBDIR%%
+
+if [ "$2" = "POST-INSTALL" ]; then
+ umask 022
+ mkdir -p $GAMESROOT
+ touch $GAMESROOT/snake-scores
+ touch $GAMESROOT/tetris-scores
+ chown games $ARCHLIBDIR/update-game-score
+ chmod u+s $ARCHLIBDIR/update-game-score
+ chown games $GAMESROOT
+ chmod 775 $GAMESROOT
+fi
+
+exit 0
diff --git a/editors/emacs/pkg-install b/editors/emacs/pkg-install
deleted file mode 100644
index eb3644e890ee..000000000000
--- a/editors/emacs/pkg-install
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/sh
-
-GAMESROOT=/var/games/emacs
-
-if [ "$2" = "POST-INSTALL" ]; then
- touch $GAMESROOT/snake-scores
- touch $GAMESROOT/tetris-scores
-fi
-
-exit 0