aboutsummaryrefslogtreecommitdiff
path: root/editors/flim113-xemacs21-mule/Makefile
diff options
context:
space:
mode:
authorShigeyuki Fukushima <shige@FreeBSD.org>1999-09-10 19:07:08 +0000
committerShigeyuki Fukushima <shige@FreeBSD.org>1999-09-10 19:07:08 +0000
commitf48ce1576498a20ec4ca0ee8fd413bacd29229a5 (patch)
tree0116b4e6e535573b23f2e465dac457266589d4fe /editors/flim113-xemacs21-mule/Makefile
parentcf25e2b69a16a5572b4598676c696fc92d9fce25 (diff)
downloadports-f48ce1576498a20ec4ca0ee8fd413bacd29229a5.tar.gz
ports-f48ce1576498a20ec4ca0ee8fd413bacd29229a5.zip
Fix for xemacs-21.1.6.
flim-current/semi-current/wemi-current should be compatible with xemacs-packages on xemacs-21.x.
Notes
Notes: svn path=/head/; revision=21599
Diffstat (limited to 'editors/flim113-xemacs21-mule/Makefile')
-rw-r--r--editors/flim113-xemacs21-mule/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/editors/flim113-xemacs21-mule/Makefile b/editors/flim113-xemacs21-mule/Makefile
index c0b86ecfa595..0f8449b6984b 100644
--- a/editors/flim113-xemacs21-mule/Makefile
+++ b/editors/flim113-xemacs21-mule/Makefile
@@ -17,9 +17,11 @@ MASTERDIR= ${.CURDIR}/../../editors/flim-emacs-current
EMACS_NAME= xemacs
EMACS_PORT= xemacs-mule
EMACS_VER= 21.1.6
-EMACS_LIBDIR= lib/${EMACS_NAME}-${EMACS_VER}
-# xemacs-mule-21.1.6 has no version specific site-lisp directories.
-EMACS_LIBDIR_WITH_VER= ${EMACS_LIBDIR}
+EMACS_PACKAGESDIR= lib/${EMACS_NAME}/${EMACS_NAME}-packages
+
+# how to make and install
+ALL_TARGET= package
+INSTALL_TARGET= install-package
# RUN_DEPENDS port name's suffix is '-common'.
HAVE_COMMON_PORT= YES
@@ -27,4 +29,9 @@ HAVE_COMMON_PORT= YES
# use pkg/* files in ${.CURDIR}
PKGDIR= ${.CURDIR}/pkg
+# package info manifest
+MANIFEST= MANIFEST.flim
+# package documents
+FLIMDOCDIR= ${EMACS_PACKAGESDIR}/lisp/flim
+
.include <${MASTERDIR}/Makefile>