aboutsummaryrefslogtreecommitdiff
path: root/editors/gedit-plugins
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 04:15:24 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 04:15:24 +0000
commitb41b93b15ebfeedd9f62aebec8978a35c88717ae (patch)
tree7ac6e576ee4973c487ff0555f63e4ddcc0ae866e /editors/gedit-plugins
parent7d1eeeb27a898dd696ecb27e68e75edae1fc288e (diff)
downloadports-b41b93b15ebfeedd9f62aebec8978a35c88717ae.tar.gz
ports-b41b93b15ebfeedd9f62aebec8978a35c88717ae.zip
Fix some known compatibility problems with GNOME 2.6.
Notes
Notes: svn path=/head/; revision=106192
Diffstat (limited to 'editors/gedit-plugins')
-rw-r--r--editors/gedit-plugins/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/editors/gedit-plugins/Makefile b/editors/gedit-plugins/Makefile
index 736ac527c6a4..5a599925c6fe 100644
--- a/editors/gedit-plugins/Makefile
+++ b/editors/gedit-plugins/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gedit-plugins
PORTVERSION= 2.3.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= editors gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.3
@@ -21,10 +21,15 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
USE_BZIP2= yes
USE_PERL5= yes
USE_X_PREFIX= yes
-USE_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
USE_GNOME= gnomehack gnomeprefix gnometarget lthack
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+post-patch:
+ @${REINPLACE_CMD} -e "s|gedit-2.4|gedit-2.6|g" \
+ ${WRKSRC}/configure
+
.include <bsd.port.mk>