aboutsummaryrefslogtreecommitdiff
path: root/editors/gedit2/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-05-15 04:52:45 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-05-15 04:52:45 +0000
commitcd44c2581e27af3264c80e983d5f4f2d5c3dc1fe (patch)
tree20f5153873c90af594ce2695b02846d20420b7ca /editors/gedit2/Makefile
parent3b9cefcee022395cbe7109aef8b755bad41337f1 (diff)
downloadports-cd44c2581e27af3264c80e983d5f4f2d5c3dc1fe.tar.gz
ports-cd44c2581e27af3264c80e983d5f4f2d5c3dc1fe.zip
Add gedit2 after a repo copy from gedit. gedit2 is a lightweight editor
for the GNOME 2.0 desktop environment.
Notes
Notes: svn path=/head/; revision=59144
Diffstat (limited to 'editors/gedit2/Makefile')
-rw-r--r--editors/gedit2/Makefile31
1 files changed, 16 insertions, 15 deletions
diff --git a/editors/gedit2/Makefile b/editors/gedit2/Makefile
index 9ff2a61118f8..4ca62d3c8e7a 100644
--- a/editors/gedit2/Makefile
+++ b/editors/gedit2/Makefile
@@ -1,31 +1,32 @@
-# New ports collection makefile for: gedit
-# Date created: 4 May 1999
-# Whom: Andrey Zakhvatov
+# New ports collection makefile for: gedit2
+# Date created: 14 May 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
#
-PORTNAME= gedit
-PORTVERSION= 0.9.7
-PORTREVISION= 1
+PORTNAME= gedit2
+PORTVERSION= 1.118.0
CATEGORIES= editors gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= stable/sources/gedit
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-20020509
+DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-BUILD_DEPENDS= msgfmt-old:${PORTSDIR}/devel/gettext-old
+LIB_DEPENDS= gnomeprintui-2.0:${PORTSDIR}/x11-toolkits/libgnomeprintui
+WRKSRC= ${WRKDIR}/gedit-${PORTVERSION}
+
+USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib" \
- MSGFMT="${LOCALBASE}/bin/msgfmt-old" \
- XGETTEXT="${LOCALBASE}/bin/xgettext-old"
-
-MAN1= gedit.1
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \