aboutsummaryrefslogtreecommitdiff
path: root/editors/gobby/Makefile
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2013-01-09 11:31:47 +0000
committerSofian Brabez <sbz@FreeBSD.org>2013-01-09 11:31:47 +0000
commit39b6712492a286855d07097dd69fef74201d9134 (patch)
tree471a45f1e95f532e9f4416552112b14318bbbc70 /editors/gobby/Makefile
parent7c736f500c6baa050583d83547fe58f8a97a2640 (diff)
downloadports-39b6712492a286855d07097dd69fef74201d9134.tar.gz
ports-39b6712492a286855d07097dd69fef74201d9134.zip
- Update to 0.4.13
- Update MASTER_SITES - Convert to new option framework - Add LICENSE
Notes
Notes: svn path=/head/; revision=310137
Diffstat (limited to 'editors/gobby/Makefile')
-rw-r--r--editors/gobby/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/editors/gobby/Makefile b/editors/gobby/Makefile
index 4b71ae0e0ca0..38c9049df017 100644
--- a/editors/gobby/Makefile
+++ b/editors/gobby/Makefile
@@ -1,21 +1,23 @@
# $FreeBSD$
PORTNAME= gobby
-PORTVERSION= 0.4.12
-PORTREVISION= 4
+PORTVERSION= 0.4.13
CATEGORIES= editors
-MASTER_SITES= http://releases.0x539.de/gobby/
+MASTER_SITES= http://releases.0x539.de/gobby/ \
+ LOCAL/${MAINTAINER:C/([^@]*)@.*/\1/}
MAINTAINER= sbz@FreeBSD.org
COMMENT= A free collaborative editor
+LICENSE= GPLv2
+
LIB_DEPENDS= obby-0.4.1:${PORTSDIR}/devel/obby \
net6-1.3.0:${PORTSDIR}/net/net6 \
xml++-2.6.2:${PORTSDIR}/textproc/libxml++26 \
gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
-OPTIONS= GTKSPELL "Enable GtkSpell support" off \
- NLS "Enable Native Language support" off
+OPTIONS_DEFINE= GTKSPELL NLS
+GTKSPELL_DESC= Enable GtkSpell support
USE_GNOME= gnomehack gtksourceview2 intltool
USE_GMAKE= yes
@@ -25,16 +27,16 @@ INSTALLS_ICONS= yes
MAN1= ${PORTNAME}.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_GTKSPELL)
-LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell
+.if ${PORT_OPTIONS:MGTKSPELL}
+LIB_DEPENDS+= gtkspell:${PORTSDIR}/textproc/gtkspell
CONFIGURE_ARGS+=--with-gtkspell
.else
CONFIGURE_ARGS+=--without-gtkspell
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lintl
CONFIGURE_ARGS+= --enable-nls
@@ -45,4 +47,4 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>