aboutsummaryrefslogtreecommitdiff
path: root/editors/joe2
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-18 11:13:27 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-18 11:13:27 +0000
commitb52a2cb357153e65635662929c47ff215076392e (patch)
tree0a931dac3d65d6cf815d6eb6463254bc67b25f27 /editors/joe2
parent00958a7588cb45d6ed172d28b9fbc9ed03d0a9d9 (diff)
downloadports-b52a2cb357153e65635662929c47ff215076392e.tar.gz
ports-b52a2cb357153e65635662929c47ff215076392e.zip
drop sgid/suid on backup files
PR: 42920 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=66585
Diffstat (limited to 'editors/joe2')
-rw-r--r--editors/joe2/Makefile2
-rw-r--r--editors/joe2/files/patch-ufile.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/editors/joe2/Makefile b/editors/joe2/Makefile
index 06ec3e8aa397..fc9008a66f29 100644
--- a/editors/joe2/Makefile
+++ b/editors/joe2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= joe
PORTVERSION= 2.8
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES+= editors
MASTER_SITES= ftp://ftp.std.com/src/editors/
DISTNAME= ${PORTNAME}${PORTVERSION}
diff --git a/editors/joe2/files/patch-ufile.c b/editors/joe2/files/patch-ufile.c
new file mode 100644
index 000000000000..fcea6cc24d15
--- /dev/null
+++ b/editors/joe2/files/patch-ufile.c
@@ -0,0 +1,11 @@
+--- ufile.c.orig Wed Sep 18 19:09:53 2002
++++ ufile.c Wed Sep 18 19:10:19 2002
+@@ -149,7 +149,7 @@
+ f=open(from,O_RDONLY);
+ if(f<0) return -1;
+ if(fstat(f,&sbuf)<0) return -1;
+- g=creat(to,sbuf.st_mode);
++ g=creat(to,sbuf.st_mode&~(S_ISGID|S_ISUID));
+ if(g<0)
+ {
+ close(f);