aboutsummaryrefslogtreecommitdiff
path: root/editors/koffice-kde4/Makefile
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2006-12-19 21:19:54 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2006-12-19 21:19:54 +0000
commit1160fd7012e9178dcc628403246431be1258220c (patch)
tree7e40351a3df9a22683e158e9f84074c3071a0c56 /editors/koffice-kde4/Makefile
parentcba6322b417f491888799446be04740401e2d0fb (diff)
downloadports-1160fd7012e9178dcc628403246431be1258220c.tar.gz
ports-1160fd7012e9178dcc628403246431be1258220c.zip
Update to KDE 3.5.5 / KOffice 1.6.1
Approved by: portmgr
Notes
Notes: svn path=/head/; revision=180198
Diffstat (limited to 'editors/koffice-kde4/Makefile')
-rw-r--r--editors/koffice-kde4/Makefile21
1 files changed, 16 insertions, 5 deletions
diff --git a/editors/koffice-kde4/Makefile b/editors/koffice-kde4/Makefile
index 6f27fc720383..9cb07045d1ed 100644
--- a/editors/koffice-kde4/Makefile
+++ b/editors/koffice-kde4/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= koffice
-PORTVERSION= 1.5.2
+PORTVERSION= 1.6.1
PORTEPOCH= 2
CATEGORIES= editors kde
MASTER_SITES= ${MASTER_SITE_KDE}
@@ -16,15 +16,16 @@ DIST_SUBDIR= KDE/koffice
MAINTAINER= kde@FreeBSD.org
COMMENT= Office Suite for KDE3
-BUILD_DEPENDS= ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx \
- Magick-config:${PORTSDIR}/graphics/ImageMagick
-LIB_DEPENDS= art_lgpl_2.5:${PORTSDIR}/graphics/libart_lgpl \
+BUILD_DEPENDS= ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx
+LIB_DEPENDS= GraphicsMagick++:${PORTSDIR}/graphics/GraphicsMagick \
+ art_lgpl_2.5:${PORTSDIR}/graphics/libart_lgpl \
aspell:${PORTSDIR}/textproc/aspell \
exif.12:${PORTSDIR}/graphics/libexif \
fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
freetype:${PORTSDIR}/print/freetype2 \
lcms:${PORTSDIR}/graphics/lcms \
paper:${PORTSDIR}/print/libpaper \
+ poppler-qt:${PORTSDIR}/graphics/poppler-qt \
wpd-0.8:${PORTSDIR}/textproc/libwpd \
wv2:${PORTSDIR}/textproc/wv2 \
xml2:${PORTSDIR}/textproc/libxml2 \
@@ -46,7 +47,9 @@ USE_PGSQL= yes
.include <bsd.port.pre.mk>
CONFIGURE_ARGS+=--with-pgsqlincdir=${LOCALBASE}/include \
- --with-pgsqllibdir=${LOCALBASE}/lib
+ --with-pgsqllibdir=${LOCALBASE}/lib \
+ --with-pqxx-includes=${LOCALBASE}/include \
+ --with-pqxx-libraries=${LOCALBASE}/lib
.if ${OSVERSION} < 500035
EXTRA_PATCHES= ${PATCHDIR}/extrapatch-kexi-main-keximainwindowimpl.cpp
@@ -63,6 +66,14 @@ post-configure:
${WRKSRC}/kchart/kdchart/Makefile \
${WRKSRC}/kexi/kexidb/drivers/pqxx/Makefile \
${WRKSRC}/kexi/migration/pqxx/Makefile
+ ${REINPLACE_CMD} -e 's|round(|rint(|g' \
+ ${WRKSRC}/krita/plugins/filters/levelfilter/kgradientslider.cc
+ ${REINPLACE_CMD} -e 's|-O[s23]||g' -e 's|-O|-O0|g' \
+ ${WRKSRC}/krita/plugins/filters/cimg/Makefile
+ ${REINPLACE_CMD} -e 's|xor|^|g' \
+ ${WRKSRC}/kspread/kspread_style.cc
+ ${REINPLACE_CMD} -e 's|trunc(|rint(|g' \
+ ${WRKSRC}/kchart/kdchart/KDChartAxesPainter.cpp
.endif
.include <bsd.port.post.mk>