aboutsummaryrefslogtreecommitdiff
path: root/editors/lazarus
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-09-23 19:50:43 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-09-23 19:50:43 +0000
commit4186e6895aef6aeb1652f2147530dd031f33c1c5 (patch)
treea39a9c5765a48f85c56a43cf129c8641b9970979 /editors/lazarus
parented8efc9d700175fd0e85d5443063a966288fe3d1 (diff)
downloadports-4186e6895aef6aeb1652f2147530dd031f33c1c5.tar.gz
ports-4186e6895aef6aeb1652f2147530dd031f33c1c5.zip
- Use lazarus wrapper script instead of symlink.
- Bump PORTREVISION Suggested by: Ales Katona <almindor__at__gmail.com>
Notes
Notes: svn path=/head/; revision=173664
Diffstat (limited to 'editors/lazarus')
-rw-r--r--editors/lazarus/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/editors/lazarus/Makefile b/editors/lazarus/Makefile
index ceb219867503..8694e4809b85 100644
--- a/editors/lazarus/Makefile
+++ b/editors/lazarus/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lazarus
PORTVERSION= 0.9.18
+PORTREVISION= 1
CATEGORIES= editors devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S|$|freepascal/:freepascal|} \
ftp://ftp.freepascal.org/pub/fpc/dist/source-${FPC_MINVER}/:freepascal \
@@ -124,6 +125,11 @@ post-build:
@cd ${WRKSRC} && \
${RM} -Rf Makefile* COPYING* debian
+pre-install:
+ @${ECHO} "#!/bin/sh" > ${WRKDIR}/lazarus-wrapper
+ @${ECHO} "cd ${DATADIR} || exit 1 " >> ${WRKDIR}/lazarus-wrapper
+ @${ECHO} "exec ./startlazarus" >> ${WRKDIR}/lazarus-wrapper
+
do-install:
.for DIRE in components converter debugger designer doceditor docs examples ide ideintf images install \
languages lcl packager tools units
@@ -138,6 +144,6 @@ do-install:
.endfor
${INSTALL_SCRIPT} ${WRKSRC}/localize.sh ${DATADIR}
- ${LN} -s ${DATADIR}/startlazarus ${PREFIX}/bin/lazarus
+ ${INSTALL_SCRIPT} ${WRKDIR}/lazarus-wrapper ${PREFIX}/bin/${PORTNAME}
.include <bsd.port.post.mk>