aboutsummaryrefslogtreecommitdiff
path: root/editors/libreoffice/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-04-26 14:55:09 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-04-26 14:55:09 +0000
commit11cee2e8c90cf7b2564f712b4ceb2ba08f91f761 (patch)
treea8fd9448fe533541847172a404c8cc229acbe427 /editors/libreoffice/Makefile
parent63000530e371cda19dd2fcf0b0051770994d1bc0 (diff)
downloadports-11cee2e8c90cf7b2564f712b4ceb2ba08f91f761.tar.gz
ports-11cee2e8c90cf7b2564f712b4ceb2ba08f91f761.zip
- add a patch fixing .doc/.docx loading [1]
- workaround a pointyhat/tinderbox box, preventing it to figureout clang is needed as a dependency on 7 and 8 when host is 9+ Submitted by: Meowthink <meowthink@gmail.com> (via office@ mailing list) Obtained from: libreoffice git master [1]
Notes
Notes: svn path=/head/; revision=295566
Diffstat (limited to 'editors/libreoffice/Makefile')
-rw-r--r--editors/libreoffice/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index d42ef9a954b5..e2b5e40d7086 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -7,7 +7,7 @@
.include "${.CURDIR}/Makefile.common"
-PORTREVISION= 1
+PORTREVISION= 2
MASTER_SITE_SUBDIR= src/${PORTVERSION}/
MASTER_SITES+= http://dev-www.libreoffice.org/src/:ext \
@@ -217,7 +217,13 @@ CC= clang
CXX= clang++
CXXCPP= clang-cpp
CPP= clang-cpp
-.if !exists(${DESTDIR}/usr/bin/clang)
+# Work around a bug in pointyhat and tinderbox, prevent it to determine than
+# clang from ports is needed when host is a freebsd 9+
+.if defined(PACKAGE_BUILDING)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/clang:${PORTSDIR}/lang/clang
+USE_BINUTILS= yes
+.endif
+.if !exists(/usr/bin/clang)
BUILD_DEPENDS+= ${LOCALBASE}/bin/clang:${PORTSDIR}/lang/clang
USE_BINUTILS= yes
CXXCPP= clang++ -E