aboutsummaryrefslogtreecommitdiff
path: root/editors/mined
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-12-25 15:27:13 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-12-25 15:27:13 +0000
commit51ee7be17b56d1d0335c17fc6f3b5bdbcd9ce9bc (patch)
treef305ea6920bd5eb4a043b799b8904cfa9c90962e /editors/mined
parent2ad712e83d460c6c7e536945b66bc5e10239fdeb (diff)
downloadports-51ee7be17b56d1d0335c17fc6f3b5bdbcd9ce9bc.tar.gz
ports-51ee7be17b56d1d0335c17fc6f3b5bdbcd9ce9bc.zip
Add mined 2000.9, a text mode editor with Unicode support.
Notes
Notes: svn path=/head/; revision=125134
Diffstat (limited to 'editors/mined')
-rw-r--r--editors/mined/Makefile52
-rw-r--r--editors/mined/distinfo2
-rw-r--r--editors/mined/files/patch-makemined11
-rw-r--r--editors/mined/files/patch-src::makefile.bsd29
-rw-r--r--editors/mined/files/patch-src::mkinclud.cc11
-rw-r--r--editors/mined/pkg-descr10
-rw-r--r--editors/mined/pkg-plist7
7 files changed, 122 insertions, 0 deletions
diff --git a/editors/mined/Makefile b/editors/mined/Makefile
new file mode 100644
index 000000000000..3ddd14474f5f
--- /dev/null
+++ b/editors/mined/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: mined
+# Date created: 24 December 2004
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= mined
+PORTVERSION= 2000.9
+CATEGORIES= editors
+MASTER_SITES= http://towo.net/mined/
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Text mode editor with Unicode support
+
+MAKEFILE= makefile
+
+.if defined(NOPORTDOCS)
+ALL_TARGET= mined manual
+.else
+PORTDOCS= cancel.html changes.html contact.html dollar.gif donate.html \
+ download.html euro1.gif features.html handr.gif header.html \
+ index-dl.html index.html logo.gif mined-small.gif mined.gif \
+ mined.html mined.lsm mined.uni.gif mnemodoc.html navigate.html \
+ new-rot.gif new.gif overview.html paypal_donate.gif \
+ paypal_logo.gif paypal_payments.gif script-arabic.gif \
+ script-cyrillic.gif script-greek.gif script-han.gif \
+ script-hebrew.gif script-hiragana.gif script-thai.gif \
+ thankyou.html unicode.html
+EXAMPLES= configure-xterm mterm uterm
+.endif
+
+USE_GMAKE= YES
+MAKE_ARGS= GMAKE=${GMAKE} CC=${CC:T}
+
+MAN1= mined.1
+
+pre-build:
+ @(if [ ! -f ${WRKSRC}/src/mkinclud.${CC:T} ] ; then \
+ ${LN} -sf ${WRKSRC}/src/mkinclud.cc ${WRKSRC}/src/mkinclud.${CC:T} ; \
+ fi)
+
+post-install:
+ @${STRIP_CMD} ${PREFIX}/bin/mined
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${DOCSDIR}
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${EXAMPLES:S|^|${WRKSRC}/doc/|} ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/editors/mined/distinfo b/editors/mined/distinfo
new file mode 100644
index 000000000000..18e1281799b6
--- /dev/null
+++ b/editors/mined/distinfo
@@ -0,0 +1,2 @@
+MD5 (mined-2000.9.tar.gz) = 5b0e682a9ff2c10c19197bad921e23f0
+SIZE (mined-2000.9.tar.gz) = 1922021
diff --git a/editors/mined/files/patch-makemined b/editors/mined/files/patch-makemined
new file mode 100644
index 000000000000..0aba18fa8f32
--- /dev/null
+++ b/editors/mined/files/patch-makemined
@@ -0,0 +1,11 @@
+--- makemined.orig Wed Apr 23 17:16:42 2003
++++ makemined Sat Dec 25 10:55:07 2004
+@@ -5,7 +5,7 @@
+ Linux*) make -f makefile.linux $1;;
+ Sun*) make -f makefile.sun $1;;
+ HP*) make -f makefile.hp $1;;
+-*BSD*) make -f makefile.bsd $1;;
++*BSD*) ${GMAKE} -f makefile.bsd $1;;
+ CYG*) make -f makefile.cygwin $1;;
+ Darwin*) make -f makefile.osx $1;;
+ esac
diff --git a/editors/mined/files/patch-src::makefile.bsd b/editors/mined/files/patch-src::makefile.bsd
new file mode 100644
index 000000000000..39b004fda12f
--- /dev/null
+++ b/editors/mined/files/patch-src::makefile.bsd
@@ -0,0 +1,29 @@
+--- ./src/makefile.bsd.orig Fri Mar 14 12:25:01 2003
++++ ./src/makefile.bsd Sat Dec 25 12:33:55 2004
+@@ -6,7 +6,7 @@
+ # Where and how to install
+ prefix = $(PREFIX)
+ bindir = $(prefix)/bin
+-helpdir = $(prefix)/share/help
++helpdir = $(prefix)/share/doc/mined/help
+ mandir = $(prefix)/man
+ INSTALL = install
+ #INSTALL = /bin/cp -p
+@@ -54,7 +54,7 @@
+ # link options
+
+ # link dynamically
+-LDOPTS=-d y # -d n links statically
++LDOPTS= # -d n links statically
+ GLDOPTS= # -static links statically
+
+
+@@ -62,7 +62,7 @@
+ # compiler selection and compiler-specific options
+ # (source warnings, optimisation and debug)
+
+-CC=gcc
++#CC=gcc
+ include mkinclud.$(CC)
+
+
diff --git a/editors/mined/files/patch-src::mkinclud.cc b/editors/mined/files/patch-src::mkinclud.cc
new file mode 100644
index 000000000000..26088f9ea120
--- /dev/null
+++ b/editors/mined/files/patch-src::mkinclud.cc
@@ -0,0 +1,11 @@
+--- src/mkinclud.cc.orig Mon Apr 9 19:43:04 2001
++++ src/mkinclud.cc Sat Dec 25 12:25:56 2004
+@@ -25,7 +25,7 @@
+ # compilation setup
+
+ # Collection of compilation parameters:
+-CFLAGS = $(SYSFLAGS) $(OPT) $(DEBUG)
++CFLAGS+= $(SYSFLAGS) $(DEBUG)
+
+
+ #############################################################################
diff --git a/editors/mined/pkg-descr b/editors/mined/pkg-descr
new file mode 100644
index 000000000000..a48a8d651934
--- /dev/null
+++ b/editors/mined/pkg-descr
@@ -0,0 +1,10 @@
+Mined was the first text mode editor with Unicode support. It now has both
+extensive Unicode and CJK support offering many specific features and
+covering special cases that other editors are not aware of (like auto-
+detection features and automatic handling of terminal variations).
+
+And basically, it is an editor tailored to efficient editing of plain text
+documents and programs, with features and interactive behaviour designed
+for this purpose.
+
+WWW: http://towo.net/mined/
diff --git a/editors/mined/pkg-plist b/editors/mined/pkg-plist
new file mode 100644
index 000000000000..cc6205c2cecb
--- /dev/null
+++ b/editors/mined/pkg-plist
@@ -0,0 +1,7 @@
+bin/mined
+%%PORTDOCS%%%%DOCSDIR%%/help/mined.hlp
+%%PORTDOCS%%%%EXAMPLESDIR%%/configure-xterm
+%%PORTDOCS%%%%EXAMPLESDIR%%/mterm
+%%PORTDOCS%%%%EXAMPLESDIR%%/uterm
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/help
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%