aboutsummaryrefslogtreecommitdiff
path: root/editors/nedit
diff options
context:
space:
mode:
authorDaniel Eischen <deischen@FreeBSD.org>2004-02-07 23:38:15 +0000
committerDaniel Eischen <deischen@FreeBSD.org>2004-02-07 23:38:15 +0000
commit516e68ade219b77158d45f8a26a0a860beaaf632 (patch)
treeefe0872a5eb05f935e880a1348e1ea85426c3bc2 /editors/nedit
parent85127a7a4866bdcd31a3821fc106c15d98c35c8e (diff)
downloadports-516e68ade219b77158d45f8a26a0a860beaaf632.tar.gz
ports-516e68ade219b77158d45f8a26a0a860beaaf632.zip
Update Nedit to 5.4. Note that our open-motif port is at 2.2.2 which
is known to be buggy. It was pulled from the opengroup site. Nedit now checks the version of motif and issues a very loud warning when it is built.
Notes
Notes: svn path=/head/; revision=100309
Diffstat (limited to 'editors/nedit')
-rw-r--r--editors/nedit/Makefile15
-rw-r--r--editors/nedit/distinfo2
-rw-r--r--editors/nedit/files/patch-ab12
-rw-r--r--editors/nedit/files/patch-ac53
-rw-r--r--editors/nedit/files/patch-ad160
-rw-r--r--editors/nedit/files/patch-ae14
6 files changed, 63 insertions, 193 deletions
diff --git a/editors/nedit/Makefile b/editors/nedit/Makefile
index b6502dc23cd2..e989df17f299 100644
--- a/editors/nedit/Makefile
+++ b/editors/nedit/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= nedit
-PORTVERSION= 5.3
+PORTVERSION= 5.4
CATEGORIES= editors
-MASTER_SITES= ftp://ftp.nedit.org/pub/v5_3/ \
- ftp://ftp.nedit.org/pub/contrib/misc/ \
- http://www.nedit.org/ftp/v5_3/ \
- http://www.nedit.org/ftp/contrib/misc/
-DISTFILES= nedit-5.3-source.tar.bz2 nedit.app-defaults
-EXTRACT_ONLY= nedit-5.3-source.tar.bz2
+MASTER_SITES= ftp://nl.nedit.org/pub/NEdit/v5_4/ \
+ ftp://nl.nedit.org/pub/NEdit/contrib/misc/ \
+ http://nl.nedit.org/ftp/v5_4/ \
+ http://nl.nedit.org/ftp/contrib/misc/
+DISTFILES= nedit-5.4-source.tar.bz2 nedit.app-defaults
+EXTRACT_ONLY= nedit-5.4-source.tar.bz2
MAINTAINER= deischen@freebsd.org
COMMENT= An X11/Motif GUI text editor for programs and plain text files
@@ -25,6 +25,7 @@ USE_XPM= yes
MAN1= nclient.1 nedit.1
ALL_TARGET= freebsd
MAKE_ENV+= BINOWN=${BINOWN} BINGRP=${BINGRP} BINMODE=${BINMODE}
+CFLAGS+= -DBUILD_BROKEN_NEDIT
post-extract:
${CP} ${DISTDIR}/nedit.app-defaults ${WRKSRC}/NEdit.ad
diff --git a/editors/nedit/distinfo b/editors/nedit/distinfo
index edd88a0827a3..eefca3d300da 100644
--- a/editors/nedit/distinfo
+++ b/editors/nedit/distinfo
@@ -1,2 +1,2 @@
-MD5 (nedit-5.3-source.tar.bz2) = 27633066f5e9214c22d4ecc18d7e96d2
+MD5 (nedit-5.4-source.tar.bz2) = b71afab27f07def3121a8c6f319697ca
MD5 (nedit.app-defaults) = 36c5e660039e0bd4b4d05df609b505bb
diff --git a/editors/nedit/files/patch-ab b/editors/nedit/files/patch-ab
index d106e7895b76..abe5194e6c2b 100644
--- a/editors/nedit/files/patch-ab
+++ b/editors/nedit/files/patch-ab
@@ -1,9 +1,9 @@
---- source/Makefile.common.orig Tue Dec 14 21:58:24 1999
-+++ source/Makefile.common Sun May 28 19:31:01 2000
-@@ -15,6 +15,10 @@
- nc: nc.o
- $(CC) $(CFLAGS) nc.o ../util/libNUtil.a $(LIBS) -o $@
-
+--- source/Makefile.common.orig Thu May 15 19:42:31 2003
++++ source/Makefile.common Sat Feb 7 14:47:52 2004
+@@ -21,6 +21,10 @@
+ nc: nc.o server_common.o ../util/libNUtil.a
+ $(CC) $(CFLAGS) nc.o server_common.o ../util/libNUtil.a $(LIBS) -o $@
+
+install: nedit nc
+ ${INSTALL} ${COPY} ${STRIP} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} nedit ${PREFIX}/bin
+ ${INSTALL} ${COPY} ${STRIP} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} nc ${PREFIX}/bin/nclient
diff --git a/editors/nedit/files/patch-ac b/editors/nedit/files/patch-ac
index a725a806dc52..4f4e0e0ce384 100644
--- a/editors/nedit/files/patch-ac
+++ b/editors/nedit/files/patch-ac
@@ -1,31 +1,22 @@
-*** makefiles/Makefile.freebsd.orig Fri Aug 17 19:02:55 2001
---- makefiles/Makefile.freebsd Tue Oct 23 14:10:00 2001
-***************
-*** 1,13 ****
- # $Id: Makefile.freebsd,v 1.3 2001/08/17 23:02:55 edg Exp $
-! CC=cc
-! AR=ar
-
- # For editres, add -DEDITRES to CFLAGS and -lXmu to LIBS
- #
- # To evaluate an alternative layout for the Replace/Find dialog, add
- # -DREPLACE_SCOPE to the CFLAGS. See the README file for more information.
- #
-! CFLAGS=-O -I${PREFIX}/include -DUSE_DIRENT -DUSE_LPR_PRINT_CMD -DUSE_XMIM
-! LIBS= ${MOTIFLIB} -L${PREFIX}/lib -lm -lXpm -lXext -lXt -lSM -lICE -lX11
-
- include Makefile.common
---- 1,13 ----
- # $Id: Makefile.freebsd,v 1.3 2001/08/17 23:02:55 edg Exp $
-! CC?=cc
-! AR?=ar
-
- # For editres, add -DEDITRES to CFLAGS and -lXmu to LIBS
- #
- # To evaluate an alternative layout for the Replace/Find dialog, add
- # -DREPLACE_SCOPE to the CFLAGS. See the README file for more information.
- #
-! CFLAGS+=-O -I${X11BASE}/include -DUSE_DIRENT -DUSE_LPR_PRINT_CMD -DUSE_XMIM
-! LIBS= ${MOTIFLIB} -L${X11BASE}/lib -lm -lXpm -lXext -lXt -lSM -lICE -lX11
-
- include Makefile.common
+--- makefiles/Makefile.freebsd.orig Sun Sep 28 15:03:10 2003
++++ makefiles/Makefile.freebsd Sat Feb 7 15:00:18 2004
+@@ -1,6 +1,6 @@
+ # $Id: Makefile.freebsd,v 1.5.2.1 2003/09/28 15:03:10 edg Exp $
+-CC=cc
+-AR=ar
++CC?=cc
++AR?=ar
+
+ # For editres, add -DEDITRES to CFLAGS and -lXmu to LIBS
+ #
+@@ -10,8 +10,8 @@
+ # To test if the Motif library exports the runtime version
+ # add -DHAVE__XMVERSIONSTRING to CFLAGS
+ #
+-CFLAGS=-O -I${PREFIX}/include -DUSE_DIRENT -DUSE_LPR_PRINT_CMD -DUSE_XMIM
+-LIBS= ${MOTIFLIB} -L${PREFIX}/lib -lm -lXpm -lXext -lXt -lSM -lICE -lX11
++CFLAGS+=-O -I${X11BASE}/include -DUSE_DIRENT -DUSE_LPR_PRINT_CMD -DUSE_XMIM
++LIBS+= ${MOTIFLIB} -L${X11BASE}/lib -lm -lXpm -lXext -lXt -lSM -lICE -lX11
+
+ include Makefile.common
+
diff --git a/editors/nedit/files/patch-ad b/editors/nedit/files/patch-ad
index 2de722a430d0..12cdc67f5583 100644
--- a/editors/nedit/files/patch-ad
+++ b/editors/nedit/files/patch-ad
@@ -1,148 +1,12 @@
-*** doc/nc.man.orig Tue Oct 23 14:11:38 2001
---- doc/nc.man Tue Oct 23 14:13:39 2001
-***************
-*** 137,162 ****
- .rm #[ #] #H #V #F C
- .\" ======================================================================
- .\"
-! .IX Title "NC 1"
-! .TH NC 1 " " "2001-08-12" " "
- .UC
- .SH "NAME"
-! nc \- Client program for NEdit text editor
- .SH "SYNOPSYS"
- .IX Header "SYNOPSYS"
-! \&\fBnc\fR [\fB\-read\fR] [\fB\-create\fR] [\fB\-line\fR \fIn\fR | \fB+\fR\fIn\fR] [\fB\-do\fR \fIcommand\fR]
- [\fB\-ask\fR] [\fB\-noask\fR] [\fB\-svrname\fR \fIname\fR] [\fB\-svrcmd\fR \fIcommand\fR] [\fB\-lm\fR
- \&\fIlanguagemode\fR] [\fB\-geometry\fR \fIgeometry\fR] [\fB\-iconic\fR] [\fB\-display\fR
- \&\fI[host]:server[.screen]\fR] [file...]
- .SH "DESCRIPTION"
- .IX Header "DESCRIPTION"
-! \&\fBnc\fR is the client interface to the NEdit text editor. A server can be started
- explicitly by running NEdit in server mode:
- .PP
- .Vb 1
- \& nedit -server
- .Ve
-! If no server is running, \fBnc\fR will start one unless configured otherwize.
- Client/server mode is useful for integrating NEdit with software development
- environments, mailers, and other programs; or just as a quick way to open files
- from the shell command line without starting a new NEdit session.
---- 137,162 ----
- .rm #[ #] #H #V #F C
- .\" ======================================================================
- .\"
-! .IX Title "NCLIENT 1"
-! .TH NCLIENT 1 " " "2001-08-12" " "
- .UC
- .SH "NAME"
-! nclient \- Client program for NEdit text editor
- .SH "SYNOPSYS"
- .IX Header "SYNOPSYS"
-! \&\fBnclient\fR [\fB\-read\fR] [\fB\-create\fR] [\fB\-line\fR \fIn\fR | \fB+\fR\fIn\fR] [\fB\-do\fR \fIcommand\fR]
- [\fB\-ask\fR] [\fB\-noask\fR] [\fB\-svrname\fR \fIname\fR] [\fB\-svrcmd\fR \fIcommand\fR] [\fB\-lm\fR
- \&\fIlanguagemode\fR] [\fB\-geometry\fR \fIgeometry\fR] [\fB\-iconic\fR] [\fB\-display\fR
- \&\fI[host]:server[.screen]\fR] [file...]
- .SH "DESCRIPTION"
- .IX Header "DESCRIPTION"
-! \&\fBnclient\fR is the client interface to the NEdit text editor. A server can be started
- explicitly by running NEdit in server mode:
- .PP
- .Vb 1
- \& nedit -server
- .Ve
-! If no server is running, \fBnclient\fR will start one unless configured otherwize.
- Client/server mode is useful for integrating NEdit with software development
- environments, mailers, and other programs; or just as a quick way to open files
- from the shell command line without starting a new NEdit session.
-***************
-*** 177,194 ****
- the command line.
- .Ip "\fB\-ask\fR, \fB\-noask\fR" 4
- .IX Item "-ask, -noask"
-! Instructs \fBnc\fR whether to automatically start a server if one is not
-! available. This is also settable via the X resource, \f(CW\*(C`nc.autoStart\*(C'\fR.
- .Ip "\fB\-svrname\fR \fIname\fR" 4
- .IX Item "-svrname name"
-! Explicitly instructs \fBnc\fR which server to connect to, an instance of
- \&\fBnedit\fR(1) with a corresponding \fB\-svrname\fR argument. By naming servers, you
- can run several simultaneously, and direct files and commands specifically to
- any one.
- .Ip "\fB\-svrcmd\fR \fIcommand\fR" 4
- .IX Item "-svrcmd command"
-! The command which \fBnc\fR uses to start an NEdit server. It is also settable via
-! the X resource \f(CW\*(C`nc.serverCommand\*(C'\fR, by default, \fI\*(L"nedit \-server\*(R"\fR.
- .Ip "\fB\-lm\fR \fIlanguagemode\fR" 4
- .IX Item "-lm languagemode"
- Initial language mode used for editing succeeding files.
---- 177,194 ----
- the command line.
- .Ip "\fB\-ask\fR, \fB\-noask\fR" 4
- .IX Item "-ask, -noask"
-! Instructs \fBnclient\fR whether to automatically start a server if one is not
-! available. This is also settable via the X resource, \f(CW\*(C`nclient.autoStart\*(C'\fR.
- .Ip "\fB\-svrname\fR \fIname\fR" 4
- .IX Item "-svrname name"
-! Explicitly instructs \fBnclient\fR which server to connect to, an instance of
- \&\fBnedit\fR(1) with a corresponding \fB\-svrname\fR argument. By naming servers, you
- can run several simultaneously, and direct files and commands specifically to
- any one.
- .Ip "\fB\-svrcmd\fR \fIcommand\fR" 4
- .IX Item "-svrcmd command"
-! The command which \fBnclient\fR uses to start an NEdit server. It is also settable via
-! the X resource \f(CW\*(C`nclient.serverCommand\*(C'\fR, by default, \fI\*(L"nedit \-server\*(R"\fR.
- .Ip "\fB\-lm\fR \fIlanguagemode\fR" 4
- .IX Item "-lm languagemode"
- Initial language mode used for editing succeeding files.
-***************
-*** 226,236 ****
- .Ve
- .SH "NOTES"
- .IX Header "NOTES"
-! Communication between \fBnc\fR and \fBnedit\fR(1) is through the X display. So as
-! long as X windows is set up and working properly, \fBnc\fR will work properly
-! as well. \fBnc\fR uses the \f(CW\*(C`DISPLAY\*(C'\fR environment variable, the machine name and
- your user name to find the appropriate server, meaning, if you have several
-! machines sharing a common file system, \fBnc\fR will not be able to find a server
- that is running on a machine with a different host name, even though it may be
- perfectly appropriate for editing a given file.
- .PP
---- 226,236 ----
- .Ve
- .SH "NOTES"
- .IX Header "NOTES"
-! Communication between \fBnclient\fR and \fBnedit\fR(1) is through the X display. So as
-! long as X windows is set up and working properly, \fBnclient\fR will work properly
-! as well. \fBnclient\fR uses the \f(CW\*(C`DISPLAY\*(C'\fR environment variable, the machine name and
- your user name to find the appropriate server, meaning, if you have several
-! machines sharing a common file system, \fBnclient\fR will not be able to find a server
- that is running on a machine with a different host name, even though it may be
- perfectly appropriate for editing a given file.
- .PP
-***************
-*** 239,250 ****
- .Ip "incorrect:" 4
- .IX Item "incorrect:"
- .Vb 1
-! \& nc file.c -line 25
- .Ve
- .Ip "correct:" 4
- .IX Item "correct:"
- .Vb 1
-! \& nc -line 25 file.c
- .Ve
- .PP
- For more information see NEdit's online help, or \fInedit.doc\fR in the NEdit
---- 239,250 ----
- .Ip "incorrect:" 4
- .IX Item "incorrect:"
- .Vb 1
-! \& nclient file.c -line 25
- .Ve
- .Ip "correct:" 4
- .IX Item "correct:"
- .Vb 1
-! \& nclient -line 25 file.c
- .Ve
- .PP
- For more information see NEdit's online help, or \fInedit.doc\fR in the NEdit
+--- doc/nc.man.orig Thu Nov 20 18:40:13 2003
++++ doc/nc.man Sat Feb 7 14:54:18 2004
+@@ -285,6 +285,9 @@
+ .PP
+ For more information see NEdit's online help, or \fInedit.doc\fR in the NEdit
+ distribution kit.
++.PP
++In FreeBSD, \fInc\fR is installed as \fInclient\fR so it does not
++conflict with the \fInetcat\fR port which also installs an \fInc\fR.
+ .SH "SEE ALSO"
+ .IX Header "SEE ALSO"
+ \&\fInedit\fR\|(1), X(1), \fImwm\fR\|(1), \fIctags\fR\|(1), \fIetags\fR\|(1)
diff --git a/editors/nedit/files/patch-ae b/editors/nedit/files/patch-ae
new file mode 100644
index 000000000000..3b2f8a2e4c37
--- /dev/null
+++ b/editors/nedit/files/patch-ae
@@ -0,0 +1,14 @@
+--- util/check_lin_tif.c.orig Thu Nov 13 07:09:50 2003
++++ util/check_lin_tif.c Sat Feb 7 14:57:33 2004
+@@ -164,9 +164,8 @@
+ "risking instability and probable data loss. You are very brave!\n"
+ "Please do not report bugs to the NEdit developers unless you can\n"
+ "reproduce them with a known-good NEdit binary downloaded from:\n"
+- "\thttp://www.nedit.org\n"
+- "\nHIT ENTER TO CONTINUE\n", tif);
+- fgets(buf, 2, stdin);
++ "\thttp://www.nedit.org\n", tif);
++ sleep(5);
+ exit(0);
+ #else
+ fprintf(stderr,