aboutsummaryrefslogtreecommitdiff
path: root/editors/nedit
diff options
context:
space:
mode:
authorDaniel Eischen <deischen@FreeBSD.org>2001-10-31 18:07:28 +0000
committerDaniel Eischen <deischen@FreeBSD.org>2001-10-31 18:07:28 +0000
commit81ec07987a93baed0450a6e9e38b0e8462ea3ae7 (patch)
tree7ea460b3c9bec67026b2f583691fee080bbe9573 /editors/nedit
parent086bcfa4808d4a015bf108b9241644430140b028 (diff)
downloadports-81ec07987a93baed0450a6e9e38b0e8462ea3ae7.tar.gz
ports-81ec07987a93baed0450a6e9e38b0e8462ea3ae7.zip
Upgrade to version 5.2.
Notes
Notes: svn path=/head/; revision=49432
Diffstat (limited to 'editors/nedit')
-rw-r--r--editors/nedit/Makefile8
-rw-r--r--editors/nedit/distinfo2
-rw-r--r--editors/nedit/files/patch-aa6
-rw-r--r--editors/nedit/files/patch-ac22
-rw-r--r--editors/nedit/files/patch-ad167
-rw-r--r--editors/nedit/pkg-plist2
6 files changed, 173 insertions, 34 deletions
diff --git a/editors/nedit/Makefile b/editors/nedit/Makefile
index 27580eeed14c..84e08322c457 100644
--- a/editors/nedit/Makefile
+++ b/editors/nedit/Makefile
@@ -6,18 +6,18 @@
#
PORTNAME= nedit
-PORTVERSION= 5.1.1
+PORTVERSION= 5.2
CATEGORIES= editors
-MASTER_SITES= ftp://ftp.nedit.org/pub/v5_1_1/ \
+MASTER_SITES= ftp://ftp.nedit.org/pub/v5_2/ \
ftp://ftp.nedit.org/pub/contrib/misc/
-DISTFILES= nedit-5.1.1-src.tar.gz nedit.app-defaults
+DISTFILES= nedit-5.2-src.tar.Z nedit.app-defaults
MAINTAINER= deischen@freebsd.org
USE_MOTIF= yes
USE_X_PREFIX= yes
USE_XPM= yes
-EXTRACT_ONLY= nedit-5.1.1-src.tar.gz
+EXTRACT_ONLY= nedit-5.2-src.tar.Z
MAN1= nclient.1 nedit.1
ALL_TARGET= freebsd
diff --git a/editors/nedit/distinfo b/editors/nedit/distinfo
index ad8387bd5815..1e23e316c643 100644
--- a/editors/nedit/distinfo
+++ b/editors/nedit/distinfo
@@ -1,2 +1,2 @@
-MD5 (nedit-5.1.1-src.tar.gz) = dba0970c60debada237ca852b5f57ec8
+MD5 (nedit-5.2-src.tar.Z) = 76810d24eb16f069da9e558fba29b3e3
MD5 (nedit.app-defaults) = 36c5e660039e0bd4b4d05df609b505bb
diff --git a/editors/nedit/files/patch-aa b/editors/nedit/files/patch-aa
index 3439e869c62b..8b0d0863d571 100644
--- a/editors/nedit/files/patch-aa
+++ b/editors/nedit/files/patch-aa
@@ -8,9 +8,9 @@
+ install::
+ (cd source; make -f Makefile.freebsd install)
-+ ${INSTALL} ${COPY} -o ${BINOWN} -g ${BINGRP} -m 644 nedit.man ${PREFIX}/man/man1/nedit.1
-+ ${INSTALL} ${COPY} -o ${BINOWN} -g ${BINGRP} -m 644 nc.man ${PREFIX}/man/man1/nclient.1
-+ ${INSTALL} ${COPY} -m 644 NEdit.ad ${X11BASE}/lib/X11/app-defaults/NEdit
++ ${INSTALL} ${COPY} -o ${BINOWN} -g ${BINGRP} -m 644 doc/nedit.man ${PREFIX}/man/man1/nedit.1
++ ${INSTALL} ${COPY} -o ${BINOWN} -g ${BINGRP} -m 644 doc/nc.man ${PREFIX}/man/man1/nclient.1
++ ${INSTALL} ${COPY} -m 644 NEdit.ad ${X11BASE}/lib/X11/app-defaults/NEdit.ad
+
clean:
(cd util; $(MAKE) -f Makefile.common clean)
diff --git a/editors/nedit/files/patch-ac b/editors/nedit/files/patch-ac
index 2ed59bcf2bd0..a725a806dc52 100644
--- a/editors/nedit/files/patch-ac
+++ b/editors/nedit/files/patch-ac
@@ -1,21 +1,31 @@
-*** makefiles/Makefile.freebsd.orig Sun Dec 12 09:07:47 1999
---- makefiles/Makefile.freebsd Mon Mar 27 07:49:08 2000
+*** makefiles/Makefile.freebsd.orig Fri Aug 17 19:02:55 2001
+--- makefiles/Makefile.freebsd Tue Oct 23 14:10:00 2001
***************
-*** 1,8 ****
+*** 1,13 ****
+ # $Id: Makefile.freebsd,v 1.3 2001/08/17 23:02:55 edg Exp $
! CC=cc
! AR=ar
# For editres, add -DEDITRES to CFLAGS and -lXmu to LIBS
+ #
+ # To evaluate an alternative layout for the Replace/Find dialog, add
+ # -DREPLACE_SCOPE to the CFLAGS. See the README file for more information.
+ #
! CFLAGS=-O -I${PREFIX}/include -DUSE_DIRENT -DUSE_LPR_PRINT_CMD -DUSE_XMIM
! LIBS= ${MOTIFLIB} -L${PREFIX}/lib -lm -lXpm -lXext -lXt -lSM -lICE -lX11
-! include Makefile.common
---- 1,8 ----
+ include Makefile.common
+--- 1,13 ----
+ # $Id: Makefile.freebsd,v 1.3 2001/08/17 23:02:55 edg Exp $
! CC?=cc
! AR?=ar
# For editres, add -DEDITRES to CFLAGS and -lXmu to LIBS
+ #
+ # To evaluate an alternative layout for the Replace/Find dialog, add
+ # -DREPLACE_SCOPE to the CFLAGS. See the README file for more information.
+ #
! CFLAGS+=-O -I${X11BASE}/include -DUSE_DIRENT -DUSE_LPR_PRINT_CMD -DUSE_XMIM
! LIBS= ${MOTIFLIB} -L${X11BASE}/lib -lm -lXpm -lXext -lXt -lSM -lICE -lX11
-! include Makefile.common
+ include Makefile.common
diff --git a/editors/nedit/files/patch-ad b/editors/nedit/files/patch-ad
index 67e296e3bae6..2de722a430d0 100644
--- a/editors/nedit/files/patch-ad
+++ b/editors/nedit/files/patch-ad
@@ -1,19 +1,148 @@
---- nc.man.orig Sun May 28 19:29:15 2000
-+++ nc.man Sun May 28 19:29:59 2000
-@@ -1,12 +1,12 @@
--.TH NC 1
-+.TH NCLIENT 1
- .SH NAME
--NC \- Client program for NEdit text editor
-+NCLIENT \- Client program for NEdit text editor
- .SH SYNOPSYS
--.B nc [\-read] [\-create] [\-line n\ |\ +n] [\-do\ command]
-+.B nclient [\-read] [\-create] [\-line n\ |\ +n] [\-do\ command]
- [\-ask] [\-noask] [\-svrname\ name] [-svrcmd\ command]
- [\-lm languagemode] [\-geometry\ geometry] [\-iconic] [file...]
- .SH DESCRIPTION
--nc is the client interface to the NEdit text editor. To use nc,
-+nclient is the client interface to the NEdit text editor. To use nclient,
- first run NEdit in server mode:
- .PP
- .EX
+*** doc/nc.man.orig Tue Oct 23 14:11:38 2001
+--- doc/nc.man Tue Oct 23 14:13:39 2001
+***************
+*** 137,162 ****
+ .rm #[ #] #H #V #F C
+ .\" ======================================================================
+ .\"
+! .IX Title "NC 1"
+! .TH NC 1 " " "2001-08-12" " "
+ .UC
+ .SH "NAME"
+! nc \- Client program for NEdit text editor
+ .SH "SYNOPSYS"
+ .IX Header "SYNOPSYS"
+! \&\fBnc\fR [\fB\-read\fR] [\fB\-create\fR] [\fB\-line\fR \fIn\fR | \fB+\fR\fIn\fR] [\fB\-do\fR \fIcommand\fR]
+ [\fB\-ask\fR] [\fB\-noask\fR] [\fB\-svrname\fR \fIname\fR] [\fB\-svrcmd\fR \fIcommand\fR] [\fB\-lm\fR
+ \&\fIlanguagemode\fR] [\fB\-geometry\fR \fIgeometry\fR] [\fB\-iconic\fR] [\fB\-display\fR
+ \&\fI[host]:server[.screen]\fR] [file...]
+ .SH "DESCRIPTION"
+ .IX Header "DESCRIPTION"
+! \&\fBnc\fR is the client interface to the NEdit text editor. A server can be started
+ explicitly by running NEdit in server mode:
+ .PP
+ .Vb 1
+ \& nedit -server
+ .Ve
+! If no server is running, \fBnc\fR will start one unless configured otherwize.
+ Client/server mode is useful for integrating NEdit with software development
+ environments, mailers, and other programs; or just as a quick way to open files
+ from the shell command line without starting a new NEdit session.
+--- 137,162 ----
+ .rm #[ #] #H #V #F C
+ .\" ======================================================================
+ .\"
+! .IX Title "NCLIENT 1"
+! .TH NCLIENT 1 " " "2001-08-12" " "
+ .UC
+ .SH "NAME"
+! nclient \- Client program for NEdit text editor
+ .SH "SYNOPSYS"
+ .IX Header "SYNOPSYS"
+! \&\fBnclient\fR [\fB\-read\fR] [\fB\-create\fR] [\fB\-line\fR \fIn\fR | \fB+\fR\fIn\fR] [\fB\-do\fR \fIcommand\fR]
+ [\fB\-ask\fR] [\fB\-noask\fR] [\fB\-svrname\fR \fIname\fR] [\fB\-svrcmd\fR \fIcommand\fR] [\fB\-lm\fR
+ \&\fIlanguagemode\fR] [\fB\-geometry\fR \fIgeometry\fR] [\fB\-iconic\fR] [\fB\-display\fR
+ \&\fI[host]:server[.screen]\fR] [file...]
+ .SH "DESCRIPTION"
+ .IX Header "DESCRIPTION"
+! \&\fBnclient\fR is the client interface to the NEdit text editor. A server can be started
+ explicitly by running NEdit in server mode:
+ .PP
+ .Vb 1
+ \& nedit -server
+ .Ve
+! If no server is running, \fBnclient\fR will start one unless configured otherwize.
+ Client/server mode is useful for integrating NEdit with software development
+ environments, mailers, and other programs; or just as a quick way to open files
+ from the shell command line without starting a new NEdit session.
+***************
+*** 177,194 ****
+ the command line.
+ .Ip "\fB\-ask\fR, \fB\-noask\fR" 4
+ .IX Item "-ask, -noask"
+! Instructs \fBnc\fR whether to automatically start a server if one is not
+! available. This is also settable via the X resource, \f(CW\*(C`nc.autoStart\*(C'\fR.
+ .Ip "\fB\-svrname\fR \fIname\fR" 4
+ .IX Item "-svrname name"
+! Explicitly instructs \fBnc\fR which server to connect to, an instance of
+ \&\fBnedit\fR(1) with a corresponding \fB\-svrname\fR argument. By naming servers, you
+ can run several simultaneously, and direct files and commands specifically to
+ any one.
+ .Ip "\fB\-svrcmd\fR \fIcommand\fR" 4
+ .IX Item "-svrcmd command"
+! The command which \fBnc\fR uses to start an NEdit server. It is also settable via
+! the X resource \f(CW\*(C`nc.serverCommand\*(C'\fR, by default, \fI\*(L"nedit \-server\*(R"\fR.
+ .Ip "\fB\-lm\fR \fIlanguagemode\fR" 4
+ .IX Item "-lm languagemode"
+ Initial language mode used for editing succeeding files.
+--- 177,194 ----
+ the command line.
+ .Ip "\fB\-ask\fR, \fB\-noask\fR" 4
+ .IX Item "-ask, -noask"
+! Instructs \fBnclient\fR whether to automatically start a server if one is not
+! available. This is also settable via the X resource, \f(CW\*(C`nclient.autoStart\*(C'\fR.
+ .Ip "\fB\-svrname\fR \fIname\fR" 4
+ .IX Item "-svrname name"
+! Explicitly instructs \fBnclient\fR which server to connect to, an instance of
+ \&\fBnedit\fR(1) with a corresponding \fB\-svrname\fR argument. By naming servers, you
+ can run several simultaneously, and direct files and commands specifically to
+ any one.
+ .Ip "\fB\-svrcmd\fR \fIcommand\fR" 4
+ .IX Item "-svrcmd command"
+! The command which \fBnclient\fR uses to start an NEdit server. It is also settable via
+! the X resource \f(CW\*(C`nclient.serverCommand\*(C'\fR, by default, \fI\*(L"nedit \-server\*(R"\fR.
+ .Ip "\fB\-lm\fR \fIlanguagemode\fR" 4
+ .IX Item "-lm languagemode"
+ Initial language mode used for editing succeeding files.
+***************
+*** 226,236 ****
+ .Ve
+ .SH "NOTES"
+ .IX Header "NOTES"
+! Communication between \fBnc\fR and \fBnedit\fR(1) is through the X display. So as
+! long as X windows is set up and working properly, \fBnc\fR will work properly
+! as well. \fBnc\fR uses the \f(CW\*(C`DISPLAY\*(C'\fR environment variable, the machine name and
+ your user name to find the appropriate server, meaning, if you have several
+! machines sharing a common file system, \fBnc\fR will not be able to find a server
+ that is running on a machine with a different host name, even though it may be
+ perfectly appropriate for editing a given file.
+ .PP
+--- 226,236 ----
+ .Ve
+ .SH "NOTES"
+ .IX Header "NOTES"
+! Communication between \fBnclient\fR and \fBnedit\fR(1) is through the X display. So as
+! long as X windows is set up and working properly, \fBnclient\fR will work properly
+! as well. \fBnclient\fR uses the \f(CW\*(C`DISPLAY\*(C'\fR environment variable, the machine name and
+ your user name to find the appropriate server, meaning, if you have several
+! machines sharing a common file system, \fBnclient\fR will not be able to find a server
+ that is running on a machine with a different host name, even though it may be
+ perfectly appropriate for editing a given file.
+ .PP
+***************
+*** 239,250 ****
+ .Ip "incorrect:" 4
+ .IX Item "incorrect:"
+ .Vb 1
+! \& nc file.c -line 25
+ .Ve
+ .Ip "correct:" 4
+ .IX Item "correct:"
+ .Vb 1
+! \& nc -line 25 file.c
+ .Ve
+ .PP
+ For more information see NEdit's online help, or \fInedit.doc\fR in the NEdit
+--- 239,250 ----
+ .Ip "incorrect:" 4
+ .IX Item "incorrect:"
+ .Vb 1
+! \& nclient file.c -line 25
+ .Ve
+ .Ip "correct:" 4
+ .IX Item "correct:"
+ .Vb 1
+! \& nclient -line 25 file.c
+ .Ve
+ .PP
+ For more information see NEdit's online help, or \fInedit.doc\fR in the NEdit
diff --git a/editors/nedit/pkg-plist b/editors/nedit/pkg-plist
index b759ec33c043..46b0c50522f4 100644
--- a/editors/nedit/pkg-plist
+++ b/editors/nedit/pkg-plist
@@ -1,3 +1,3 @@
bin/nclient
bin/nedit
-lib/X11/app-defaults/NEdit
+lib/X11/app-defaults/NEdit.ad