aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-3-devel/Makefile
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2005-06-03 23:18:49 +0000
committerMaho Nakata <maho@FreeBSD.org>2005-06-03 23:18:49 +0000
commit8b311bac35dc42c77568037344edb3bc175b503a (patch)
treea8e1fe4a6c733d4b1e6709cbba47038b8dbd8a70 /editors/openoffice-3-devel/Makefile
parentab3f4c8bf48715a2bf389138024fa46b0f60004e (diff)
downloadports-8b311bac35dc42c77568037344edb3bc175b503a.tar.gz
ports-8b311bac35dc42c77568037344edb3bc175b503a.zip
o For QA purpose, add optional target package-canonical.
Using this packaging method, packages must build without errors. Nevertheless we'll go our own way. o Change packaging method from generic one to FreeBSD's native one. This works well for both packaging method and slightly saves disk space as well. o Fix some problems arose by using FreeBSD's native packaging method. Result of: CodeFest Japan 2005 https://members.fsij.org/trac/codefest2005/
Notes
Notes: svn path=/head/; revision=136770
Diffstat (limited to 'editors/openoffice-3-devel/Makefile')
-rw-r--r--editors/openoffice-3-devel/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index 94a4282f01d2..800c6c97b989 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -103,7 +103,7 @@ TCSH?= /bin/tcsh
PKGMESSAGE= ${WRKDIR}/pkg-message
NUMOFPROCESSES?= 1
-CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp --with-gnu-patch=${LOCALBASE}/bin/gpatch --with-package-format=portable
+CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp --with-gnu-patch=${LOCALBASE}/bin/gpatch
.include <${FILESDIR}/Makefile.knobs>
@@ -144,7 +144,7 @@ do-build:
.endif
do-install:
- @cd ${WRKSRC}/instsetoo_native/unxfbsd.pro/OpenOffice/install/${LOCALIZED_LANG}/freebsd-*/ ; ${LS} *.sw > ${WRKDIR}/INSTALLFILES
+ @cd ${WRKSRC}/instsetoo_native/unxfbsd.pro/OpenOffice/install/${LOCALIZED_LANG}/freebsd-*/ ; ${LS} *.tgz > ${WRKDIR}/INSTALLFILES
@${RM} -Rf ${WRKDIR}/tmp
@${MKDIR} ${WRKDIR}/tmp
@for i in `${CAT} ${WRKDIR}/INSTALLFILES`; do \
@@ -198,6 +198,12 @@ package-rename:
@${MV} ${PKGFILE} \
${WRKDIR}/../${PACKAGE_BASENAME}_install_${LOCALIZED_LANG}${PKG_SUFX}
+package-canonical:
+ @${ECHO_MSG} "===> Canonical packaging for OpenOffice.org";
+ @cd ${WRKSRC}/instsetoo_native/unxfbsd.pro/OpenOffice/install/${LOCALIZED_LANG}/freebsd-*/ ;\
+ ${TAR} cfj ${WRKDIR}/../${PACKAGE_BASENAME}_native_install_${LOCALIZED_LANG}${PKG_SUFX} .
+ @${CP} ${WRKSRC}/instsetoo_native/unxfbsd.pro/OpenOffice_languagepack/install/${LOCALIZED_LANG}/freebsd-*/openofficeorg-*.tgz .
+
sdk:
@${ECHO_MSG} "===> Make SDK of OpenOffice.org"
@cd ${WRKSRC} ; ${TCSH} -c 'source FreeBSDEnv.Set ; cd sdk_oo ; build.pl ; deliver.pl'
@@ -220,7 +226,7 @@ languagepack:
@${MKDIR} ${WRKDIR}/langpack_tmp
.if defined (LOCALIZED_LANG)
@cd ${WRKDIR}/langpack_tmp ; \
- ${TAR} xf ${WRKSRC}/instsetoo_native/unxfbsd.pro/OpenOffice_languagepack/install/${LOCALIZED_LANG}/freebsd-*/openofficeorg-*.sw
+ ${TAR} xf ${WRKSRC}/instsetoo_native/unxfbsd.pro/OpenOffice_languagepack/install/${LOCALIZED_LANG}/freebsd-*/openofficeorg-*.tgz
@cd ${WRKDIR}/langpack_tmp/opt/openoffice* ; \
${MKDIR} ../${INSTALLATION_BASEDIR} ; \
${MV} * ../${INSTALLATION_BASEDIR} ; cd .. ; \