aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-4
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2014-01-22 05:44:33 +0000
committerMaho Nakata <maho@FreeBSD.org>2014-01-22 05:44:33 +0000
commit4f3aa3c715ff5fee2d8ef2e1a56306794c2576b6 (patch)
tree368c71dbea39974e7b9b38354820e25af1ae5b3c /editors/openoffice-4
parentbf0d93dca31c9629e5a08b4d77f363d496e9c6c6 (diff)
downloadports-4f3aa3c715ff5fee2d8ef2e1a56306794c2576b6.tar.gz
ports-4f3aa3c715ff5fee2d8ef2e1a56306794c2576b6.zip
Fix build
PR: 185401 Submitted by: Jan Henrik Sylvester <me@janh.de>
Notes
Notes: svn path=/head/; revision=340680
Diffstat (limited to 'editors/openoffice-4')
-rw-r--r--editors/openoffice-4/files/patch-moz-freetype_header_relocation73
-rw-r--r--editors/openoffice-4/files/patch-nss-gcc4627
-rw-r--r--editors/openoffice-4/files/patch-vcl_source_glyphs_graphite_adaptors.cxx11
3 files changed, 111 insertions, 0 deletions
diff --git a/editors/openoffice-4/files/patch-moz-freetype_header_relocation b/editors/openoffice-4/files/patch-moz-freetype_header_relocation
new file mode 100644
index 000000000000..499b7c55adee
--- /dev/null
+++ b/editors/openoffice-4/files/patch-moz-freetype_header_relocation
@@ -0,0 +1,73 @@
+--- moz/makefile.mk.orig 2013-08-13 11:49:32.000000000 +0000
++++ moz/makefile.mk 2014-01-01 20:09:17.000000000 +0000
+@@ -99,7 +99,8 @@
+ patches/respect_disable_pango.patch \
+ patches/arm_build_fix.patch \
+ patches/link_fontconfig.patch \
+- patches/brokenmakefile.patch
++ patches/brokenmakefile.patch \
++ patches/freetype_header_relocation.patch
+
+ .IF "$(OS)"=="LINUX"
+ PATCH_FILES+=patches/nss_linux.patch
+--- moz/patches/freetype_header_relocation.patch.orig 1970-01-01 00:00:00.000000000 +0000
++++ moz/patches/freetype_header_relocation.patch 2014-01-01 20:50:11.000000000 +0000
+@@ -0,0 +1,58 @@
++--- misc/build/mozilla/config/system-headers.orig 2007-11-19 21:36:18.000000000 +0100
+++++ misc/build/mozilla/config/system-headers 2014-01-01 20:47:56.000000000 +0100
++@@ -193,12 +193,12 @@
++ fpieee.h
++ frame/log.h
++ frame/req.h
++-freetype/freetype.h
++-freetype/ftcache.h
++-freetype/ftglyph.h
++-freetype/ftoutln.h
++-freetype/ttnameid.h
++-freetype/tttables.h
+++freetype.h
+++ftcache.h
+++ftglyph.h
+++ftoutln.h
+++ttnameid.h
+++tttables.h
++ fribidi/fribidi.h
++ FSp_fopen.h
++ fstream.h
++--- misc/build/mozilla/gfx/src/gtk/nsFontMetricsXft.cpp.orig 2008-01-29 19:31:08.000000000 +0000
+++++ misc/build/mozilla/gfx/src/gtk/nsFontMetricsXft.cpp 2014-01-01 20:43:42.000000000 +0000
++@@ -67,8 +67,8 @@
++ #include "nsFontConfigUtils.h"
++
++ #include <gdk/gdkx.h>
++-#include <freetype/tttables.h>
++-#include <freetype/freetype.h>
+++#include <tttables.h>
+++#include <freetype.h>
++
++ #define FORCE_PR_LOG
++ #include "prlog.h"
++--- misc/build/mozilla/gfx/src/gtk/nsFontMetricsPango.cpp.orig 2008-01-29 19:31:08.000000000 +0000
+++++ misc/build/mozilla/gfx/src/gtk/nsFontMetricsPango.cpp 2014-01-01 20:44:06.000000000 +0000
++@@ -58,7 +58,7 @@
++ #include <fontconfig/fontconfig.h>
++ #include <gdk/gdk.h>
++ #include <gdk/gdkx.h>
++-#include <freetype/tttables.h>
+++#include <tttables.h>
++
++ #include "mozilla-decoder.h"
++
++--- misc/build/mozilla/gfx/src/cairo/nsFontMetricsXft.cpp.orig 2008-01-29 19:31:08.000000000 +0000
+++++ misc/build/mozilla/gfx/src/cairo/nsFontMetricsXft.cpp 2014-01-01 20:44:34.000000000 +0000
++@@ -67,8 +67,8 @@
++ #include "nsFontConfigUtils.h"
++
++ #include <gdk/gdkx.h>
++-#include <freetype/tttables.h>
++-#include <freetype/freetype.h>
+++#include <tttables.h>
+++#include <freetype.h>
++
++ #define FORCE_PR_LOG
++ #include "prlog.h"
diff --git a/editors/openoffice-4/files/patch-nss-gcc46 b/editors/openoffice-4/files/patch-nss-gcc46
new file mode 100644
index 000000000000..e3358a9e28e8
--- /dev/null
+++ b/editors/openoffice-4/files/patch-nss-gcc46
@@ -0,0 +1,27 @@
+--- nss/makefile.mk.orig 2013-08-13 11:46:06.000000000 +0000
++++ nss/makefile.mk 2014-01-01 18:13:26.000000000 +0000
+@@ -44,6 +44,10 @@
+ TARFILE_ROOTDIR=nss-3.12.6
+ PATCH_FILES=nss.patch
+
++.IF "$(OS)"=="FREEBSD"
++PATCH_FILES+=nss_freebsd.patch
++.ENDIF # "$(OS)"=="FREEBSD"
++
+ .IF "$(OS)"=="MACOSX"
+ MACOS_SDK_DIR=/Developer/SDKs/MacOSX10.4u.sdk
+ .EXPORT : MACOS_SDK_DIR
+--- nss/nss_freebsd.patch.orig 1970-01-01 00:00:00.000000000 +0000
++++ nss/nss_freebsd.patch 2014-01-01 18:08:20.000000000 +0000
+@@ -0,0 +1,11 @@
++--- misc/build/nss-3.12.6/mozilla/security/coreconf/FreeBSD.mk.orig 2009-08-22 05:33:09.000000000 +0000
+++++ misc/build/nss-3.12.6/mozilla/security/coreconf/FreeBSD.mk 2014-01-01 13:47:48.000000000 +0000
++@@ -38,7 +38,7 @@
++ include $(CORE_DEPTH)/coreconf/UNIX.mk
++
++ DEFAULT_COMPILER = gcc
++-CC = gcc
+++#CC = gcc
++ CCC = g++
++ RANLIB = ranlib
++
diff --git a/editors/openoffice-4/files/patch-vcl_source_glyphs_graphite_adaptors.cxx b/editors/openoffice-4/files/patch-vcl_source_glyphs_graphite_adaptors.cxx
new file mode 100644
index 000000000000..28d522376d42
--- /dev/null
+++ b/editors/openoffice-4/files/patch-vcl_source_glyphs_graphite_adaptors.cxx
@@ -0,0 +1,11 @@
+--- vcl/source/glyphs/graphite_adaptors.cxx.orig 2013-08-13 11:45:43.000000000 +0000
++++ vcl/source/glyphs/graphite_adaptors.cxx 2013-12-31 16:39:41.000000000 +0000
+@@ -45,7 +45,7 @@
+
+ #include <salgdi.hxx>
+
+-#include <freetype/ftsynth.h>
++#include <ftsynth.h>
+
+ // Module
+ #include "gcach_ftyp.hxx"