aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice.org-1.0/files/patch-tools+bootstrp+makefile.mk
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2002-03-07 16:49:17 +0000
committerMartin Blapp <mbr@FreeBSD.org>2002-03-07 16:49:17 +0000
commit31d5ac22c5c389d41cfc9172948b0916ac5282df (patch)
treee008da3e6628c093d8e9224aa17373f55d93f37a /editors/openoffice.org-1.0/files/patch-tools+bootstrp+makefile.mk
parent715b153f257091390c3c212dae2e0d7cc6b371be (diff)
downloadports-31d5ac22c5c389d41cfc9172948b0916ac5282df.tar.gz
ports-31d5ac22c5c389d41cfc9172948b0916ac5282df.zip
Avoid double symbols for set_new_handler__FPFv_v. Patch from NetBSD
Notes
Notes: svn path=/head/; revision=55682
Diffstat (limited to 'editors/openoffice.org-1.0/files/patch-tools+bootstrp+makefile.mk')
-rw-r--r--editors/openoffice.org-1.0/files/patch-tools+bootstrp+makefile.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/editors/openoffice.org-1.0/files/patch-tools+bootstrp+makefile.mk b/editors/openoffice.org-1.0/files/patch-tools+bootstrp+makefile.mk
new file mode 100644
index 000000000000..b188641846f0
--- /dev/null
+++ b/editors/openoffice.org-1.0/files/patch-tools+bootstrp+makefile.mk
@@ -0,0 +1,23 @@
+--- ../tools/bootstrp/makefile.mk.orig Tue Jan 1 14:12:19 2002
++++ ../tools/bootstrp/makefile.mk
+@@ -83,6 +83,15 @@
+ @echo No bootstrp for Mac OS
+ .ELSE # "$(OS)"=="MACOS"
+
++.IF "$(OS)"=="NETBSD" || "$(OS)"=="FREEBSD"
++ALLTAR2: $(LB)$/libgcc_pic.a $(LB)$/libgcc.a ALLTAR
++ @echo ""
++$(LB)$/libgcc_pic.a:
++ -objcopy -L set_new_handler__FPFv_v /usr/lib/libgcc_pic.a $(LB)$/libgcc_pic.a
++$(LB)$/libgcc.a:
++ objcopy -L set_new_handler__FPFv_v `gcc -print-libgcc-file-name` $(LB)$/libgcc.a
++.ENDIF
++
+ OBJFILES= \
+ $(OBJ)$/sstring.obj \
+ $(OBJ)$/appdef.obj \
+@@ -172,3 +181,4 @@
+ # --- Targets ------------------------------------------------------
+
+ .INCLUDE : target.mk
++