aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice.org-2.0-devel/files/debugpatch-solenv+inc+unxfbsdi.mk
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2002-07-21 22:48:50 +0000
committerMartin Blapp <mbr@FreeBSD.org>2002-07-21 22:48:50 +0000
commitc626bc93e8151e078923d60d0790229849be1d28 (patch)
tree8ebfa376a0e471769644b0cd641fee55b9e89f3b /editors/openoffice.org-2.0-devel/files/debugpatch-solenv+inc+unxfbsdi.mk
parent5e81b40672a3c3c099c00f5b7230e4973e2955c6 (diff)
downloadports-c626bc93e8151e078923d60d0790229849be1d28.tar.gz
ports-c626bc93e8151e078923d60d0790229849be1d28.zip
Make WITH_DEBUG tunable. WITH_DEBUG=1 just adds debugs symbols.
WITH_DEBUG=2 turns on internal OO.org debug support. Unfortunatly it is broken at the moment.
Notes
Notes: svn path=/head/; revision=63340
Diffstat (limited to 'editors/openoffice.org-2.0-devel/files/debugpatch-solenv+inc+unxfbsdi.mk')
-rw-r--r--editors/openoffice.org-2.0-devel/files/debugpatch-solenv+inc+unxfbsdi.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/editors/openoffice.org-2.0-devel/files/debugpatch-solenv+inc+unxfbsdi.mk b/editors/openoffice.org-2.0-devel/files/debugpatch-solenv+inc+unxfbsdi.mk
new file mode 100644
index 000000000000..52bd2b3d58d6
--- /dev/null
+++ b/editors/openoffice.org-2.0-devel/files/debugpatch-solenv+inc+unxfbsdi.mk
@@ -0,0 +1,18 @@
+--- ../solenv/inc/unxfbsdi.mk.orig Mon Jul 22 00:40:56 2002
++++ ../solenv/inc/unxfbsdi.mk Mon Jul 22 00:42:02 2002
+@@ -25,12 +25,12 @@
+ .ENDIF
+
+ # flags for C and C++ Compiler
+-CFLAGS+=-w -c $(INCLUDE) -I$(SOLARENV)/unxfbsdi/usr/include
++CFLAGS+=-g -ggdb -w -c $(INCLUDE) -I$(SOLARENV)/unxfbsdi/usr/include
+ CFLAGS+=-I/usr/X11R6/include
+
+ # flags for the C++ Compiler
+-CFLAGSCC=-pipe
+-CFLAGSCXX=-pipe -fno-for-scope -fpermissive
++CFLAGSCC=-g -ggdb -pipe
++CFLAGSCXX=-g -ggdb -pipe -fno-for-scope -fpermissive
+
+ # Flags for enabling exception handling
+ CFLAGSEXCEPTIONS=-fexceptions