aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice.org-3-RC
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2006-04-18 20:54:47 +0000
committerMaho Nakata <maho@FreeBSD.org>2006-04-18 20:54:47 +0000
commit790e51e299f7c2169e6c810cf239ee792c766cdf (patch)
tree821ac3486bd479668711130356e27bfa364e6ca8 /editors/openoffice.org-3-RC
parent4f0fd4573a38f8463ae94f3a56f89dca08eb31bb (diff)
downloadports-790e51e299f7c2169e6c810cf239ee792c766cdf.tar.gz
ports-790e51e299f7c2169e6c810cf239ee792c766cdf.zip
Java related fix (regcomp/javaldx)
Notes
Notes: svn path=/head/; revision=159903
Diffstat (limited to 'editors/openoffice.org-3-RC')
-rw-r--r--editors/openoffice.org-3-RC/Makefile2
-rw-r--r--editors/openoffice.org-3-RC/files/patch-i6444255
2 files changed, 55 insertions, 2 deletions
diff --git a/editors/openoffice.org-3-RC/Makefile b/editors/openoffice.org-3-RC/Makefile
index f3f49e533376..5b7825537414 100644
--- a/editors/openoffice.org-3-RC/Makefile
+++ b/editors/openoffice.org-3-RC/Makefile
@@ -182,13 +182,11 @@ post-extract:
@cd ${WRKDIR} ; ${CAT} ${DISTDIR}/${DIST_SUBDIR}/${ANT_DISTFILE} | ${BZIP2_CMD} -d | ${TAR} xf -
@${RM} -Rf ${WRKDIR}/gnugcj
@${MKDIR} ${WRKDIR}/gnugcj/bin
- @${MKDIR} ${WRKDIR}/gnugcj/lib
@${LN} -s ${LOCALBASE}/bin/gcj41 ${WRKDIR}/gnugcj/bin/gcj
@${LN} -s ${LOCALBASE}/bin/gij41 ${WRKDIR}/gnugcj/bin/gij
@${LN} -s ${LOCALBASE}/bin/gjdoc ${WRKDIR}/gnugcj/bin/javadoc # #iXXXXX# xmerge doesn't support gjdoc
@${LN} -s ${LOCALBASE}/bin/fastjar41 ${WRKDIR}/gnugcj/bin/fastjar
@${LN} -s ${LOCALBASE}/bin/gcj-dbtool41 ${WRKDIR}/gnugcj/bin/gcj-dbtool
- @${LN} -s ${PREFIX}/lib/gcc/${MACHINE_ARCH}-portbld-freebsd${OSREL}/${GCCVER}/libgcj.so ${WRKDIR}/gnugcj/lib
.endif
.if defined(WITH_GPC)
@cd ${WRKDIR} ; ${CAT} ${DISTDIR}/${DIST_SUBDIR}/gpc231.tar.Z | ${TAR} xfz -
diff --git a/editors/openoffice.org-3-RC/files/patch-i64442 b/editors/openoffice.org-3-RC/files/patch-i64442
new file mode 100644
index 000000000000..9b7670ffc11f
--- /dev/null
+++ b/editors/openoffice.org-3-RC/files/patch-i64442
@@ -0,0 +1,55 @@
+
+Index: jvmfwk/plugins/sunmajor/pluginlib/gnujre.cxx
+===================================================================
+RCS file: /cvs/udk/jvmfwk/plugins/sunmajor/pluginlib/gnujre.cxx,v
+retrieving revision 1.5
+diff -u -r1.5 gnujre.cxx
+--- jvmfwk/plugins/sunmajor/pluginlib/gnujre.cxx 20 Jan 2006 10:54:22 -0000 1.5
++++ jvmfwk/plugins/sunmajor/pluginlib/gnujre.cxx 18 Apr 2006 02:29:16 -0000
+@@ -63,11 +63,11 @@
+ char const* const* GnuInfo::getRuntimePaths(int * size)
+ {
+ static char const* ar[]= {
+- "/lib/libgcj.so.7",
+- "/lib/libgcj.so.6"
++ "/libgcj.so.7",
++ "/libgcj.so.6"
+ #if 0 //unreliable
+- , "/lib/libgcj.so.5"
+- , "/lib/libgcj.so.4"
++ , "/libgcj.so.5"
++ , "/libgcj.so.4"
+ #endif
+ };
+ *size = sizeof(ar) / sizeof (char*);
+@@ -86,7 +86,7 @@
+ OUString sVersionProperty(
+ RTL_CONSTASCII_USTRINGPARAM("java.version"));
+ OUString sHomeProperty(
+- RTL_CONSTASCII_USTRINGPARAM("java.home"));
++ RTL_CONSTASCII_USTRINGPARAM("gnu.classpath.home.url"));
+ OUString sAccessProperty(
+ RTL_CONSTASCII_USTRINGPARAM("javax.accessibility.assistive_technologies"));
+
+@@ -110,19 +110,8 @@
+ }
+ else if (!bHome && sHomeProperty.equals(i->first))
+ {
+- OUString fileURL;
+- if (osl_getFileURLFromSystemPath(i->second.pData,& fileURL.pData) ==
+- osl_File_E_None)
+- {
+- //make sure that the drive letter have all the same case
+- //otherwise file:///c:/jre and file:///C:/jre produce two
+- //different objects!!!
+- if (makeDriveLetterSame( & fileURL))
+- {
+- m_sHome = fileURL;
+- bHome = true;
+- }
+- }
++ m_sHome = i->second;
++ bHome = true;
+ }
+ else if (!bAccess && sAccessProperty.equals(i->first))
+ {