aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice.org-3-devel
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2006-09-25 08:56:01 +0000
committerMaho Nakata <maho@FreeBSD.org>2006-09-25 08:56:01 +0000
commitfd6a9c860a11b5133eab0eb35f09f6b4278f4696 (patch)
tree75b3be78927c166b1f3d6b5ca0edba356e8ddd3b /editors/openoffice.org-3-devel
parent7f387e66d948865451b8695e46f9616c5defc6cf (diff)
downloadports-fd6a9c860a11b5133eab0eb35f09f6b4278f4696.tar.gz
ports-fd6a9c860a11b5133eab0eb35f09f6b4278f4696.zip
Update to SRC680_m185, better patch to #i69469#[1]
Submitted by: jkim[1]
Notes
Notes: svn path=/head/; revision=173782
Diffstat (limited to 'editors/openoffice.org-3-devel')
-rw-r--r--editors/openoffice.org-3-devel/Makefile4
-rw-r--r--editors/openoffice.org-3-devel/distinfo6
-rw-r--r--editors/openoffice.org-3-devel/files/patch-i6946949
3 files changed, 42 insertions, 17 deletions
diff --git a/editors/openoffice.org-3-devel/Makefile b/editors/openoffice.org-3-devel/Makefile
index 3552e7e0ebaa..c58eb1f674c3 100644
--- a/editors/openoffice.org-3-devel/Makefile
+++ b/editors/openoffice.org-3-devel/Makefile
@@ -75,9 +75,9 @@ IGNORE= install lang/perl5.8 then try again
CODELINE= 680
RELEASE_NR= 2.0
-MILESTONE?= 184
+MILESTONE?= 185
OOOTAG?= SRC680_m${MILESTONE}
-SNAPDATE= 20060915
+SNAPDATE= 20060919
INSTALLATION_BASEDIR?= openoffice.org-${OOOTAG}
EXECBASE?= openoffice.org-${OOOTAG}
DIST_SUBDIR= openoffice.org2.0
diff --git a/editors/openoffice.org-3-devel/distinfo b/editors/openoffice.org-3-devel/distinfo
index 9471d0e78de4..9049f681919a 100644
--- a/editors/openoffice.org-3-devel/distinfo
+++ b/editors/openoffice.org-3-devel/distinfo
@@ -1,6 +1,6 @@
-MD5 (openoffice.org2.0/OOo_SRC680_m184_source.tar.bz2) = e9dc233a1433bf834fac55601872300d
-SHA256 (openoffice.org2.0/OOo_SRC680_m184_source.tar.bz2) = 086d5925d32830731001e471c76a1d204ab816fc926494a347c3817e367e75eb
-SIZE (openoffice.org2.0/OOo_SRC680_m184_source.tar.bz2) = 267956144
+MD5 (openoffice.org2.0/OOo_SRC680_m185_source.tar.bz2) = b604f6cf5d6931d2628c5f6ba0825e03
+SHA256 (openoffice.org2.0/OOo_SRC680_m185_source.tar.bz2) = 74401ca1469833abde44846e76186f73442e2e0266903ddcd7b5a750a9cb0e27
+SIZE (openoffice.org2.0/OOo_SRC680_m185_source.tar.bz2) = 267957938
MD5 (openoffice.org2.0/unowinreg.dll) = e3a0b76dcd876f3d721ee7183729153d
SHA256 (openoffice.org2.0/unowinreg.dll) = f563e522922133db9340b0306711c2d8767cc3481dd9e7d9b0d059906d12653c
SIZE (openoffice.org2.0/unowinreg.dll) = 6144
diff --git a/editors/openoffice.org-3-devel/files/patch-i69469 b/editors/openoffice.org-3-devel/files/patch-i69469
index 0aa01b88ae70..e55b3b80ac85 100644
--- a/editors/openoffice.org-3-devel/files/patch-i69469
+++ b/editors/openoffice.org-3-devel/files/patch-i69469
@@ -1,20 +1,45 @@
---- sw/source/core/doc/docfld.cxx.orig Tue Aug 15 00:57:08 2006
-+++ sw/source/core/doc/docfld.cxx Sun Sep 17 06:16:58 2006
+--- sw/inc/IDocumentFieldsAccess.hxx.orig Mon Aug 14 11:12:27 2006
++++ sw/inc/IDocumentFieldsAccess.hxx Thu Sep 21 18:10:10 2006
+@@ -189,7 +189,7 @@
+ SwNode (see parameter pChk) is (?) part of the private
+ data structure of SwDoc and should not be exposed
+ */
+- virtual bool SetFieldsDirty(bool b, const SwNode* pChk, sal_uInt32 nLen) = 0;
++ virtual bool SetFieldsDirty(bool b, const SwNode* pChk, ULONG nLen) = 0;
+
+ /**
+ */
+@@ -200,7 +200,7 @@
+ // eine erzeugte Liste aller Felder mit uebergegeben werden.
+ // (ist die Adresse != 0, und der Pointer == 0 wird eine neue
+ // Liste returnt.)
+- virtual void FldsToCalc(SwCalc& rCalc, sal_uInt32 nLastNd, sal_uInt16 nLastCntnt) = 0;
++ virtual void FldsToCalc(SwCalc& rCalc, ULONG nLastNd, sal_uInt16 nLastCnt) = 0;
+
+ /**
+ */
+--- sw/inc/doc.hxx.orig Thu Sep 21 18:11:45 2006
++++ sw/inc/doc.hxx Thu Sep 21 18:11:01 2006
+@@ -838,9 +838,9 @@
+ virtual void UnlockExpFlds();
+ virtual bool IsExpFldsLocked() const;
+ virtual SwDocUpdtFld& GetUpdtFlds() const;
+- virtual bool SetFieldsDirty(bool b, const SwNode* pChk, sal_uInt32 nLen);
++ virtual bool SetFieldsDirty(bool b, const SwNode* pChk, ULONG nLen);
+ virtual void SetFixFields(bool bOnlyTimeDate, const DateTime* pNewDateTime);
+- virtual void FldsToCalc(SwCalc& rCalc, sal_uInt32 nLastNd, sal_uInt16 nLastCntnt);
++ virtual void FldsToCalc(SwCalc& rCalc, ULONG nLastNd, sal_uInt16 nLastCnt);
+ virtual void FldsToCalc(SwCalc& rCalc, const _SetGetExpFld& rToThisFld);
+ virtual void FldsToExpand(SwHash**& ppTbl, sal_uInt16& rTblSize, const _SetGetExpFld& rToThisFld);
+ virtual bool IsNewFldLst() const;
+--- sw/source/core/doc/docfld.cxx.orig Thu Sep 21 17:49:14 2006
++++ sw/source/core/doc/docfld.cxx Thu Sep 21 12:36:17 2006
@@ -1223,7 +1223,7 @@
pMgr->CloseAll(FALSE);
}
-void SwDoc::FldsToCalc( SwCalc& rCalc, ULONG nLastNd, USHORT nLastCnt )
-+void SwDoc::FldsToCalc( SwCalc& rCalc, sal_uInt32 nLastNd, sal_uInt16 nLastCnt )
++void SwDoc::FldsToCalc( SwCalc& rCalc, ULONG nLastNd, sal_uInt16 nLastCnt )
{
// erzeuge die Sortierteliste aller SetFelder
pUpdtFlds->MakeFldList( *this, mbNewFldLst, GETFLD_CALC );
-@@ -2243,7 +2243,7 @@
- ResetModified();
- }
-
--bool SwDoc::SetFieldsDirty( bool b, const SwNode* pChk, ULONG nLen )
-+bool SwDoc::SetFieldsDirty( bool b, const SwNode* pChk, sal_uInt32 nLen )
- {
- // teste ggfs. mal, ob die angegbenen Nodes ueberhaupt Felder beinhalten.
- // wenn nicht, braucht das Flag nicht veraendert werden.