aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice.org-vcltesttool/Makefile
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2008-08-06 12:21:29 +0000
committerMaho Nakata <maho@FreeBSD.org>2008-08-06 12:21:29 +0000
commit8fb1d78ca318dde34cfc6abf364ac74415dc0c80 (patch)
tree64f6a45253dfe1e47fc6e2482ba8f18a692249e9 /editors/openoffice.org-vcltesttool/Makefile
parent3b4790d21a19c14d39a5c921afa5a3881bab5a27 (diff)
downloadports-8fb1d78ca318dde34cfc6abf364ac74415dc0c80.tar.gz
ports-8fb1d78ca318dde34cfc6abf364ac74415dc0c80.zip
Use stock gcc for FreeBSD 6.
Notes
Notes: svn path=/head/; revision=218133
Diffstat (limited to 'editors/openoffice.org-vcltesttool/Makefile')
-rw-r--r--editors/openoffice.org-vcltesttool/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/editors/openoffice.org-vcltesttool/Makefile b/editors/openoffice.org-vcltesttool/Makefile
index 96ea44c634f6..0850893b4f1f 100644
--- a/editors/openoffice.org-vcltesttool/Makefile
+++ b/editors/openoffice.org-vcltesttool/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= openoffice.org
PORTVERSION?= 2.4.${SNAPDATE}
-PORTREVISION?= 3
+PORTREVISION?= 4
PORTEPOCH?= 1
CATEGORIES+= editors java
MASTER_SITES+= http://ooopackages.good-day.net/pub/OpenOffice.org/sources/ \
@@ -107,11 +107,6 @@ PKGNAMESUFFIX= -${LANG_SUFFIX}
RUN_DEPENDS+= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
-USE_GCC= 4.2
-#following part should sync with ports/Mk/bsd.gcc.mk
-.if (${OSVERSION} >= 700042)
-CONFIGURE_ARGS+= --with-system-stdlibs
-.endif
.if defined(WITH_CCACHE)
BUILD_DEPENDS+= ccache:${PORTSDIR}/devel/ccache
CCACHE_PREFIX= ccache
@@ -153,7 +148,9 @@ CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp \
--with-gnu-patch=${LOCALBASE}/bin/gpatch \
--enable-crashdump=yes \
--with-system-zlib \
+ --with-system-stdlibs \
--with-epm=internal
+
.if ${ARCH} == amd64
WITHOUT_MOZILLA= yes
LIB_DEPENDS+= boost_regex:${PORTSDIR}/devel/boost