aboutsummaryrefslogtreecommitdiff
path: root/editors/pdfedit/files
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-12-21 02:41:03 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-12-21 02:41:03 +0000
commit5ed0ddb490e2d887fe30db24ae2c0931dceedee0 (patch)
tree9b108f15e4ce6cc39cee3d00e64e81448797a805 /editors/pdfedit/files
parent4d648ade2db70db99eccc711b4eb7a2161e62cbb (diff)
downloadports-5ed0ddb490e2d887fe30db24ae2c0931dceedee0.tar.gz
ports-5ed0ddb490e2d887fe30db24ae2c0931dceedee0.zip
Free editor for manipulating PDF documents. GUI version + commandline
interface. Scripting is used to a great extent in editor and almost anything can be scripted, it is possible to create own scripts or plugins. Target platform are operating systems of Unix type (Linux, BSD, ...), we are using C++, XPDF, QT3 and QSA. WWW: http://pdfedit.petricek.net/
Notes
Notes: svn path=/head/; revision=204239
Diffstat (limited to 'editors/pdfedit/files')
-rw-r--r--editors/pdfedit/files/patch-config.pro.in.in12
-rw-r--r--editors/pdfedit/files/patch-src__gui__pdfedit.pro11
-rw-r--r--editors/pdfedit/files/patch-src__utils__Makefile15
3 files changed, 38 insertions, 0 deletions
diff --git a/editors/pdfedit/files/patch-config.pro.in.in b/editors/pdfedit/files/patch-config.pro.in.in
new file mode 100644
index 000000000000..50f6c0765019
--- /dev/null
+++ b/editors/pdfedit/files/patch-config.pro.in.in
@@ -0,0 +1,12 @@
+--- ./config.pro.in.in.orig Mon Apr 23 13:36:32 2007
++++ ./config.pro.in.in Thu May 3 14:32:03 2007
+@@ -4,6 +4,8 @@
+ DATA_PATH = @datadir@/pdfedit
+ DOC_PATH = @datadir@/doc/pdfedit
+ MAN_PATH = @mandir@/man1
+-BIN_PATH = @bindir@
++E_RELEASE = @enable_release@
++
++include($$QMAKESPEC/qmake.conf)
+ E_RELEASE = @enable_release@
+ QTVERSION = qt3
diff --git a/editors/pdfedit/files/patch-src__gui__pdfedit.pro b/editors/pdfedit/files/patch-src__gui__pdfedit.pro
new file mode 100644
index 000000000000..72ea27a3362d
--- /dev/null
+++ b/editors/pdfedit/files/patch-src__gui__pdfedit.pro
@@ -0,0 +1,11 @@
+--- ./src/gui/pdfedit.pro.orig Sun Apr 29 14:28:52 2007
++++ ./src/gui/pdfedit.pro Thu May 3 15:00:01 2007
+@@ -240,7 +240,7 @@
+ }
+
+ #OutputDevice
+-LIBS += -lqoutputdevices -L../kpdf-kde-3.3.2
++LIBS += -lqoutputdevices -L../kpdf-kde-3.3.2 -L$$LOCALBASE/lib -lt1
+
+ include(../kernel/kernel-obj.pro)
+
diff --git a/editors/pdfedit/files/patch-src__utils__Makefile b/editors/pdfedit/files/patch-src__utils__Makefile
new file mode 100644
index 000000000000..86f3ea7039c1
--- /dev/null
+++ b/editors/pdfedit/files/patch-src__utils__Makefile
@@ -0,0 +1,15 @@
+--- ./src/utils/Makefile.orig Fri Apr 13 12:08:02 2007
++++ ./src/utils/Makefile Thu May 3 14:32:03 2007
+@@ -18,10 +18,10 @@
+
+ AR = ar cqs
+ DEL_FILE = rm -f
+-CXX = g++
++CXX ?= g++
+ LEX = flex
+ YACC = yacc
+-CXXFLAGS = -pipe -Wall -W -Wconversion -Wcast-qual -Wwrite-strings -ansi -pedantic -Wno-unused-variable -Wunused-function -D_REENTRANT $(UTIL_CXXFLAGS)
++CXXFLAGS += -pipe -Wall -W -Wconversion -Wcast-qual -Wwrite-strings -ansi -pedantic -Wno-unused-variable -Wunused-function -D_REENTRANT $(UTIL_CXXFLAGS)
+ INCPATH = -I./ -I../ -I../xpdf/ -I../xpdf/xpdf -I../xpdf/goo -I../xpdf/splash -I../xpdf/fofi
+
+ .SUFFIXES: .o .cc