aboutsummaryrefslogtreecommitdiff
path: root/editors/psgml
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2005-05-12 20:27:09 +0000
committerHiroki Sato <hrs@FreeBSD.org>2005-05-12 20:27:09 +0000
commite031c0ac38057657579b059744aa651cc9f51335 (patch)
treeafeb2e1ef304c4cb3496a7c079fc4140246898d8 /editors/psgml
parent78eb4756a791139d5e0f69404c000643efb03612 (diff)
downloadports-e031c0ac38057657579b059744aa651cc9f51335.tar.gz
ports-e031c0ac38057657579b059744aa651cc9f51335.zip
- Change the install directory to Emacs version specific ones[1].
Bump PORTREVISION. - Clean up the slave ports[1]. - Mark as BROKEN for ia64[2]. PR[1]: ports/80644 Based on work by[1]: KIMURA Yasuhiro Reported from[2]: pointyhat
Notes
Notes: svn path=/head/; revision=135154
Diffstat (limited to 'editors/psgml')
-rw-r--r--editors/psgml/Makefile32
-rw-r--r--editors/psgml/files/psgml-startup.el.in2
-rw-r--r--editors/psgml/pkg-descr11
-rw-r--r--editors/psgml/pkg-plist48
-rw-r--r--editors/psgml/scripts/configure12
5 files changed, 46 insertions, 59 deletions
diff --git a/editors/psgml/Makefile b/editors/psgml/Makefile
index 0868a7bd7947..13e6af17ac0c 100644
--- a/editors/psgml/Makefile
+++ b/editors/psgml/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= psgml
-PORTVERSION= ${PSGML_VER}
-PORTREVISION= 0
+PORTVERSION= 1.3.2
+PORTREVISION= 1
CATEGORIES= editors elisp
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= psgml
@@ -22,18 +22,22 @@ COMMENT?= A major mode for editing SGML and XML documents for emacs21
INFO= psgml psgml-api
-# distfile version
-PSGML_VER= 1.3.2
PSGML_STARTUPEL= psgml-startup.el
-SCRIPTS_ENV= TARGETS="${PSGML_STARTUPEL}" SED=${SED}
-PLIST_SUB= PSGML_STARTUPEL=${PSGML_STARTUPEL}
+SUB_FILES= ${PSGML_STARTUPEL}
+SUB_LIST= PSGML_LISPDIR=${PSGML_LISPDIR}
+PLIST_SUB= PSGML_STARTUPEL=${PSGML_STARTUPEL}
+NOT_FOR_ARCHS= ia64
# This is a master port.
-PORTCLASS?= master
+EMACS_PORT_NAME?= emacs21
-.if (${PORTCLASS} == "master")
-EMACS_PORT_NAME= emacs21
+.if ${EMACS_PORT_NAME} == xemacs21-mule
+PLIST_SUB+= XEMACS="" \
+ NON_XEMACS="@comment "
+.else
+PLIST_SUB+= XEMACS="@comment " \
+ NON_XEMACS=""
.endif
.include <bsd.port.pre.mk>
@@ -42,9 +46,10 @@ EMACS_PORT_NAME= emacs21
# emacs ports setup
#
.if defined(EMACS_PORT_NAME)
+PSGML_LISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/psgml
GNU_CONFIGURE= YES
-CONFIGURE_ARGS= --lispdir=${LOCALBASE}/${EMACS_LIBDIR}/site-lisp/psgml \
- --infodir=${LOCALBASE}/info
+CONFIGURE_ARGS= --lispdir=${PSGML_LISPDIR} \
+ --infodir=${PREFIX}/${INFO_PATH}
CONFIGURE_ENV= EMACS=${EMACS_CMD}
.else
.BEGIN:
@@ -53,12 +58,9 @@ CONFIGURE_ENV= EMACS=${EMACS_CMD}
@${FALSE}
.endif
-pre-configure:
- ${CP} ${FILESDIR}/${PSGML_STARTUPEL}.in ${WRKDIR}
-
post-install:
cd ${WRKSRC} && ${MAKE} install-info
${INSTALL_DATA} ${WRKDIR}/${PSGML_STARTUPEL} \
- ${LOCALBASE}/${EMACS_LIBDIR}/site-lisp
+ ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}
.include <bsd.port.post.mk>
diff --git a/editors/psgml/files/psgml-startup.el.in b/editors/psgml/files/psgml-startup.el.in
index f3ee1aae70b8..0f4e53f7fe27 100644
--- a/editors/psgml/files/psgml-startup.el.in
+++ b/editors/psgml/files/psgml-startup.el.in
@@ -6,7 +6,7 @@
;; setup load-path
(if (not (fboundp 'normal-top-level-add-subdirs-to-load-path))
(setq load-path (append '(
- "@@PREFIX@@/@@EMACS_LIBDIR@@/site-lisp/psgml"
+ "%%PSGML_LISPDIR%%"
) load-path)))
(defalias 'sgml-mode 'psgml-mode)
diff --git a/editors/psgml/pkg-descr b/editors/psgml/pkg-descr
index 33e24d70287f..e2365c131fcd 100644
--- a/editors/psgml/pkg-descr
+++ b/editors/psgml/pkg-descr
@@ -1,7 +1,3 @@
-PSGML: a major mode for editing SGML and XML documents for emacs21.
-
---- Emacs Library Porting
-
PSGML is a major mode for editing SGML and XML documents. It works
with GNU Emacs 19.34, 20.3 and later or with XEmacs 19.9 and later.
PSGML contains a simple SGML parser and can work with any DTD.
@@ -10,13 +6,12 @@ only the contextually valid tags, identification of structural errors,
editing of attribute values in a separate window with information about
types and defaults, and structure based editing.
- PSGML is installed the following directory tree:
- ${PREFIX}/share/emacs/site-lisp/psgml/
-
To use psgml, put the following setup into your ~/.emacs:
(require 'psgml-startup)
---- Porting by shige <shige@FreeBSD.ORG>.
+Ports of PSGML are initially created by shige <shige@FreeBSD.org> and
+kuriyama@FreeBSD.ORG.
+
WWW: http://www.lysator.liu.se/~lenst/about_psgml/
WWW: http://sourceforge.net/projects/psgml/
diff --git a/editors/psgml/pkg-plist b/editors/psgml/pkg-plist
index 4de78cc58933..8cc41cb5f455 100644
--- a/editors/psgml/pkg-plist
+++ b/editors/psgml/pkg-plist
@@ -1,24 +1,26 @@
@comment $FreeBSD$
-%%EMACS_LIBDIR%%/site-lisp/psgml/iso88591.map
-%%EMACS_LIBDIR%%/site-lisp/psgml/psgml-api.el
-%%EMACS_LIBDIR%%/site-lisp/psgml/psgml-api.elc
-%%EMACS_LIBDIR%%/site-lisp/psgml/psgml-charent.el
-%%EMACS_LIBDIR%%/site-lisp/psgml/psgml-charent.elc
-%%EMACS_LIBDIR%%/site-lisp/psgml/psgml-dtd.el
-%%EMACS_LIBDIR%%/site-lisp/psgml/psgml-dtd.elc
-%%EMACS_LIBDIR%%/site-lisp/psgml/psgml-edit.el
-%%EMACS_LIBDIR%%/site-lisp/psgml/psgml-edit.elc
-%%EMACS_LIBDIR%%/site-lisp/psgml/psgml-ids.el
-%%EMACS_LIBDIR%%/site-lisp/psgml/psgml-ids.elc
-%%EMACS_LIBDIR%%/site-lisp/psgml/psgml-info.el
-%%EMACS_LIBDIR%%/site-lisp/psgml/psgml-info.elc
-%%EMACS_LIBDIR%%/site-lisp/psgml/psgml-other.el
-%%EMACS_LIBDIR%%/site-lisp/psgml/psgml-other.elc
-%%EMACS_LIBDIR%%/site-lisp/psgml/psgml-parse.el
-%%EMACS_LIBDIR%%/site-lisp/psgml/psgml-parse.elc
-%%EMACS_LIBDIR%%/site-lisp/psgml/psgml-sysdep.el
-%%EMACS_LIBDIR%%/site-lisp/psgml/psgml-sysdep.elc
-%%EMACS_LIBDIR%%/site-lisp/psgml/psgml.el
-%%EMACS_LIBDIR%%/site-lisp/psgml/psgml.elc
-%%EMACS_LIBDIR%%/site-lisp/%%PSGML_STARTUPEL%%
-@dirrm %%EMACS_LIBDIR%%/site-lisp/psgml
+%%EMACS_VERSION_SITE_LISPDIR%%/psgml/iso88591.map
+%%EMACS_VERSION_SITE_LISPDIR%%/psgml/psgml-api.el
+%%EMACS_VERSION_SITE_LISPDIR%%/psgml/psgml-api.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/psgml/psgml-charent.el
+%%EMACS_VERSION_SITE_LISPDIR%%/psgml/psgml-charent.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/psgml/psgml-dtd.el
+%%EMACS_VERSION_SITE_LISPDIR%%/psgml/psgml-dtd.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/psgml/psgml-edit.el
+%%EMACS_VERSION_SITE_LISPDIR%%/psgml/psgml-edit.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/psgml/psgml-ids.el
+%%EMACS_VERSION_SITE_LISPDIR%%/psgml/psgml-ids.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/psgml/psgml-info.el
+%%EMACS_VERSION_SITE_LISPDIR%%/psgml/psgml-info.elc
+%%NON_XEMACS%%%%EMACS_VERSION_SITE_LISPDIR%%/psgml/psgml-other.el
+%%NON_XEMACS%%%%EMACS_VERSION_SITE_LISPDIR%%/psgml/psgml-other.elc
+%%XEMACS%%%%EMACS_VERSION_SITE_LISPDIR%%/psgml/psgml-lucid.el
+%%XEMACS%%%%EMACS_VERSION_SITE_LISPDIR%%/psgml/psgml-lucid.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/psgml/psgml-parse.el
+%%EMACS_VERSION_SITE_LISPDIR%%/psgml/psgml-parse.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/psgml/psgml-sysdep.el
+%%EMACS_VERSION_SITE_LISPDIR%%/psgml/psgml-sysdep.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/psgml/psgml.el
+%%EMACS_VERSION_SITE_LISPDIR%%/psgml/psgml.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/%%PSGML_STARTUPEL%%
+@dirrm %%EMACS_VERSION_SITE_LISPDIR%%/psgml
diff --git a/editors/psgml/scripts/configure b/editors/psgml/scripts/configure
index 589c62fd0e78..e69de29bb2d1 100644
--- a/editors/psgml/scripts/configure
+++ b/editors/psgml/scripts/configure
@@ -1,12 +0,0 @@
-#!/bin/sh
-
-for i in ${TARGETS}
-do
- if [ -f ${WRKDIR}/${i}.in ]; then
- cat ${WRKDIR}/${i}.in | ${SED} \
- -e "s;@@PREFIX@@;${PREFIX};g" \
- -e "s;@@EMACS_LIBDIR@@;${EMACS_LIBDIR};g" \
- -e "s;@@EMACS_VER@@;${EMACS_VER};g" \
- > ${WRKDIR}/${i}
- fi
-done