aboutsummaryrefslogtreecommitdiff
path: root/editors/rospell
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-30 00:53:22 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-30 00:53:22 +0000
commitc11a3b5dbe060fb142d848310a360e9608d30f11 (patch)
tree1f87ad8e4518bff871b2e2aab29e99f6e7ada472 /editors/rospell
parent2769f0eabcca687c1930f449b1136e79e1ce4bca (diff)
downloadports-c11a3b5dbe060fb142d848310a360e9608d30f11.tar.gz
ports-c11a3b5dbe060fb142d848310a360e9608d30f11.zip
[MAINTAINER] editors/rospell: fix build on 4.x
4.x make doesn't know what BSDmakefile is so tekk it what to use. Remove HAS_CONFIGURE= yes because we don't use distributed ./configure At the end, it still failed on 4.x. A short discussion with the submitter ended up in a "let's keep it broken on 4.x" PR: ports/89740 Submitted by: Ion-Mihai Tetcu <itetcu@people.tecnik93.com>
Notes
Notes: svn path=/head/; revision=149987
Diffstat (limited to 'editors/rospell')
-rw-r--r--editors/rospell/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/editors/rospell/Makefile b/editors/rospell/Makefile
index c48050fff736..75b93bdf85d7 100644
--- a/editors/rospell/Makefile
+++ b/editors/rospell/Makefile
@@ -20,7 +20,7 @@ USE_QT_VER= 3
MAKE_ENV+= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} PTHREAD_LIBS=${PTHREAD_LIBS}
CONFIGURE_ENV= QTDIR=${X11BASE} LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
-HAS_CONFIGURE= yes
+MAKEFILE= BSDmakefile
MAN1= rospell.1
@@ -30,10 +30,13 @@ MAN1= rospell.1
IGNORE= doesn't compile properly on 4.x systems
.endif
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} -f ${MAKEFILE} dictfiles.h
+
do-build:
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE}
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} -f ${MAKEFILE} ${ALL_TARGET}
do-install:
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} install
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} -f ${MAKEFILE} ${INSTALL_TARGET}
.include <bsd.port.post.mk>