aboutsummaryrefslogtreecommitdiff
path: root/editors/rox-edit
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2009-11-11 22:12:13 +0000
committerKris Moore <kmoore@FreeBSD.org>2009-11-11 22:12:13 +0000
commitce2a8e76499424f03516ad75bfecedfc496e958d (patch)
tree6b22e1971c577a6ecbf48f01527f57ed2ca7f5ca /editors/rox-edit
parent581eba9bb29ec1254750351da359f075c9146702 (diff)
downloadports-ce2a8e76499424f03516ad75bfecedfc496e958d.tar.gz
ports-ce2a8e76499424f03516ad75bfecedfc496e958d.zip
- Fix runtime issues when using CUSTOM prefix
PR: 139647 Submitted by: myself Approved by: Maintainer Timeout Approved by: miwi (mentor)
Notes
Notes: svn path=/head/; revision=244136
Diffstat (limited to 'editors/rox-edit')
-rw-r--r--editors/rox-edit/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/editors/rox-edit/Makefile b/editors/rox-edit/Makefile
index 228274c429ae..c9f7b3ed26c7 100644
--- a/editors/rox-edit/Makefile
+++ b/editors/rox-edit/Makefile
@@ -28,6 +28,11 @@ do-build:
@${PYTHON_CMD} -m compileall ${WRKSRC}
@${PYTHON_CMD} -O -m compileall ${WRKSRC}
+pre-install:
+ @${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
+ ${WRKSRC}/Edit/findrox.py
+ @${FIND} ${WRKSRC} -name *.bak | ${XARGS} ${RM}
+
do-install:
@${MKDIR} ${PREFIX}/apps
@${CP} -r ${WRKSRC}/Edit ${PREFIX}/apps/