aboutsummaryrefslogtreecommitdiff
path: root/editors/semi/Makefile
diff options
context:
space:
mode:
authorShigeyuki Fukushima <shige@FreeBSD.org>2001-12-03 15:17:41 +0000
committerShigeyuki Fukushima <shige@FreeBSD.org>2001-12-03 15:17:41 +0000
commit88bf41c9fc7bd946f4abd364549e99e93a9b7816 (patch)
tree5381a44060024cd512f66f0bb8fc45f411172a81 /editors/semi/Makefile
parent7a93a41411f23952888354526e4268e29b8204de (diff)
downloadports-88bf41c9fc7bd946f4abd364549e99e93a9b7816.tar.gz
ports-88bf41c9fc7bd946f4abd364549e99e93a9b7816.zip
New master/slave scheme for semi-1.14.x ports.
Update master port to emacs21. Update slave ports to stub port: semi-emacs20, semi-xemacs21-mule. Does not support semi-emacs(19) and semi-mule for semi-1.14.x or later. Change some style.
Notes
Notes: svn path=/head/; revision=50969
Diffstat (limited to 'editors/semi/Makefile')
-rw-r--r--editors/semi/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/editors/semi/Makefile b/editors/semi/Makefile
index 87e41e06d1cf..eeba489b89d7 100644
--- a/editors/semi/Makefile
+++ b/editors/semi/Makefile
@@ -32,10 +32,14 @@ SEMI_LISPDIR= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}
SEMI_VERSION_SPECIFIC_LISPDIR= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}
.if (${PORTCLASS} == "master")
-# emacs port setup
-EMACS_PORT_NAME= emacs20
+EMACS_PORT_NAME= emacs21
+DEPPORT_SUFFIX=
+.else
+DEPPORT_SUFFIX= -${EMACS_PORT_NAME}
.endif
+EMACS_MASTERDIR_PKGFILES=YES
+
# target name for make build
ALL_TARGET?= elc
# environments
@@ -48,8 +52,8 @@ MAKE_ARGS+= PREFIX="${LOCALBASE}" \
.if defined(EMACS_PORT_NAME)
# depends on flim
-BUILD_DEPENDS+= ${LOCALBASE}/share/flim/${FLIM_COOKIE}:${PORTSDIR}/editors/flim${FLIM_TRUNK:S/.//}-${EMACS_PORT_NAME}
-RUN_DEPENDS+= ${LOCALBASE}/share/flim/${FLIM_COOKIE}:${PORTSDIR}/editors/flim${FLIM_TRUNK:S/.//}-${EMACS_PORT_NAME}
+BUILD_DEPENDS+= ${LOCALBASE}/share/flim/${FLIM_COOKIE}:${PORTSDIR}/editors/flim${DEPPORT_SUFFIX}
+RUN_DEPENDS+= ${LOCALBASE}/share/flim/${FLIM_COOKIE}:${PORTSDIR}/editors/flim${DEPPORT_SUFFIX}
.else
.BEGIN:
@${ECHO} "Error: Bad port."