aboutsummaryrefslogtreecommitdiff
path: root/editors/semi113
diff options
context:
space:
mode:
authorShigeyuki Fukushima <shige@FreeBSD.org>2000-07-12 15:51:49 +0000
committerShigeyuki Fukushima <shige@FreeBSD.org>2000-07-12 15:51:49 +0000
commit6c420154581a1c6ca32213a2818cf903013c2b09 (patch)
treedab99f7f19086362f653b3908d70d27bc0c8f371 /editors/semi113
parent632d31cbaea6f4aca26adec053a1fdc8b2ad72f8 (diff)
downloadports-6c420154581a1c6ca32213a2818cf903013c2b09.tar.gz
ports-6c420154581a1c6ca32213a2818cf903013c2b09.zip
Convert into EMACS_PORT_NAME style port.
Notes
Notes: svn path=/head/; revision=30528
Diffstat (limited to 'editors/semi113')
-rw-r--r--editors/semi113/Makefile101
-rw-r--r--editors/semi113/files/semi-setupel.el.in2
-rw-r--r--editors/semi113/pkg-descr.emacs192
-rw-r--r--editors/semi113/pkg-descr.emacs202
-rw-r--r--editors/semi113/pkg-descr.emacs212
-rw-r--r--editors/semi113/pkg-descr.mule2
-rw-r--r--editors/semi113/scripts/configure2
7 files changed, 41 insertions, 72 deletions
diff --git a/editors/semi113/Makefile b/editors/semi113/Makefile
index f37fae3164a5..0331c6187f95 100644
--- a/editors/semi113/Makefile
+++ b/editors/semi113/Makefile
@@ -5,14 +5,14 @@
# $FreeBSD$
#
-PORTNAME= semi-${EMACS_PORT}
+PORTNAME= semi
PORTVERSION= ${SEMI_VER}
CATEGORIES= editors elisp
MASTER_SITES= ftp://ftp.etl.go.jp/pub/mule/semi/semi-1.13-for-flim-1.13/ \
ftp://ftp.media.kyoto-u.ac.jp/pub/mule/semi/semi-1.13-for-flim-1.13/ \
ftp://ftp.win.or.jp/pub/word/mule/semi/semi-1.13-for-flim-1.13/ \
ftp://ftp.eos.hokudai.ac.jp/pub/GNU/emacs/mule/semi/semi-1.13-for-flim-1.13/
-DISTNAME= semi-${SEMI_VER}
+PKGNAMESUFFIX= -${EMACS_PORT_NAME}
MAINTAINER?= shige@FreeBSD.org
@@ -25,62 +25,33 @@ SEMI_VER= 1.13.7
SEMI_SETUPEL= semi-setupel.el
# document install directory by install-doc target
SEMIDOCDIR?= share/doc/semi
-FLIM_COOKIE= flim-${EMACS_PORT}-${FLIM_VER}.FreeBSD-packages
-SEMI_COOKIE= semi-${EMACS_PORT}-${SEMI_VER}.FreeBSD-packages
+FLIM_COOKIE= flim-${EMACS_PORT_NAME}-${FLIM_VER}.FreeBSD-packages
+SEMI_COOKIE= semi-${EMACS_PORT_NAME}-${SEMI_VER}.FreeBSD-packages
.if (${PORTCLASS} == "master")
# emacs port setup
-EMACS_NAME= emacs
-EMACS_PORT= emacs
-EMACS_VER= 19.34
-EMACS_LIBDIR= share/${EMACS_NAME}
-EMACS_LIBDIR_WITH_VER= ${EMACS_LIBDIR}/${EMACS_VER}
+EMACS_PORT_NAME= emacs
# whether emacs requires *-setupel.el
-REQUIRE_SETUPEL= YES
+REQUIRE_SETUPEL= YES
.endif
# target name for make build
ALL_TARGET?= elc
-
-.if defined(EMACS_PORT)
-EMACS_CMD= ${PREFIX}/bin/${EMACS_NAME}-${EMACS_VER}
-BUILD_DEPENDS+= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT}
-.if defined(HAS_COMMON_PORT) && (${HAS_COMMON_PORT} == "YES")
-RUN_DEPENDS+= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT}-common
-.else
-RUN_DEPENDS= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT}
-.endif
-SCRIPTS_ENV+= EMACS_LIBDIR=${EMACS_LIBDIR} EMACS_VER=${EMACS_VER} \
- EMACS_LIBDIR_WITH_VER=${EMACS_LIBDIR_WITH_VER} \
- EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR} \
- TARGETS="${SEMI_SETUPEL}"
-PLIST_SUB+= EMACS_LIBDIR=${EMACS_LIBDIR} EMACS_VER=${EMACS_VER} \
- EMACS_LIBDIR_WITH_VER=${EMACS_LIBDIR_WITH_VER} \
- EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR} \
- SEMIDOCDIR=${SEMIDOCDIR} SEMI_SETUPEL=${SEMI_SETUPEL} \
+# environments
+SCRIPTS_ENV+= TARGETS="${SEMI_SETUPEL}"
+PLIST_SUB+= SEMIDOCDIR=${SEMIDOCDIR} SEMI_SETUPEL=${SEMI_SETUPEL} \
SEMI_COOKIE=${SEMI_COOKIE}
-MAKE_FLAGS+= EMACS=${EMACS_CMD} XEMACS=${EMACS_CMD}
-.if (${EMACS_VER} == "19.34")
-# depends on custom: emacs-19.34 or mule-19.34
-BUILD_DEPENDS+= ${PREFIX}/${EMACS_LIBDIR_WITH_VER}/site-lisp/custom.el:${PORTSDIR}/editors/custom-${EMACS_PORT}
-RUN_DEPENDS+= ${PREFIX}/${EMACS_LIBDIR_WITH_VER}/site-lisp/custom.el:${PORTSDIR}/editors/custom-${EMACS_PORT}
-.endif
-# depends on apel (case of xemacs-21.x or later)
-.if defined(EMACS_PACKAGESDIR)
-BUILD_DEPENDS+= ${PREFIX}/${EMACS_PACKAGESDIR}/lisp/apel/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT}
-RUN_DEPENDS+= ${PREFIX}/${EMACS_PACKAGESDIR}/lisp/apel/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT}
-.else
-# depends on apel (case of other emacsen etc...)
-BUILD_DEPENDS+= ${PREFIX}/${EMACS_LIBDIR_WITH_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT}
-RUN_DEPENDS+= ${PREFIX}/${EMACS_LIBDIR_WITH_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT}
-.endif
+
+.include <bsd.port.pre.mk>
+
+.if defined(EMACS_PORT_NAME)
# depends on flim
-BUILD_DEPENDS+= ${PREFIX}/share/flim/${FLIM_COOKIE}:${PORTSDIR}/editors/flim-${EMACS_PORT}-current
-RUN_DEPENDS+= ${PREFIX}/share/flim/${FLIM_COOKIE}:${PORTSDIR}/editors/flim-${EMACS_PORT}-current
+BUILD_DEPENDS+= ${LOCALBASE}/share/flim/${FLIM_COOKIE}:${PORTSDIR}/editors/flim-${EMACS_PORT_NAME}-current
+RUN_DEPENDS+= ${LOCALBASE}/share/flim/${FLIM_COOKIE}:${PORTSDIR}/editors/flim-${EMACS_PORT_NAME}-current
.else
.BEGIN:
@${ECHO} "Error: Bad port."
- @${ECHO} "You must define EMACS_NAME, EMACS_PORT, EMACS_VER, EMACS_LIBDIR, EMACS_LIBDIR_WITH_VER."
+ @${ECHO} "You must define EMACS_PORT_NAME."
@${FALSE}
.endif
@@ -94,8 +65,6 @@ pre-configure:
@${CP} ${FILESDIR}/${SEMI_SETUPEL}.in ${WRKDIR}
.endif
-.include <bsd.port.pre.mk>
-
MAKEINFO= makeinfo --no-split --no-validate
MAKEINFO_EMACS= ${EMACS_CMD} -no-site-file -no-init-file -batch
MAKEINFO_EMACS_FLAGS= -e texinfo-format-buffer -f save-buffer
@@ -121,8 +90,8 @@ pre-install:
.endif
post-install:
- @${MKDIR} -p ${PREFIX}/share/semi
- @${TOUCH} ${PREFIX}/share/semi/${SEMI_COOKIE}
+ @${MKDIR} -p ${LOCALBASE}/share/semi
+ @${TOUCH} ${LOCALBASE}/share/semi/${SEMI_COOKIE}
.if defined(REQUIRE_SETUPEL) && (${REQUIRE_SETUPEL} == "YES")
@${MAKE} setupel-install
.endif
@@ -148,7 +117,7 @@ info-build:
${CAT} $${i}.jis | nkf -e > $${i} ; \
${MAKEINFO} $${i} || ${TRUE} ; \
done)
-.if defined(HAS_MULE) && (${HAS_MULE} == "YES")
+.if defined(EMACS_HAS_MULE) && (${EMACS_HAS_MULE} == "YES")
@(cd ${WRKSRC} ; \
for i in mime-ui-ja.texi; do \
${MV} $${i} $${i}.jis ; \
@@ -162,7 +131,7 @@ info-build-by-emacs:
for i in mime-ui-en.texi; do \
${MAKEINFO_EMACS} $${i} ${MAKEINFO_EMACS_FLAGS} || ${TRUE} ; \
done)
-.if defined(HAS_MULE) && (${HAS_MULE} == "YES")
+.if defined(EMACS_HAS_MULE) && (${EMACS_HAS_MULE} == "YES")
@(cd ${WRKSRC} ; \
for i in mime-ui-ja.texi; do \
${MAKEINFO_EMACS} $${i} ${MAKEINFO_EMACS_FLAGS} || ${TRUE} ; \
@@ -176,38 +145,38 @@ pkg-el-copy:
pkg-el-install:
@(if [ -f ${FILESDIR}/_pkg.el ] ; then \
- ${MKDIR} ${PREFIX}/${EMACS_PACKAGESDIR}/lisp/${XEMACS_PKGNAME} ;\
+ ${MKDIR} ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/${XEMACS_PKGNAME} ;\
${INSTALL_DATA} ${FILESDIR}/_pkg.el \
- ${PREFIX}/${EMACS_PACKAGESDIR}/lisp/${XEMACS_PKGNAME}/_pkg.el ;\
+ ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/${XEMACS_PKGNAME}/_pkg.el ;\
fi)
mkdir-site-packages:
@(for i in ${EMACS_PACKAGES_SUBDIRS} ; do \
- ${MKDIR} ${PREFIX}/${EMACS_PACKAGESDIR}/$${i} ; \
+ ${MKDIR} ${LOCALBASE}/${EMACS_PACKAGESDIR}/$${i} ; \
done)
doc-install:
- @${MKDIR} ${PREFIX}/${SEMIDOCDIR}
+ @${MKDIR} ${LOCALBASE}/${SEMIDOCDIR}
@(cd ${WRKSRC} ; \
for i in ChangeLog NEWS README.* TODO VERSION ; do \
- ${INSTALL_DATA} $${i} ${PREFIX}/${SEMIDOCDIR}/ ; \
+ ${INSTALL_DATA} $${i} ${LOCALBASE}/${SEMIDOCDIR}/ ; \
done)
setupel-install:
@${INSTALL_DATA} ${WRKDIR}/${SEMI_SETUPEL} \
- ${PREFIX}/${EMACS_LIBDIR_WITH_VER}/site-lisp
+ ${LOCALBASE}/${EMACS_LIBDIR_WITH_VER}/site-lisp
info-install:
@(cd ${WRKSRC} ; \
for i in mime-ui-en.info; do \
- ${INSTALL_DATA} ${WRKSRC}/$${i} ${PREFIX}/info ; \
- install-info ${PREFIX}/info/$${i} ${PREFIX}/info/dir ; \
+ ${INSTALL_DATA} ${WRKSRC}/$${i} ${LOCALBASE}/info ; \
+ install-info ${LOCALBASE}/info/$${i} ${LOCALBASE}/info/dir ; \
done)
-.if defined(HAS_MULE) && (${HAS_MULE} == "YES")
+.if defined(EMACS_HAS_MULE) && (${EMACS_HAS_MULE} == "YES")
@(cd ${WRKSRC} ; \
for i in mime-ui-ja.info; do \
- ${INSTALL_DATA} ${WRKSRC}/$${i} ${PREFIX}/info ; \
- install-info ${PREFIX}/info/$${i} ${PREFIX}/info/dir ; \
+ ${INSTALL_DATA} ${WRKSRC}/$${i} ${LOCALBASE}/info ; \
+ install-info ${LOCALBASE}/info/$${i} ${LOCALBASE}/info/dir ; \
done)
.endif
@@ -215,12 +184,12 @@ info-package-install:
@(cd ${WRKSRC} ; \
for i in mime-ui-en.info mime-ui-ja.info; do \
${INSTALL_DATA} ${WRKSRC}/$${i} \
- ${PREFIX}/${EMACS_PACKAGESDIR}/info ; \
+ ${LOCALBASE}/${EMACS_PACKAGESDIR}/info ; \
done ; \
- ${MKDIR} -p ${PREFIX}/${EMACS_PACKAGESDIR}/man/semi ; \
+ ${MKDIR} -p ${LOCALBASE}/${EMACS_PACKAGESDIR}/man/semi ; \
for i in mime-ui-en.texi mime-ui-ja.texi; do \
${INSTALL_DATA} ${WRKSRC}/$${i} \
- ${PREFIX}/${EMACS_PACKAGESDIR}/man/semi ; \
+ ${LOCALBASE}/${EMACS_PACKAGESDIR}/man/semi ; \
done)
manifest-install:
@@ -228,6 +197,6 @@ manifest-install:
@${CAT} ${PKGDIR}/PLIST | ${GREP} -e "^%%EMACS_PACKAGESDIR%%" | \
${SED} -e "s;^%%EMACS_PACKAGESDIR%%/;;" > ${WRKDIR}/${MANIFEST}
@${INSTALL_DATA} ${WRKDIR}/${MANIFEST} \
- ${PREFIX}/${EMACS_PACKAGESDIR}/pkginfo/
+ ${LOCALBASE}/${EMACS_PACKAGESDIR}/pkginfo/
.include <bsd.port.post.mk>
diff --git a/editors/semi113/files/semi-setupel.el.in b/editors/semi113/files/semi-setupel.el.in
index 767148046718..7fdd3efd2ae0 100644
--- a/editors/semi113/files/semi-setupel.el.in
+++ b/editors/semi113/files/semi-setupel.el.in
@@ -3,6 +3,6 @@
;; -- by shige@FreeBSD.ORG
(setq load-path (append '(
- "@@PREFIX@@/@@EMACS_LIBDIR@@/site-lisp/semi"
+ "@@LOCALBASE@@/@@EMACS_LIBDIR@@/site-lisp/semi"
) load-path))
(provide 'semi-setupel)
diff --git a/editors/semi113/pkg-descr.emacs19 b/editors/semi113/pkg-descr.emacs19
index 2fde40381c18..6643b26f426b 100644
--- a/editors/semi113/pkg-descr.emacs19
+++ b/editors/semi113/pkg-descr.emacs19
@@ -20,7 +20,7 @@ SEMI, Library of MIME feature for GNU Emacs for emacs.
MUAs. They are released as separated packages.
SEMI is installed the following directory tree:
- ${PREFIX}/share/emacs/site-lisp/semi/ --- SEMI
+ ${LOCALBASE}/share/emacs/site-lisp/semi/ --- SEMI
To use flim, put the following setup into your ~/.emacs:
diff --git a/editors/semi113/pkg-descr.emacs20 b/editors/semi113/pkg-descr.emacs20
index 4730cbddbd85..62b014e02da6 100644
--- a/editors/semi113/pkg-descr.emacs20
+++ b/editors/semi113/pkg-descr.emacs20
@@ -20,6 +20,6 @@ SEMI, Library of MIME feature for GNU Emacs for emacs20.
MUAs. They are released as separated packages.
SEMI is installed the following directory tree:
- ${PREFIX}/share/emacs/site-lisp/semi/ --- SEMI
+ ${LOCALBASE}/share/emacs/site-lisp/semi/ --- SEMI
--- Porting by shige <shige@FreeBSD.ORG>
diff --git a/editors/semi113/pkg-descr.emacs21 b/editors/semi113/pkg-descr.emacs21
index 4730cbddbd85..62b014e02da6 100644
--- a/editors/semi113/pkg-descr.emacs21
+++ b/editors/semi113/pkg-descr.emacs21
@@ -20,6 +20,6 @@ SEMI, Library of MIME feature for GNU Emacs for emacs20.
MUAs. They are released as separated packages.
SEMI is installed the following directory tree:
- ${PREFIX}/share/emacs/site-lisp/semi/ --- SEMI
+ ${LOCALBASE}/share/emacs/site-lisp/semi/ --- SEMI
--- Porting by shige <shige@FreeBSD.ORG>
diff --git a/editors/semi113/pkg-descr.mule b/editors/semi113/pkg-descr.mule
index 0d7de9ab0b4d..e7727d684b63 100644
--- a/editors/semi113/pkg-descr.mule
+++ b/editors/semi113/pkg-descr.mule
@@ -20,7 +20,7 @@ SEMI, Library of MIME feature for GNU Emacs for mule.
MUAs. They are released as separated packages.
SEMI is installed the following directory tree:
- ${PREFIX}/share/emacs/site-lisp/semi/ --- SEMI
+ ${LOCALBASE}/share/emacs/site-lisp/semi/ --- SEMI
To use flim, put the following setup into your ~/.emacs:
diff --git a/editors/semi113/scripts/configure b/editors/semi113/scripts/configure
index 04796ae5df87..083bc7164d33 100644
--- a/editors/semi113/scripts/configure
+++ b/editors/semi113/scripts/configure
@@ -4,7 +4,7 @@ for i in ${TARGETS}
do
if [ -f ${WRKDIR}/${i}.in ]; then
cat ${WRKDIR}/${i}.in | /usr/bin/sed \
- -e "s;@@PREFIX@@;${PREFIX};g" \
+ -e "s;@@LOCALBASE@@;${LOCALBASE};g" \
-e "s;@@EMACS_LIBDIR@@;${EMACS_LIBDIR};g" \
-e "s;@@EMACS_VER@@;${EMACS_VER};g" \
-e "s;@@EMACS_LIBDIR_WITH_VER@@;${EMACS_LIBDIR_WITH_VER};g" \