aboutsummaryrefslogtreecommitdiff
path: root/editors/spe
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-12-05 18:28:40 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-12-05 18:28:40 +0000
commitc0acd64d7353b22fb6f751df482a1a0f44cad2d9 (patch)
treec397faa5b7a445b9f9cd511d540d4ce81ed79193 /editors/spe
parentf18a8cc963d5b0083358a18e96f44ed02b2f439a (diff)
downloadports-c0acd64d7353b22fb6f751df482a1a0f44cad2d9.tar.gz
ports-c0acd64d7353b22fb6f751df482a1a0f44cad2d9.zip
- Update to 0.8.0c
PR: ports/89973 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=150484
Diffstat (limited to 'editors/spe')
-rw-r--r--editors/spe/Makefile9
-rw-r--r--editors/spe/distinfo5
-rw-r--r--editors/spe/pkg-plist6
3 files changed, 16 insertions, 4 deletions
diff --git a/editors/spe/Makefile b/editors/spe/Makefile
index a1d354d37906..fbda54872de7 100644
--- a/editors/spe/Makefile
+++ b/editors/spe/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= SPE
-PORTVERSION= 0.8.0b
+PORTVERSION= 0.8.0c
CATEGORIES= editors devel python
MASTER_SITES= http://download.berlios.de/python/ \
${MASTER_SITE_SOURCEFORGE}
@@ -15,11 +15,13 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:C/[a-z]$/.&/g}-wx2.6.1.0.-bl2.35
MAINTAINER= nivit@email.it
COMMENT= Stani's Python Editor
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/${WX_PYTHON_DIR}/wxPython/_wx.py:${PORTSDIR}/x11-toolkits/py-wxPython26
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/${WX_PYTHON_DIR}/wxPython/_wx.py:${PORTSDIR}/x11-toolkits/py-wxPython26
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+OPTIONS= ENCRYPTED_DEBUG "Enable encrypted debug in SPE" off
+
SPEDOCS= ${PYTHON_SITELIBDIR}/_${PORTNAME:L}/doc
SPEXAMPLES= ${PYTHON_SITELIBDIR}/_${PORTNAME:L}/examples
WINSCRIPT= spe_wininst.py
@@ -49,4 +51,7 @@ WX_PYTHON_DIR= wx-2.6-gtk2-unicode
WX_PYTHON_DIR= wx-2.6-gtk2-ansi
.endif
+.if defined(WITH_ENCRYPTED_DEBUG)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/Crypto/__init__.py:${PORTSDIR}/security/py-pycrypto
+.endif
.include <bsd.port.post.mk>
diff --git a/editors/spe/distinfo b/editors/spe/distinfo
index b786f0d1f9aa..aef618f389b6 100644
--- a/editors/spe/distinfo
+++ b/editors/spe/distinfo
@@ -1,2 +1,3 @@
-MD5 (SPE-0.8.0.b-wx2.6.1.0.-bl2.35.tar.gz) = ecf3bfa9fe7af2511fe3e8ad6b0ca2ac
-SIZE (SPE-0.8.0.b-wx2.6.1.0.-bl2.35.tar.gz) = 1233397
+MD5 (SPE-0.8.0.c-wx2.6.1.0.-bl2.35.tar.gz) = 5e5e67881b615feb32bfc61c29b96408
+SHA256 (SPE-0.8.0.c-wx2.6.1.0.-bl2.35.tar.gz) = 6a87dc675d0c0b39da00cfc832efa70e7e5fd53bea86b58da261dee83c17f4fd
+SIZE (SPE-0.8.0.c-wx2.6.1.0.-bl2.35.tar.gz) = 1267134
diff --git a/editors/spe/pkg-plist b/editors/spe/pkg-plist
index c77ae1d8400c..6fe28eca1b27 100644
--- a/editors/spe/pkg-plist
+++ b/editors/spe/pkg-plist
@@ -834,6 +834,7 @@ bin/spe
%%PYTHON_SITELIBDIR%%/_spe/skins/default/empty.png
%%PYTHON_SITELIBDIR%%/_spe/skins/default/encoding.png
%%PYTHON_SITELIBDIR%%/_spe/skins/default/eraser.png
+%%PYTHON_SITELIBDIR%%/_spe/skins/default/error.gif
%%PYTHON_SITELIBDIR%%/_spe/skins/default/exec.png
%%PYTHON_SITELIBDIR%%/_spe/skins/default/exit.png
%%PYTHON_SITELIBDIR%%/_spe/skins/default/explore.png
@@ -891,6 +892,8 @@ bin/spe
%%PYTHON_SITELIBDIR%%/_spe/skins/default/tab_right.png
%%PYTHON_SITELIBDIR%%/_spe/skins/default/tar.png
%%PYTHON_SITELIBDIR%%/_spe/skins/default/test/index.png
+%%PYTHON_SITELIBDIR%%/_spe/skins/default/throbber.gif
+%%PYTHON_SITELIBDIR%%/_spe/skins/default/throbber_disabled.gif
%%PYTHON_SITELIBDIR%%/_spe/skins/default/thumbnail.png
%%PYTHON_SITELIBDIR%%/_spe/skins/default/todo.png
%%PYTHON_SITELIBDIR%%/_spe/skins/default/uml.png
@@ -921,6 +924,9 @@ bin/spe
%%PYTHON_SITELIBDIR%%/_spe/sm/uml.py
%%PYTHON_SITELIBDIR%%/_spe/sm/uml.pyc
%%PYTHON_SITELIBDIR%%/_spe/sm/uml.pyo
+%%PYTHON_SITELIBDIR%%/_spe/sm/wxp/NotebookCtrl.py
+%%PYTHON_SITELIBDIR%%/_spe/sm/wxp/NotebookCtrl.pyc
+%%PYTHON_SITELIBDIR%%/_spe/sm/wxp/NotebookCtrl.pyo
%%PYTHON_SITELIBDIR%%/_spe/sm/wxp/__init__.py
%%PYTHON_SITELIBDIR%%/_spe/sm/wxp/__init__.pyc
%%PYTHON_SITELIBDIR%%/_spe/sm/wxp/__init__.pyo