aboutsummaryrefslogtreecommitdiff
path: root/editors/teco
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-17 10:26:54 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-17 10:26:54 +0000
commit72ca267a9237ed319247dc608867fe4a2d5040f4 (patch)
tree15775c59ba21c0421a614a3c24d05aea9de9baf4 /editors/teco
parent4645028aea04fdedf1a4f5c56edc9e41bdfac9a7 (diff)
downloadports-72ca267a9237ed319247dc608867fe4a2d5040f4.tar.gz
ports-72ca267a9237ed319247dc608867fe4a2d5040f4.zip
A powerful and compact editor with completely nongrafical user interface.
PR: ports/77565 Submitted by: Stanislav Sedov <stas@core.310.ru>
Notes
Notes: svn path=/head/; revision=129080
Diffstat (limited to 'editors/teco')
-rw-r--r--editors/teco/Makefile39
-rw-r--r--editors/teco/distinfo2
-rw-r--r--editors/teco/files/patch-makefile26
-rw-r--r--editors/teco/files/patch-zlinux32
-rw-r--r--editors/teco/pkg-descr9
-rw-r--r--editors/teco/pkg-message13
-rw-r--r--editors/teco/pkg-plist36
7 files changed, 157 insertions, 0 deletions
diff --git a/editors/teco/Makefile b/editors/teco/Makefile
new file mode 100644
index 000000000000..bafa50d02326
--- /dev/null
+++ b/editors/teco/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: teco
+# Date created: Feb 15 2005
+# Whom: Stanislav Sedov <stas@core.310.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= teco
+PORTVERSION= 0398
+CATEGORIES= editors
+MASTER_SITES= http://almy.us/files/
+DISTNAME= tecoclinux${PORTVERSION}
+
+MAINTAINER= stas@core.310.ru
+COMMENT= Powerful and compact editor with nongrafical user interface
+
+MAKEFILE= makefile
+WRKSRC= ${WRKDIR}/tecoc${PORTVERSION}
+BUILD_WRKSRC= ${WRKSRC}/src
+ALL_TARGET= #
+
+DOCSFILES= src/readme.1st src/readme.lnx src/changes.txt src/aaout.txt \
+ src/problems.txt src/video.txt doc/teco.doc doc/wchart.txt
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/tecoc ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/lib/* ${DATADIR}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for FILE in ${DOCSFILES}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/editors/teco/distinfo b/editors/teco/distinfo
new file mode 100644
index 000000000000..afed974653c0
--- /dev/null
+++ b/editors/teco/distinfo
@@ -0,0 +1,2 @@
+MD5 (tecoclinux0398.tar.gz) = 4667649cd858d8b1acc60024e38a7d70
+SIZE (tecoclinux0398.tar.gz) = 374792
diff --git a/editors/teco/files/patch-makefile b/editors/teco/files/patch-makefile
new file mode 100644
index 000000000000..82e791bad6e5
--- /dev/null
+++ b/editors/teco/files/patch-makefile
@@ -0,0 +1,26 @@
+--- src/makefile.orig Fri May 21 18:26:06 2004
++++ src/makefile Tue Feb 15 03:20:32 2005
+@@ -23,11 +23,11 @@
+ # COMPILE.c macro so it doesn't stick in the -target option, which gcc
+ # doesn't understand.
+
+-CC= gcc
+ #CFLAGS= ${OSVERS} ${DEBG} ${CCHEK} -O -Wall -Wshadow -Wpointer-arith -Wcast-qual -DLINUX
+-CFLAGS= ${OSVERS} ${DEBG} ${CCHEK} -O -DLINUX
++CFLAGS+= -DLINUX
+ #TERMOBJS = -ltermcap
+-COMPILE.c = $(CC) $(CFLAGS) $(CPPFLAGS) -c -g
++COMPILE.c = $(CC) $(CFLAGS) $(CPPFLAGS) -c
++LINK.c = $(CC) $(LDFLAGS)
+
+ #############################################################################
+
+@@ -56,7 +56,7 @@
+ tecoc.o: tecoc.c zport.h tecoc.h deferr.h dchars.h chmacs.h
+
+ clpars.h: genclp clpars.tec
+- genclp
++ ./genclp
+
+ genclp: genclp.o
+ ${LINK.c} -o $@ genclp.o
diff --git a/editors/teco/files/patch-zlinux b/editors/teco/files/patch-zlinux
new file mode 100644
index 000000000000..14d8f2b01dcc
--- /dev/null
+++ b/editors/teco/files/patch-zlinux
@@ -0,0 +1,32 @@
+--- src/zlinux.c.orig Tue Feb 15 20:15:29 2005
++++ src/zlinux.c Tue Feb 15 20:22:42 2005
+@@ -10,7 +10,6 @@
+
+ #include <sys/types.h> /* needed before sys/param.h is included */
+ #include <errno.h> /* define errno */
+-#include <malloc.h> /* malloc() and realloc() */
+ #include <signal.h> /* to catch ^C and ^Z signals */
+ #include <stdio.h> /* define stdin */
+ #include <string.h> /* strncpy(), strlen(), etc. */
+@@ -50,8 +49,6 @@
+
+ static int vernum(); /* see bottom of this file */
+
+-extern int sys_nerr; /* number of system error messages */
+-
+ static int SupGotCtC = 0;
+
+ static glob_t pglob;
+@@ -1057,9 +1054,9 @@
+ * execute imbedded command line-parsing macro directly from clpars[]
+ */
+
+- CStBeg = clpars; /* command string start */
+- CBfPtr = clpars; /* command string start */
+- CStEnd = clpars + CLPARS_LEN; /* command string end */
++ CStBeg = (charptr)clpars; /* command string start */
++ CBfPtr = (charptr)clpars; /* command string start */
++ CStEnd = (charptr)((unsigned int)clpars + CLPARS_LEN); /* command string end */
+ EStTop = EStBot; /* clear expression stack */
+ ExeCSt(); /* execute command string */
+
diff --git a/editors/teco/pkg-descr b/editors/teco/pkg-descr
new file mode 100644
index 000000000000..d893966fed19
--- /dev/null
+++ b/editors/teco/pkg-descr
@@ -0,0 +1,9 @@
+ TECO is the grand old text editor. It is powerful and compact
+precursor to EMACS and has a completely nongraphical user interface.
+It is very fast (probably the fastes editor in the world) and have a
+macro language. TECO was written by Dan Murphy (http://www.opost.com/dlm)
+at Digital Equipment Corporation in 1962. This is based on Pete Siemsen's
+TECOC implementation, and comes with a copy of the originals DECUS TECO
+documentation.
+
+WWW: http://almy.us/teco.html
diff --git a/editors/teco/pkg-message b/editors/teco/pkg-message
new file mode 100644
index 000000000000..05fc6fc295a2
--- /dev/null
+++ b/editors/teco/pkg-message
@@ -0,0 +1,13 @@
+=============================================================================
+
+ Teco takes a first argument of mung, teco or make to control its
+operating mode. Also the name of the executable is tested to provide this
+first argument. The mapping is:
+ teco - tecoc teco
+ Make - tecoc make
+ mung - tecoc mung
+ inspect - tecoc teco -inspect
+
+You can create symlinks for this to work.
+
+=============================================================================
diff --git a/editors/teco/pkg-plist b/editors/teco/pkg-plist
new file mode 100644
index 000000000000..1a583efea236
--- /dev/null
+++ b/editors/teco/pkg-plist
@@ -0,0 +1,36 @@
+bin/tecoc
+%%DATADIR%%/upcase.tec
+%%DATADIR%%/change.tes
+%%DATADIR%%/date.tes
+%%DATADIR%%/detab.tes
+%%DATADIR%%/dir.tes
+%%DATADIR%%/makprnt.tes
+%%DATADIR%%/squ.tes
+%%DATADIR%%/unsqu.tes
+%%DATADIR%%/change.tec
+%%DATADIR%%/checkqr.tec
+%%DATADIR%%/date.tec
+%%DATADIR%%/detab.tec
+%%DATADIR%%/dir.tec
+%%DATADIR%%/lowcase.tec
+%%DATADIR%%/makprnt.tec
+%%DATADIR%%/squ.tec
+%%DATADIR%%/sub.tec
+%%DATADIR%%/tstbsl.tec
+%%DATADIR%%/tstcss.tec
+%%DATADIR%%/tstequ.tec
+%%DATADIR%%/tsto.tec
+%%DATADIR%%/tstqr.tec
+%%DATADIR%%/tstsrc.tec
+%%DATADIR%%/tst.tec
+%%DATADIR%%/unsqu.tec
+%%PORTDOCS%%%%DOCSDIR%%/readme.1st
+%%PORTDOCS%%%%DOCSDIR%%/readme.lnx
+%%PORTDOCS%%%%DOCSDIR%%/changes.txt
+%%PORTDOCS%%%%DOCSDIR%%/aaout.txt
+%%PORTDOCS%%%%DOCSDIR%%/problems.txt
+%%PORTDOCS%%%%DOCSDIR%%/video.txt
+%%PORTDOCS%%%%DOCSDIR%%/teco.doc
+%%PORTDOCS%%%%DOCSDIR%%/wchart.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%