aboutsummaryrefslogtreecommitdiff
path: root/editors/thoteditor/Makefile
diff options
context:
space:
mode:
authorChuck Robey <chuckr@FreeBSD.org>1999-09-27 16:40:53 +0000
committerChuck Robey <chuckr@FreeBSD.org>1999-09-27 16:40:53 +0000
commit141629beba83dbf5b748799ce750a584800fcc44 (patch)
tree104d95f835e2e204050b07d41dcf07c71d50ebd1 /editors/thoteditor/Makefile
parentf9ac924e8e69bafdf9e3a8b14a98c6abe43280c6 (diff)
downloadports-141629beba83dbf5b748799ce750a584800fcc44.tar.gz
ports-141629beba83dbf5b748799ce750a584800fcc44.zip
Finally fix all parts of thoteditor.
Notes
Notes: svn path=/head/; revision=22005
Diffstat (limited to 'editors/thoteditor/Makefile')
-rw-r--r--editors/thoteditor/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/editors/thoteditor/Makefile b/editors/thoteditor/Makefile
index 3289ceaf25d4..3f955eb7e8f7 100644
--- a/editors/thoteditor/Makefile
+++ b/editors/thoteditor/Makefile
@@ -22,9 +22,6 @@ MAINTAINER= chuckr@FreeBSD.org
THOT_SUBDIR= Target
REQUIRES_MOTIF= yes
WRKSRC= $(WRKDIR)/Thot/$(THOT_SUBDIR)
-
-BROKEN= initialization issues not finished yet
-
REQUIRES_MOTIF= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-thot --enable-plugin --without-insure --without-amaya --disable-java --disable-intr --disable-jit --disable-math --disable-ilu
@@ -34,10 +31,16 @@ ALL_TARGET= all schemas
do-configure:
(cd $(WRKSRC);../configure $(CONFIGURE_ARGS))
+post-configure:
+ $(CP) $(WRKSRC)/../thotlib/base/registry.c $(WRKSRC)/../thotlib/base/registry.c.orig
+ $(SED) -e "s&%%PREFIX%%&$(PREFIX)&" <$(WRKSRC)/../thotlib/base/registry.c.orig >$(WRKSRC)/../thotlib/base/registry.c
+
post-extract:
(cd $(WRKDIR)/Thot;$(MKDIR) $(THOT_SUBDIR))
post-install:
${MKDIR} ${PREFIX}/share/thot/doc
+ $(SED) -e "s&%%PREFIX%%&$(PREFIX)&" < $(FILESDIR)/thoteditor > $(WRKDIR)/thoteditor
+ $(INSTALL_SCRIPT) $(WRKDIR)/thoteditor $(PREFIX)/bin
.include <bsd.port.mk>