aboutsummaryrefslogtreecommitdiff
path: root/editors/thoteditor/Makefile
diff options
context:
space:
mode:
authorChuck Robey <chuckr@FreeBSD.org>1999-09-22 04:36:58 +0000
committerChuck Robey <chuckr@FreeBSD.org>1999-09-22 04:36:58 +0000
commit2c344b40d32458463cbb9e9546a05fb492aee1fd (patch)
tree8b02d1646ac22de7db999956f5430416f2cf71ff /editors/thoteditor/Makefile
parent2a848883918eb8bcf7d7c74a8f9254252085299f (diff)
downloadports-2c344b40d32458463cbb9e9546a05fb492aee1fd.tar.gz
ports-2c344b40d32458463cbb9e9546a05fb492aee1fd.zip
This is still badly broken, but this fixes the worst bugs (at least it
gets started, the lib part compiles now). Chief problems were that the configure script was looking for thot in an archive named Thot, and the configure script requires all enables/disables, withs/withouts to be explicitly laid out, else there's a ream of sed errors. Oh, yeah, the WRKSRC had to be explitly created too.
Notes
Notes: svn path=/head/; revision=21876
Diffstat (limited to 'editors/thoteditor/Makefile')
-rw-r--r--editors/thoteditor/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/editors/thoteditor/Makefile b/editors/thoteditor/Makefile
index 402a2cbb207d..4cf4b3d834c6 100644
--- a/editors/thoteditor/Makefile
+++ b/editors/thoteditor/Makefile
@@ -21,6 +21,7 @@ DISTFILES= ${THOT_SRC} ${EDITOR_SRC}
MAINTAINER= chuckr@FreeBSD.org
BROKEN= 'FUBARed'
+WRKSRC= $(WRKDIR)/Thot/objects
THOT_SRC= thot-src-2.1e.tar.gz
EDITOR_SRC= thoteditor-src-2.1e.tar.gz
@@ -28,12 +29,17 @@ EDITOR_SRC= thoteditor-src-2.1e.tar.gz
EXTRACT_ONLY= ${THOT_SRC}
REQUIRES_MOTIF= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-thot --enable-plugin
+USE_GMAKE= yes
+CONFIGURE_ARGS= --with-thot --enable-plugin --without-insure --without-amaya --disable-java --disable-intr --disable-jit --disable-math --disable-ilu
USE_GMAKE= yes
ALL_TARGET= all schemas
+do-configure:
+ (cd $(WRKDIR)/Thot/objects;../configure $(CONFIGURE_ARGS))
+
post-extract:
- (${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${EDITOR_SRC} ${EXTRACT_AFTER_ARGS} -C ${WRKSRC})
+ (${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${EDITOR_SRC} ${EXTRACT_AFTER_ARGS} -C ${WRKDIR}/Thot)
+ (cd $(WRKDIR)/Thot;$(MKDIR) objects)
post-install:
${MKDIR} ${PREFIX}/share/thot/doc