aboutsummaryrefslogtreecommitdiff
path: root/editors/vim5
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2001-02-15 12:47:40 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2001-02-15 12:47:40 +0000
commit0288596190fb486324ebf70c448f72c1a6372ff4 (patch)
tree97620046fca6309cb154c783bb8034abec9db439 /editors/vim5
parent74deb8c73afb031f917e2ac3739269f76bc1e584 (diff)
downloadports-0288596190fb486324ebf70c448f72c1a6372ff4.tar.gz
ports-0288596190fb486324ebf70c448f72c1a6372ff4.zip
Add a "NO_GUI" knob for those that want full features w/o dependence on X.
Submitted by: Peter Pentchev <roam@orbitel.bg> I'm torn between having so many knobs and having the 'vim-lite' be the Right Thing for sysadmins on Xless router boxes. I'm open to opinions on if 'vim-lite' should only mean no X, or it should also mean no interpreters
Notes
Notes: svn path=/head/; revision=38372
Diffstat (limited to 'editors/vim5')
-rw-r--r--editors/vim5/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/editors/vim5/Makefile b/editors/vim5/Makefile
index f80528cb4118..247261cf566a 100644
--- a/editors/vim5/Makefile
+++ b/editors/vim5/Makefile
@@ -57,6 +57,7 @@ LIBS=-lxpg4
MAKE_ARGS+= CONF_OPT_MAX="--enable-max-features"
I18N= CONF_OPT_MULTIBYTE="--enable-multibyte --enable-fontset --enable-xim"
+.if !defined(NO_GUI)
.if defined(WITH_ATHENA)
MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=athena" ${I18N}
#MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=yes" ${I18N}
@@ -67,6 +68,9 @@ MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=gtk --with-gtk-prefix=${X11BASE}" ${I18N}
USE_MOTIF= yes
MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=motif --with-motif-lib=\"${MOTIFLIB}\"" MOTIFHOME=${X11BASE} ${I18N}
.endif
+.else # NO_GUI
+MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=no --without-x --enable-multibyte"
+.endif # NO_GUI
.if defined(PACKAGE_BUILDING)
MAKE_ARGS+= CONF_OPT_PERL="--enable-perlinterp --enable-pythoninterp --enable-tclinterp --enable-cscope"