aboutsummaryrefslogtreecommitdiff
path: root/editors/vim
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2002-09-21 23:49:28 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2002-09-21 23:49:28 +0000
commit4d446a4fadec9be8a37c141ada941567b1466b23 (patch)
tree0d35aaf7959f39806d920172bee1638798c104e4 /editors/vim
parente47e0f59bf6dcec9d78c4c86882ed417f1340ed5 (diff)
downloadports-4d446a4fadec9be8a37c141ada941567b1466b23.tar.gz
ports-4d446a4fadec9be8a37c141ada941567b1466b23.zip
This removes the need for one of the patches for WITH_PERL. I've heard
vague problems with building with WITH_PERL, but I've never been able to get hard evidence. So this patch makes the whole thing OBE. It also uses the new USE_REINPLACE. Approved by: kris (portmgr)
Notes
Notes: svn path=/head/; revision=67025
Diffstat (limited to 'editors/vim')
-rw-r--r--editors/vim/Makefile10
-rw-r--r--editors/vim/files/patch-012
2 files changed, 7 insertions, 5 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 3de2e591059b..4ce7a0ff0f04 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -30,8 +30,6 @@ PATCHFILES:= ${PATCHFILES:N6.1.${p}}
MAINTAINER?= obrien@FreeBSD.org
-BUILD_DEPENDS= perl:${PORTSDIR}/lang/perl5
-
SLAVEDIRS= editors/vim-lite
.if defined(PACKAGE_BUILDING) && !defined(LITE)
@@ -42,6 +40,7 @@ WITH_CSCOPE= yes
.endif
USE_BZIP2= yes
+USE_REINPLACE= yes
DIST_SUBDIR= vim
WRKSRC= ${WRKDIR}/vim${PORTVERSION:C/\.[0-9]*$//:S/.//g}/src
PATCH_DIST_ARGS= -d ${WRKSRC:S/src$//} --forward --quiet -E ${PATCH_DIST_STRIP}
@@ -134,9 +133,12 @@ LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
USE_XLIB= yes
.endif
-pre-build:
+post-patch:
@(cd ${WRKSRC}; ${MAKE} distclean)
- @${PERL} -pi -e 's,8\.2,8.3,' ${WRKSRC}/auto/configure
+ @${REINPLACE_CMD} -e 's|8\.2|8.3|; \
+ s|\$$gtk_config_prefix/bin/gtk-config|\$${GTK_CONFIG}|; \
+ s|\$$gtk_config_exec_prefix/bin/gtk-config|\$${GTK_CONFIG}|' \
+ ${WRKSRC}/auto/configure
post-install:
[ -e ${PREFIX}/bin/gvim ] || (cd ${PREFIX}/bin ; ${LN} -sf vim gvim)
diff --git a/editors/vim/files/patch-01 b/editors/vim/files/patch-01
index 876a0baeb202..d81da2bab293 100644
--- a/editors/vim/files/patch-01
+++ b/editors/vim/files/patch-01
@@ -103,5 +103,5 @@
-@echo 'char_u *default_vimruntime_dir = (char_u *)"$(VIMRUNTIMEDIR)";' >> $@
- -@echo 'char_u *all_cflags = (char_u *)"$(CC) -c -I$(srcdir) $(ALL_CFLAGS)";' >> $@
+ -@echo 'char_u *all_cflags = (char_u *)' >> $@
-+ -@perl -le '$$_ = q|$(CC) -c -I$(srcdir) $(ALL_CFLAGS)|; s/"/\\"/g; print qq|\t"$$_";|' >> $@
++ -@echo '$(CC) -c -I$(srcdir) $(ALL_CFLAGS)' | sed -e 's/\"/\\"/g' -e 's/\(^.*\)/ "\1";/' >> $@
-@echo 'char_u *all_lflags = (char_u *)"$(CC) $(ALL_LIB_DIRS) $(LDFLAGS) -o $(VIMTARGET) $(ALL_LIBS) ";' >> $@